* DANGEROUS * Laser turns ON while homing

edited April 2016 in Bug Reports
Hello Repetier and anyone reading this. 

After finishing my laser machine build, I did the laser control in hardware properly:
  • High signal on Laser Enable pin -> Laser ON
  • Low -> OFF
  • High Impendance state (like when burning the firmware) -> OFF
Of course, during config I set the high signal to enable the laser.
So, I figured out that after enabling the laser with M3 it operates as supposed to on G0 and G1 moves. BUT after these I may want to home the machine (G28), and at this point the laser goes ON again! This is definitely not the behavior you would expect.

I'm sure it is a bug, it is dangerous and needs fixing.

I'm running Repetier V0.92.8
Can post Configuration.h if needed.

Thanks in advance.


  • Homing is a combination of moves, but you are right that would be better to actively disable laser. Have updated to disable Laser on G28 command.
Sign In or Register to comment.