second UART for Bluetooth isnt working after upgrade from 0.9.2 to 1.0.1

Hello,

i do have tried a setup with ESP3D serial to tcp/ip connection on one of my 3d-printers.

My hardware is the classic reprap hardware with arduino mega2560 and ramps 1.4.
After a quick view in the pins.h for ramps motherboard i have seen the D16/D17 pins for UART2 are not used.
Then after activation of the "Bluetooth UART 2" the fullgraphic 12864 smartcontroller was not working, so after some search in the sources i found the places where the pins are defined.

for 0.9.2 its in "ui.h" UI_DISPLAY_RS_PIN and UI_DISPLAY_ENABLE_PIN on 16/17. On the AUX4 connector are some spare pins so i changed the signals of the display to 39 and 43 and modified the display adapter pcb. (line 801/803)

for rev 1.0.1 the right place for the same thing is "displaylist.h" (line 326/328) with same signals and pin definition.

After changing the signal lines as described and switch to the modified display adapter the smartcontroller is working now.
But i cant get a serial connection on UART2 with repetier fw 1.0.1
On version 0.9.2 it is working.

I tried different baudrate too, and a usb-serial(TTL) adapter on the pins, but doesnt work with 1.0.1

Comments

  • sorry, it was not 1.0.1, it is in firmware rev 1.0.2
  • same in 1.0.3-dev

    tell me if you need config oder displaylist files.
Sign In or Register to comment.