second UART for Bluetooth isnt working after upgrade from 0.9.2 to 1.0.1


i do have tried a setup with ESP3D serial to tcp/ip connection on one of my 3d-printers.

My hardware is the classic reprap hardware with arduino mega2560 and ramps 1.4.
After a quick view in the pins.h for ramps motherboard i have seen the D16/D17 pins for UART2 are not used.
Then after activation of the "Bluetooth UART 2" the fullgraphic 12864 smartcontroller was not working, so after some search in the sources i found the places where the pins are defined.

for 0.9.2 its in "ui.h" UI_DISPLAY_RS_PIN and UI_DISPLAY_ENABLE_PIN on 16/17. On the AUX4 connector are some spare pins so i changed the signals of the display to 39 and 43 and modified the display adapter pcb. (line 801/803)

for rev 1.0.1 the right place for the same thing is "displaylist.h" (line 326/328) with same signals and pin definition.

After changing the signal lines as described and switch to the modified display adapter the smartcontroller is working now.
But i cant get a serial connection on UART2 with repetier fw 1.0.1
On version 0.9.2 it is working.

I tried different baudrate too, and a usb-serial(TTL) adapter on the pins, but doesnt work with 1.0.1


  • sorry, it was not 1.0.1, it is in firmware rev 1.0.2
  • same in 1.0.3-dev

    tell me if you need config oder displaylist files.
  • I'm a new Repetier firmware user. I grabbed the latest 1.0.3. Having the same issue. Bluetooth serial port is not working. I manually switched RFSERIAL to Serial3 (the Y endstop pins on the MKS GEN L Ramps board) and confirmed the hardware is working OK. The Bluetooth serial port does NOT communicate with the board!
  • The same issue.

    Try 1.0.5 firmware with manual configuration, 1.0.4 from web configurator - serial1 not working.

    Try arduino ide 1.6.7 and 1.8.8.

    Try to uncomment no succes.

    When upload old firmware 0.92.9 serial1 working perfectly.

    My config section for 1.0.5:
    #define BLUETOOTH_SERIAL   1                      // Port number (1..3) - For RUMBA use 3
    #define BLUETOOTH_BAUD     115200                 // communication speed
    (i use ramps 1.4, bt connected to pins 17 and 18)

    #ifdef RAMPS_V_1_3

    #define ORIG_X_STEP_PIN         54
    #define ORIG_X_DIR_PIN          55
    #define ORIG_X_ENABLE_PIN       38
    #define ORIG_X_MIN_PIN          -1     //3
    #define ORIG_X_MAX_PIN          3      //2

    #define ORIG_Y_STEP_PIN         60
    #define ORIG_Y_DIR_PIN          61
    #define ORIG_Y_ENABLE_PIN       56
    #define ORIG_Y_MIN_PIN          -1    //14
    #define ORIG_Y_MAX_PIN          2     //15

    #define ORIG_Z_STEP_PIN         46
    #define ORIG_Z_DIR_PIN          48
    #define ORIG_Z_ENABLE_PIN       62
    #define ORIG_Z_MIN_PIN          -1    //18
    #define ORIG_Z_MAX_PIN          14    //19

  • edited February 20
    (i use ramps 1.4, bt connected to pins 17 and 18)

    Sorry, 18 and 19 pins of course.

    And i try to connect PUTTY terminal via bluetooth - empty, no one symbol after flashing new firmware. I try to short rx\tx pins on ramps 1.4 and terminal have echo but still no comunnication with board. After flashing old firmware with the same config i see on terminal "welcome" and activity and connection work properly.

  • edited February 21
    The code changes described in this bug report worked for me. I am able to use TFT32 on UART3 (Y endstops pins 14 and 15) while simultaneously having Repetier Server connected to UART0 (AUX1 / USB). Note that the repetier.xml file - protocol must be set to ascii, since the protocol is changed for both UARTs, or the MKSTFT will not work becuase it does not speak 'repetier'

    This isn't a permanent fix but it achieved what I needed for now.
Sign In or Register to comment.