Problems with moving X and Y


I have a fiew problems with "Repetier Host" and "Cartesian Printer". 
1. I made changes in my construction, and now:
 -  the "X" axis theoretically can travel 290 mm
 -  the "Y" axis theoretically can travel 250 mm
My work area is clear 240 mm * 240 mm. 
I use Repetier Firmware v.0.92 and the last version of Repetier Host.
My hardware is: Arduino Mega 2560 + RAMPS 1.4 + Discount LCD controler
HERE is my "Configuration.h" , and my "Printer settings "
Before changes my work area was: 240 mm * 240 mm  and all was OK.
Now I can't move "X" and "Y" more than 240 mm. Some Ideas where can this values be stored (240 mm) ?
When I tell the printer: G1 X250, it moves to 240 ans stops, but in the manual control, the value for X is 250 ?!?!? If I want to move it with another 10 mm (for example) it do not moves, but the value raises to 260... 
In Printer Shape section in Printer Settings, my physical "Bed left" value is 35mm. I tried to change it, to change X min, even with a negative values, but nothing changed. 
When I set X min for example as "-15", and I press "Home X", the value in the X cell changes to -15, but when the exruder hit the End Stop, this value changes to "0".
It doesnot mater what value I use, and where I put it, every time the maximum travel for "X" stais 240 mm.
The same is for "Y"


  • Sound like your firmware is the limiting factor. See eeprom settings for max xyz length which is added to home position. I guess you have enabled software endstop since it is how config tool works, so limits are now effective as set in eeprom.
  • Thank you for the reply.

    It does not mater what is the value in "xMinPos" and "yMinPos". Now they are respectivelly: 35 and 15. But even if they are 0, no diference.
    I searched all the Configuration.h , but the value of 240 I found just for the ABS extruder temperature.
    #define X_MAX_LENGTH 290
    #define Y_MAX_LENGTH 250
    #define Z_MAX_LENGTH 190
    #define X_MIN_POS 35
    #define Y_MIN_POS 15
    #define Z_MIN_POS 0

    About software EndStops - they are switched On. I don't know why...

    #define max_software_endstop_x true
    #define max_software_endstop_y true
    #define max_software_endstop_z true

    This evening I'll switch them off and will check again.

    Best Regards
  • Check eeprom not only config file! Connect with host->Config->Eeprom settings!
  • YES..... the "magic" is in "Eeprom settings"...

    Thank you very much! All is OK now.

    Just one question: Where from / to / the Host get  / put /  this settings, and why they stay even if a new skatch is loaded?

    Best Regards
  • That is what eeprom is meant for. To survive sketch uploads. There is a parameter EEPROM_MODE in config, and evertime you change it, it will copy values from config to eeprom. If it is the same it will keep data.

    BTW: Host allows to save settings, so you can copy them back in case you have overwritten them.
  • Thank's again!
  • Hello. I have a similar problem.

    After replacing the heating element on the X axis, the Extruder stopped returning to the parking lot.
    That is: +10 works. A -10 doesn't work. He's not going back.
    What could be the problem?
    Help me please.
    Thank you.
  • Check endstops with
    Assuming x min endstops if you can not go back it is probably triggering and high all the time. Did you loose endstop during replacement?
  • edited June 13
    There was no reaction to the M111 command.
    Please look at my parameters. Is everything correct? Table size 70x80

    EEPROM parameters:

    Baudrate                                    115200
    Filament printed                       1861.741   m
    Printer active                              1524307  s
    Max.inactive time                        0  ms,0=off
    Stop stepper after inactivity      360000 ms,0=off
    X-axis steps per mm        200.0000
    Y-axis steps per mm        200.0000
    Z-axis steps per mm        200.0000
    X-axis max. feedrate       200.0000  mm/s
    Y-axis max. feedrate       200.0000  mm/s
    Z-axis max. feedrate        2.0000  mm/s
    X-axis homing feedrate    40.0000  mm/s
    Y-axis homing feedrate    40.0000  mm/s
    Z-axis homing feedrate    2.0000  mm/s
    Max. jerc             20.0000  mm/s
    Max. Z-jerc         0.300  mm/s
    X home pos        0.000  mm
    Y home pos       0.000  mm
    Z home pos       0.000  mm
    X max length    70.000  mm
    Y max length    80.000  mm
    Z max length    155.000  mm
    X-axis acceleration    400.000  mm/s^2
    Y-axis acceleration   400.000  mm/s^2
    Z-axis acceleration   400.000  mm/s^2
    X-axis travel acceleration    400.000  mm/s^2
    Y-axis travel acceleration   400.000  mm/s^2
    Y-axis travel acceleration   400.000  mm/s^2
    Extr. 1 steps per mm       90.000  
    Extr. 1 max feedrate      50.000  mm/s^2
    Extr. 1 start feedrate    20.000  mm/s^2 
    Extr. 1 acceleration       5000.000  mm/s^2 
    Extr. 1 heat manager     3     0-3
    Extr. 1 PID drive max     230
    Extr. 1 PID drive min      50
    Extr. 1 PID P-gain/dead-time     7.000  
    Extr. 1 PID I-gain      2.000
    Extr. 1 PID D-gain      40.000  
    Extr. 1 PID max value    255     0-255
    Extr. 1 X-offset      0  steps
    Extr. 1 Y-offset     0  steps
    Extr. 1 temp. stabilize time      1  s
    Extr. 1 temp. for retraction when heating        150 C
    Extr. 1 temp. distance to retract when heating     0  mm
    Extr. 1 extruder cooler speed      255   0-255

    More details please. Where can I look for an error in the wires or in my parameters?
  • edited June 13
    Did you loose endstop during replacement?
  • The command for endstop report is M119 not M111!

    EEPROM looks ok so far. And if you only changed heater it is likely a hardware error you caused while changing the heater.

    BTW: Does homing still work? There X must also go to negative coordinates.
  • And how to find it?     M119 I get:    x_min:H y_min:L z_min:H
  • edited June 13
    Repetier said:
    The command for endstop report is M119 not M111!

    EEPROM looks ok so far. And if you only changed heater it is likely a hardware error you caused while changing the heater.

    BTW: Does homing still work? There X must also go to negative coordinates.
    I only replaced the table. It was 200x200, I replaced it with 70x80

    Return home doesn't work yet. Works great from home. After connecting, if you press -10, then it twitches once, and doesn’t move, and then doesn’t even twitch. And if you press home, then he travels from home, approximately +5.  
    and writes:  X:0.00 Y:0.00 Z:0.00 E:0.00

  • I found a mistake. With the limit switch disconnected, everything works correctly.
    The limit switch is broken. I will order a new one.
    I'm sorry to trouble you.
    Thank you for your responsiveness.
Sign In or Register to comment.