.92.8 Crashes hard

moved from .92.5 to .92.8
imported the config file from previous build.
only change was to extruder acceleration.
New build seems to crash regularly, while sending the first few commands or even just attempting to connect.
Get rows of black boxes on display.
Guessing those are 0xFF or 0x00 being written to display RAM incorrectly.
Strangely I did get a few full layers once or twice.
Sometimes failure does not seem to reach the display and seems like a simple usb disconnect, however it requires a reset to clear it
and reconnect so I suspect it is the same issue just that it doesn't reach the display.

Tried 3 different times with three fresh downloads and builds with the same results.
Tried using both Repetier Host and my Astrobox with similar results,
reverting to .92.5 solved cleared the problem.

I am wondering if there is any revision document that shows changes from one version to the next if so I can't find it.


  • I dont think the online configuration tool is capable of importing older configuration.h's. If you want to migrate to 0.92.8 you should define your new configuration.h from scratch I believe. Otherwise there will be some mess going on for sure. Maybe you even want to re-write the EEPROM, i.e. change the EEPROM_MODE number.
  • Thanks for the tip.

    I may give the total rewrite a try, however I was under the impression that 0.95 configuration.h should be compatible with he online config utility.  I used that utility to generate the 0.92.5 file as well as my original .92.2 setup (I think it .2).
    I imported .92.2 to get to .92.5.

    Everything seemed ok in the config utility...all the previously set features and values were imported and displayed as expected.

    Now maybe the EEPROM format has changed....maybe a full rewrite is in order, though I gave it a once over from Repetier Host and it looked correct when read in using .92.8....at least the couple times I was able to see it before a crash...I guess the crash could have corrupted it at some point too...although then I would expect when I went back to 0.92.5 it would have been a mess and it still looks fine...and I never change the EEPROM_MODE and all the values remain at my tweaked values which I don't usually write back into the configuration.h but that is as good a place to start as any I suppose.

  • The tool was written to upgrade automatically, that is no problem. It just adds default values for new introduced features whcih are normally disabled by default, so it stays the same.

    You should check the log for free ram. Early and consequent crashes may be from missing ram. Updates may require some more ram so it could run into a memory problem. Especially delta printers use every byte and then need to decrease buffer sizes.
Sign In or Register to comment.