Melzi V2.0 with LCD2004 and 5 keys



  • Hi Grizz87,

    I have good and bad news.
    Good: I had a good modified FW for this printer with autoleveling and distortion correction, which was giving good prints.
    Bad: My hard drive crashed and I stupidly did not have a backup. Meaning I still have the FW on the printer, but I have lost the source code. :(

    So it's pretty much useless to you unless you would have the exact same setup as me (autoleveling sensor connected on a certain pin).

    But if the config file doesn't upload, I would recommend just entering the settings for the configuration manually online, and checking what differences are left between the config files.
  • edited December 2016
    this anygood

  • After read all post, I have not clear what firmware cna I upload to my P802M with a capacitor autolevel.

    Could someone give me a link o file?


  • Hello everyone,

    Another victim of a weird printer here, I seems to be plagued with all of the issues listed here.

    However, it seems that no matter what I try, I can't seem to get the printer to work, I updated the bootloader, and have tried flashing both Marlin_tronxy and repetier using the config from -> boards\Zonestar P802M\Configuration-normal.h

    In all cases, the printer enters a "boot loop" so to speak, it won't respond to the 5 buttons on the printer and when connecting to it via USB, it always restarts.

    I have a Tronxy clone called DMYCO (which is a melzi clone) with an ATmega 1884P 16Mhz chip.

    I wonder if I'm doing anything wrong here? or should I try a different approach altogether?

  • What does the log say is the restart reason when you connect to usb? 
  • Well, I'm not sure why but replugging everything seems to have solved the issue! the printer now boots fine and I can connect to it via the repetier host software (I could connect to it in the past but it just rebooted all of the time).

    I'm wondering if the reboots happened because the Arduino ISP was connected? I don't think it should have mattered since the device wasn't even powered on.

    In any case, when you mention "log", do you mean the output printed in the host software when connected? (not that it matters much now in any case)
  • Yes, log is communication printed in host/server.

    ISP also connects to reset pin. If this would cause it to trigger when not powered it might make a difference.
  • edited June 2018
    Now I'm having a different issue however, it seems that the zstop isn't triggering.

    I'm not sure if this is a sensor issue or not, the stop used is an inductive proximity sensor TRZ-Pl-08N (, the LED on the sensor turns on when in contact with metal, but no signal is sent to the printer (which causes it to continuously lower onto the bed without stopping).

    I've tried checking with M119 and all stop report as L even when the LED is on for that specific sensor.

    is there a way to read the exact output from the sensor?

  • Sure you are using the right pin? Also make sure no other function uses the pin and sets it as output. One thing that can make a difference is having pullup on or off, also for electronic components off is normally correct and should at least show a difference between on/off just maybe inverted.
  • Thank you for the inputs.

    It turns out that the IO pin on the sensor's connector was a bit loose (middle pin), causing intermittent disconnections to the board.

    After replacing the connector everything seems to be working well, updating here for prosperity's sake.
  • i just found this forum and my firmware says adc keypad true

    define lcd true
     i hope this helps

Sign In or Register to comment.