Filament Runout Sensor ...

I am trying to set up a filament runout sensor on my printer. The sensor is a simple endstop switch, the problem im having is I cant find any place to define what endstop plug on my zrib board... I have enabled jam protection in the firmware already.. Any help would be much welcome...


  • The tools define it with "Jam detection pin" in the config tool. Select here the proper endstop pin you used.
  • I am also using a simple ON/OFF endstop type runout sensor. What settings should be used in Jam detection firmware if not using tracking with steps?
  • In config tool Mechanics->JAm Method mist be signal gets High or Low depending on how the switch changes. Then in extruder settings configure pin and pullup that is all you need to do. Then set Jam Action to LCD or request pause from host/server.
  • edited October 2018
    I got around the problem by connecting the switch directly to my Raspberry PI running Octoprint using the runout plug-in. The raspberry then sends the pause to the printer.. Works well this way..

    Thank you for all your help...
  • Hello, i stuck at the similar problem then neoh.
    I am using an ramps 1.4 board and 2 extruders.

    The config file has the following settings:

    #define EXT0_JAM_PIN 3
    #define EXT0_JAM_PULLUP 1

    #define EXT1_JAM_PIN 3
    #define EXT1_JAM_PULLUP 1

    #define JAM_METHOD 3
    #define JAM_ACTION 2

    After downloading the firmware and sending the command M119
    only the state of the endswitches  was send back.

    I tried differend settings with one extruder, differend jam detection settings and differend digital pins and free 
    endstops. But no success. The jam detection state or state of the choosen pin was not showing up by sending M119.

    Has anyone an idea what is missing to get this running?

    Many thanks in advanced.
  • Jam detection is not endstop, so M119 will never report them.

    Jam commands are

    - M513 - Clear all jam marker.

    - M600 Change filament

    - M602 S<1/0> P<1/0>- Debug jam control (S) Disable jam control (P). If enabled it will log signal changes and will not trigger jam errors!

    - M603 - Simulate a jam

  • Thanks for the quick andere.

    As the setting showing, jam detection is configured as switch. So end of filament should be detected.

    How can i check the function/configuration of switch/software?
  • Cut filament in a test print. Once switch switches you should get either a message in log causing server/host to pause or see a filament change on lcd depending on your configuration.
  • I'm having the same problem I installed a regular mechanical filament sensor it's either

    When I run M119 gcode it returns accordingly to either H/L.
    Before I print something I put gcode in "M602 S0 P1  because If I don't, it will always detect a JAMM.

    Still it's like the filament sensor is not there because it keeps printing even if the filament sensor is TRIGGERED or not.

    These are my settings:

    XMIN  -> Switch on GND, normally open

    MECHANICS > Jam detection and out of filament detection Section
    Jam Action -> Show Jam/out of filament dialog and block communication (requires LCD) 

    TOOLS -> Extruder section
    Extruder 0
    Jam detection pin: XMIN
    Enable pullup resisitor for jam pin : SELECTED

    Am I missing something?

Sign In or Register to comment.