No webcam stream, only static image



  • My experience seems related.  We have a RPi3 Repetier-Server Pro 0.86.2 with a single printer (Repetier), a single webcam, and an hdmi display.  Prior to webcam, never a need to power down.  Multiple long >1 day prints with no problem.  Using the webcam, everything still works for a number of prints.  But then the video fails first on port 3344.  Everything else still working.  The snapshots are still working on port 3344.  But then after a while, within a day, maybe after closing a browser and re-opening, then the snapshots fail, and when that is attempted and it fails, then port 3344 soon locks out everywhere.  Long print still running though and it finishes out with no problem.  Port 8080 is flawless the entire time, showing both videos and snapshots.  Reboot the RPi3, everything returns.  I'm a Linux noob that just wants to print... seems to me that viewing webcam from the server via port 3344 has a bug.  Even if it works, for us it is a time bomb.  Only damage done is that it locks up video first, then port 3344, but finishes the long print, and the video and snapshots on port 8080 are good the entire time.
  • I guess I have an idea where it comes from. When reading port 8080 fails it seems to go into an endless loop instead of finishing. I found this when I remove dthe webcam and reinserted it - port 8080 was then there again but no reconnect and no video in interface. Have fixed this for next update.

    Snapshots are independent as these are requesting the static image url and just store the returned image.

    The login problem might result be using up all file descriptors. Would also explain why snapshots do not work any more. Need to think how I can test/simulate this, but will have a look into it.
  • edited July 2018
    brucehvn said:
    I'm experiencing the same problem.  I use mjpg_streamer that I compiled back in 2016 and start and stop it manually.  It's always worked fine with RS.  I just upgraded to 0.86.2 and have the same problem as the OP.  The stream works fine in the browser when called up directly, and the RS settings show both the static and streams, but in the UI for the printer, it pauses for about 4 seconds then shows the webcam image with the red line through it.  My server log is being output as it should, but I don't think it reveals anything earth shattering.  This is with a pcduino v2 board and the armel version of RS.

    2017-12-17 00:26:49: Start logging...
    2017-12-17 00:26:50: Imported allowed execute command printdone
    2017-12-17 00:26:50: Webdirectory: /usr/local/Repetier-Server/www/
    2017-12-17 00:26:50: Storage directory: /var/lib/Repetier-Server/
    2017-12-17 00:26:50: Configuration file: /usr/local/Repetier-Server/etc/RepetierServer.xml
    2017-12-17 00:26:50: Directory for temporary files: /tmp/
    2017-12-17 00:26:50: Reading firmware data ...
    2017-12-17 00:26:50: Starting Network ...
    2017-12-17 00:26:50: Active features:4095
    2017-12-17 00:26:50: Reading printer configurations ...
    2017-12-17 00:26:50: Reading printer config /var/lib/Repetier-Server/configs/I3Omega.xml
    2017-12-17 00:26:50: Starting printjob manager thread for I3Omega
    2017-12-17 00:26:50: Starting printer threads ...
    2017-12-17 00:26:50: Starting work dispatcher subsystem ...
    2017-12-17 00:26:50: Starting printer thread for I3Omega
    2017-12-17 00:26:50: Starting user database ...
    2017-12-17 00:26:50: Initalizing LUA ...
    2017-12-17 00:26:50: Register LUA cloud services
    2017-12-17 00:26:50: add Repetier-Renderer
    2017-12-17 00:26:50: LUA initalization finished.
    2017-12-17 00:26:50: Starting web server ... 
    2017-12-17 00:26:50: Webserver started.
    2017-12-17 00:26:50: Work dispatcher thread started.
    2017-12-17 01:01:57: Connection started:I3-Alpha
    2017-12-17 01:01:57: Reset printer I3-Alpha
    My problem that I described above for 0.86.2 appears not to be solved in either 0.90.0 or 0.90.1.  Same issue.  The webcam configuration page looks normal and sees the proper images in the stream and snapshot parts, but when going to any of the printer screens where the webcam should be showing, it seems to time out and display the webcam with the circle and the slash.  If I set it just for static JPG images, it works.

    The streaming webcam does show up once in awhile, but I would say 98% of the time, it doesn't.  I've rebooted many times, cleared cache, etc.

    I just had to reconfigure my webcam because it appears the 0.90.1 update wiped out the configuration entirely.  But I still have the same issue after re-adding the data.
  • Need to in estigate further on this. Have seen it not appear in rare occasions ans switching screen helped, but if this also happens frequently that would be bad.
  • I wanted to run this a few days to be sure, but so far after several cycles, the webcam is working normally after I had to re-add it under 0.90.0 and then upgraded back to 0.90.1.
  • Ok, then it sounds more like a problem with upgrading from old comfigurations. Now that you can have multiple webcams the format changed to an array. Will investigate what goes wrong in upgrade.
  • Hello
    I'll get in here now. I have such a similar problem. I've just recently added an RPI camera from Waveshare Version F. There I have the problem that after starting up the Pi the camera is not started. I can reproduce the mistake. I have to restart the webcam server a few times until the camera stays on. As soon as I click on the button (Restart Webcam Server) the camera will only work for 1 millisecond. At some point it will stay on and work perfectly. But ... after the reboot, the whole thing starts again. Currently use the trial. Can this also be a problem?

  • No, trial is not the problem. I have to investigate on that problem. Server stops webcam stream when something goes wrong or no one is listening. So i have to find out which part is causing this. Have you tried switching tabs instead of rebooting webcam server? 
  • Yes, I have made so many attempts. Switching tabs brings nothing. I have on my camera a small Led which shows when the camera is on or is activated. If I click on the "Restart Webcam Server" button, it only flashes briefly and then goes inactive again. After several clicks on the button without changing tabs. If at some point you are actually active and only partially working (not shown on all pages), sometimes everything works. But must also say ... the webcam server is not the newest. 10 years no update.
  • Aren‘t you using mjpg_streamer? It is the only thing you restart with the restart button, And latest image has a newer version with updates from this year. Surely not much will happen here any more, but it is working stable normally. Problem is we proxy the webcam server so it can also be seen outside your network if you port forward the server and there the proxy seems to stop early and i need to find out when it happens. You seem to be a more extreme case as for me it is normally working. One of these hard to trace problems i guess.
  • No no I use the integrated streamer. Nothing changed. Today, for example, everything started up and the camera works wonderfully. Even in the printer front end tab. I do not understand it either. If I would restart the webcam server now ... Does the camera to 99% no longer correct. The camera itself should be 99% compatible with the original RPI camera. If I can help somehow ... like?

  • Thanks, but i fear i have to find out why it stops the streaming. Maybe i should add 3 retries on error internally before stopping the stream. Then it shiuld be more reliable,
  • Hmm ... difficult. As in my example. I may have to restart the webcam server 5 times. When 6 times it works and if I then restart a 7 times, he does not go again. Random stop.
  • 3 retries main per problem. So it starts and if a com error with webserver hapensit will wait a second and restart reading. But first i will make some tests hoping i get an error so i find out why it in first place.
  • Hello
    Update 0.90.2
    Would like to leave some feedback. So the error with the freeze frame and the webcam recordings were not displayed everywhere is definitely fixed. webcam image is now displayed everywhere.

    But I still have to manually restart the webcam server 2, 5, 10 times.
    Have now for safety's sake a second camera ordered to rule out a defect of the first camera. If the error still occurs then it would not be so nice. On the standard Pi operating system, the camera runs in any case without problems.
  • Ok, new system is if a stream is started it will never end. In the background it will always try to reconnect and stream will continue on it's own. So it is good that this is now working.

    Restarting the webcam server should not be needed and in fact I never needed this. So the question is why do you need it. Does the mjpg_streamer crash after a start so you need to restart? If you login using ssh you shoudl see the pid (first number in the row) using
    ps aux | grep mjpg
    If streamer disappears or gets a new pid then the streamer crashes and the question would be to check why this happens.

    Which image are you using? V9 or an older one. V9 has a newer version of the streamer then the older images.

  • edited August 2018
    I once opened a New Discussion (this time in German) Since the problem discussed here was actually solved with the new update 0.90.2.
Sign In or Register to comment.