Extremely weird issue after Melzi to RAMPS conversion.

edited August 2017 in Questions & Answers

I have this problem with a Wanhao Di3 converted to RAMPS 1.4. I followed the instruction on the 3DPrinterWiki and after awhile I got it mostly working. I'm getting this problem where the X side of the 20x20x20 cal cube is to the left and the indent isn't deep, the Y side is too deeply indented and to the left, and the Z side is an incomplete Z shape and the top layers aren't completely filled. 

The printer has z-braces, its solid, I reduced the accel settings by half and reduced jerk from 20 to 8. Motors are working fine, no weird noises, and belt tension is nominal. My print speed is usually 40, but tried to go lower to no better print. I know I have a bit more extruder e-step tuning to go, but all the motor e-steps have been tuned and the cal cube is reading 20mm +/- 0.05mm. Other mods include 200x300 bed and an outer frame/mounting system to replace the Wanhao control box. 

Any suggestions to what can cause this? 

Just to see, I tried printing out a low-poly Totodile, and it came out with the back with parts of the back wall printed away from the rest of the model, leaving these gaps on the left side. The right side came out fine, though (I also ran the model through netfabb's repair to be sure it wasn't the model).


  • Y looks like it is not centered which I thinkit should be. X is unsharp so nothing to see. In total it looks like you have a big backlash problem with the x axis I guess. See if x pulley is still fixed to axis without play.
  • Alright, I did check and admittedly... did find that the top linear rod on the X-Axis was completely loose (really unsure how it came loose). However, that didn't seem to change too much. 

    Comparisons: Left is the last one and Right is the fixed. The biggest significant change I found was that the X indent became more defined. Even though it still isn't as deep as the Y or the Z, and hard to see, but the new X indent's walls are more straight with a 90 degree angles, unlike the last cube where the walls were rounded off from the backlash. 

    Also, the new cube's corners are closer to straight 90 degrees. 

  • Pulley seems still loose. Put power on motor and move left/right till center then tighten the screw. Screw should point on the flat part of the shaft and only when nearly 90° it stays fixed with no play. Check if you can move it with motor on to hold the shaft. If you switch with 1000 acceleration there are quite some forces on it so if there is possible play it willget triggered.
  • Its not. I had to take apart the X-Axis completely to fix the upper liner rod. Upon reassembly, I made sure everything was good to go and put together properly. No loose parts and it cannot move. 
  • if i understand correct , the "x" should come out of the cube , the "Y" is in the cube , the"Z" also.

    if you look at the structure you can see clearly it´s underextruded , that also causes the deep "Y" , the flat"X" and the open surface on "Z".

    think you should first calibrate the extruder(if not already done) then increase Flowrate respectively adjust Filament Parameters in slicer
  • The cal cube I'm using is this one. All letters are indents: 

    https://www.thingiverse.com/thing:1278865 ;
  • The Z view shows clearly that it has underextrusion, but that seems not the mainproblem. The Z should be open but is not at the ends from backlash. Also you say it is fixed there must be some part not fix as this is th eonly thing explaining the problem, except you have configured firmware to compensate backlash and now have none. Check also how the extruder is mounted - depending on the system there can also be backlash.

    As a last source compile with backlash correction and set x backlash to 1mm - looks around that value and see if it gets better. If it does try remove the physical source which will give the better prints.
  • Love the above link  :D
  • edited August 2017
  • For sanity reasons, when you say backlash, you mean acceleration and jerk settings right? Can't find any specific "backlash" settings in Repetier Host. 

    I just spent the last two days going over everything. Mechanically, everything should check out. Reflashed the firmware and have a new Micro-Swiss hot end on the way (just in case), and put in an upgraded Mk10 extruder gear and will try and recalculate extruder steps. 

    With that said... Another curious problem I had with calculating e-steps is that when I mark the filament at 100 or 120mm, like all the tutorials suggest, it moves more than 120mm into the extruder and can't get the second measurement. So, I've been marking at 200, and still moving 100, and going from there. Thats probably a problem within itself, but I couldn't find anything online about that. (note: Feedrate is set 3mm/s)
  • No, backlast is not acceleration and jerk. Backlash is when you need to move a bit in oppsite direction before it starts to move. google the term. In config tool, machanical tab you have at the beginning an option "Enable backlash compensation (ENABLE_BACKLASH_COMPENSATION)". If enabled each motor gets a extra parameter backlash. There you enter the missing distance in mm - in your case maybe even 1mm.

    Is the x beld under good tensions? Loose belts would also lead to backlash and all printers have a belt tightener to resolve this issue.
  • Whats the problem with extruder. If it moves more then 100mm on 100mm move the steps per mm are too high. Multiply old value with 100/moved distance then it should fit.
  • Alright, so I messed with the backlash, did this test: https://www.thingiverse.com/thing:2256550 ;

    X became perfect, but no matter what I set Y backlash the backlash was never in ranges of the test. So I tried a new stepper driver and somehow screwed the RAMPS board. I'm getting to my wits end on it. Everyone makes this sound so simple and I'm getting all these crazy problems that the solutions don't work. I have another RAMPS coming it, and if that doesn't work, I'm just reverting this back to original Melzi. At least that board actually works.
  • Mh, if it worked under Melzi without backlash and would work again then it is no mechanical backlash. Then I would more suspect the stepper driver having not enough current so it falls more into full steps and does not do all microsteps. But you would normally notice that the moves are not as smooth as the other axis then. Especially if you move slowly.
Sign In or Register to comment.