Autobedlevelling with 0.92.9


I am kind of running into a tiny problem here. I am doing autoleveling with an inductive sensor through 3mm glass. I am doing a G32 s2 everytime before a print,  because I have a removable glass plate with a fixed bed and I want to be sure that i get it correct everytime. No my problem is that I have changed the points the probe is probing. It probes with this sequence: Bottom left, Bottom righ, middle top of the bed and forms a triange. The examples on the Zprobing page show a different seuqence. Bottom left, Bottom right and Top left. Is this a problem?

I am asking because although it gets quite close to being perfect, whenever it moves to the right side of the glassbed, it raises the z axis for about 0.1mm. The prints still are ok, but it still bothers me not beiing perfect. I am seeing the leadscrew turning, although there isnt actually a need.

Is the way I have my probing points setup a problem, or does the firmware compute the plane either way?
Do I have to input a Gcode after g32 s2 to make it work better?


  • Order of points is not important with 3 point measurement. The image is especially if you start measuring a grid then these span the parallelogram used for probing and then it becomes important. Only important thing is points should not be on a line and have a good distance for better accuracy.

    With inductive sensors make sure bed is off when probing. It can influence results. How do you do this? Do you have 3 points with metal for sensor at these places? Make sure that it is also measured in center and all are the same.

    Don't use S2 in G32 if you do it always. S2 stores in eeprom and that is not neccessary then. Just reduces eeproms live time.

    Check eeprom for bending correction. These values should be 0. If they are 0 you can misuse them to add the 0.1mm on the right. Set it to 0.1 and it will subtract 0.1 from measured height so it will go 0.1 less down when moving to right. Maybe the metal has just a bigger distance to glass plate. In any case if it is a consistent error you can use it to fix it.
  • I am using 3 large metal washers stuck to the glass plate where the probe measures the distance.

    the problem is consistent and I will try the bending correction and report back.
  • Hello again,

    thanks for the tip about bending correction. It sure helped. Tricky to align, but worked.
    It probably has to do with what you said about probing the center of the washers.

    However I have also another problem.

    I am using a Malzi board and have disabled z min endstop and connected the probe at z min endstop.

    Now I have a certain probe distance set, however I am not sure how I can set my Z min position. Everytime my printer starts, it thinks its at z0, which makes sense. If I do a g28 x0 y0, it zeroes xy correctly. If I start to probe however and then start to print, my nozzle is in the air.

    To my understanding, when doing a g32 and probing, z0 is set and should be equal to the height the probe is triggered minus the probe height in the eeprom. Isnt that the case?

    If i turn the printer on and the probe is 2-3 mm over the bed, it prints on the air.

    Anyone can make sense of that?

  • Just checked it in dev version and at least with bed coating != 0 it easily gets wrong distances. Need to do some more checks before I release new 1.0dev version.

    Is z min = z probe in your case?

    Autoleveling a bit a pain to manage with all the different possible combination, so switching to dev tree might already help with bed coating set 0 as there are frequently smaller changes.
  • yes z min is z probe. I am switching to see, although I have managed to get it very close to working (actually quite good). however, with values that don't really make sense...but they work every time!
  • Fore some reason I cannot compile the dev firmware, is it possible to just use BedLeveling.cpp and compile it with the 92.9 files? Or is there more to BedLeveling than just the .cpp file?
  • Printer.cpp also has some parts. But telling the compile error might shed more light on it.
  • Hi sry too butt in, i am just trying to get my inductive probe working.
    At the moment i am useing a Z max switch and a probe on z min, with a Z length of 180 mm this takes ages
    to go al the way up(with G28) and then down again to Z0.

    If i try and use try to use Z min homeing with G28 (useing the probe as endstop. G28 tries to probe off the edge of the bed.
    is there a way to get G28 to home X0 Y0 and then move to centre of the bed before it homes Z0 ?

  • @MartinH Welcome with the problems of z min endstops and autolevel. There is in deed a homing order that should work. Try xy preheat z in config tool. Then you can set homing position for z homing. Requires a minimum z height to work.
  • TY, that sort of works, i can get the sensor to go to center of the bed and set Z0. the anoying part is it then travells to X0 Y0 Z0
    and then G32 creates an error due to Z being to low and trigerring the sensor to early.
    Is there a way to stop the x y z homeing at the end of G28 command ?

  • You can modify firmware code to have different behaviour.

    Simple solution would be sending G1 X100 Y100 Z10 before sending G32 which you should do only when needed and not necessarily every print.
Sign In or Register to comment.