Anet A8 Firmware issue

hi i am Jamie i am new to 3d printers and bought a CTC A8 cheap
with repetier host if i print front right it is preinting just past middle right on the bed
it has Repetier_ firmware but is seeing the machine as a Mendel

anyway the machine was not working i got it working by replacing the hot end and thought it could be a firmware issue so after asking elsewhere was told to put marlin on it but it looks like i dont have a bootloader on the board as i can compile it but not upload it
anyway as it has Repetier firmware is there a way i can either sort it out so the program sees the machine with the correct bed size or update the firmware to sort it ??

side note the whole z extruder was on the wrong side of the gantry i olny noticed today i have now put it on the right side so that it can now physically reach the whole bed but now my dam Y axis seems to be reversed any way of fixint this>?


  • You need to modify firmware and reupload, sorry. Sounds like it was wrong configured anyway and hardware changes normally need firmware adjustments e.g. replacing sensor type by the new one, end stop direction motor direction, ... But what board are you using that you have no bootloader?
    Note thaty ou can only upload if no software is connected to the board or uploader will fail. I think it is mega 2560 board so normal avrdude should do the upload trick if com port is correct and not used by other software.
  • Board is v1.5 and has a ATMEGA 1284P chip I have previously tries to put marlin (compiled and verified) but get a sync error every time I would put repiter back on it with the right machine but I don't know all the parts for the config side of things and even if I did would it even go onto the board if it has no bootloader ?
  • v1.5 of which brand and model? Melzi is the only I know directly to use that chip.
    1284 is quite unusual and has the additional issue that the firmware must fit into the 124kb. So make sure the compiled firmware uses less flash.

    Regarding y axis you can rotate motor cable 180° to reverse direction. But is essential that the end stop is found where expected so if it then does not find end stop you need to move it as well since you otherwise need to compile firmware to tell end stop is at the other side.

    It is actually possible to upload without bootloader - that is how the bootloader gets installed. The board hopefully has a ISP connector where you could connect a AVRISP to (clone or original). But that also needs some knowledge on how to use ISP. And I'm still not 100% convinced that you don't have one. Sometimes I also got sync errors despite having bootloader. Use short cable, no main power connected might make a difference. Often it is some interference that makes it fail.
  • Just tried with shorter cable different com ports and baudrates as I had seen 57600 sometimes works but it didn't laptop was not plugged in or do you mean no main power to the printer ?

    I have been thinking of using a raspberry pi on the j3 jumper pins have found a bootloader but I'm not all that sure as I don't know much about the bootloader side of it
  • I meant main power to the printer so board is only powered by usb cable.

    If you mean baud rate in windows settings that is useless - it does not get used. avrdude determines the speed.

    Different com ports - actually you should see which com port is correct. It is the one that disappears when you unplug the printer. These old boards all have dedicated usb serial chip so com port is independent of any firmware. Makes it easy to see what com port is correct in hardware manager.

    Have you selected the correct chip in arduino ide? Especially if you have a sanguino based board it is not available for settings and your avrdude gets wrong parameter for upload and will also fail. For sanguino boards you had at least in the past to add the boards manually to the ide.

    >I have been thinking of using a raspberry pi on the j3 jumper pins have found a bootloader but I'm not all that sure as I don't know much about the bootloader side of it
    Not sure what you mean with j3 jumper pins. Pi uses 3.3V and your board 5v logic, so that also sounds dangerous but I'm no expert about that. 
  • Com ports don't show if printer has no power and I have a usbasp coming so I'll just wait and do it that way thanks for the help/ replies
  • Ok some printers have modified board to only work with main power. Often with a jumper on board. Good success with isp solution.
Sign In or Register to comment.