Random crashes after upgrade to Windows 10 AND latest 1.5

I made a mistake.  I updated both the OS from Win7 to Win10 and the Repetier from 1.0.5 (I think) to 1.5.4.

Before it was nice and stable.  Now I get crashes ("Repetier-host has stopped responding") at various times.  Its crashing viewing the model, it randomly crashes positioning things, it randomly crashes during prints (with no one touching anything) and I do not see any pattern to the crashes.

- Should it work with Win10?
- Is there any special settings I should use (for example I DO have it running in Admin Mode- could that be an issue)??  Should I be setting a compatibility mode for running it??  
- I am using a Win 8.1 Graphics Driver (Intel HD 3000) as there is not a true Win 10 driver planned for my 2nd Gen Core I5.)- should that work?
- Anything else I might be doing wrong?  I do want to keep the Win 10 as Win 7 is basically EOL).

Thanks!!  Kirk


  • Any one else using Win10 yet??
  • Yep... having same issues.. inconsistent problems.. my bed heater changes to 1c.. and it seems to pause for a 1min before starting.. other weird issues..
  • Having same problem repetier will print 2 or 3 layers then crash and will not restart.
  • I had similar problems after upgrading from Windows 7 to Windows 10.  Repetier Host kept crashing towards the end of the slicing stage unless I was printing a very simple object.

    I changed from using Slic3r to Cura and it seems to have fixed the problem.  Therefore I think that the bug is in Slic3r and not in Repetier Host.
  • same issue here repetier host crashes the moment it loads object analyzer after upgrade to win 10
  • I have checked the host on my Windows 10 machine and it worked as it should be. There is no special Windows 10 or 7 code - all we use exists since Windows XP. So I have to conclude that the problems come from different sources like different drivers (I have ATI driver here) or serial driver (my printer used buildin windows  serial driver, not tested id FTDI makes problems). And last there were always users with problems due to some unknown reasons like corrupted files or what else can make a difference. One thing everyone with problems should do is running as admin

    sfc /scannow

    to see if basic windows files are all correct and not corrupted. Also updating graphic driver has already helped some users.
  • Interesting link. Looks like they have patched it so next release will be compiled with the patched version.

    I also checked the stl file and it is a ridicle what is going on. The problem also appears on windows 8 so it is not windows 10 related. It does not happen always, so it is a gamble. If it works it loads within seconds otherwise it does not crash but takes 15-20 minutes where something is blocking. Not even the debugger is able to pause the app then. It also takes 15-20 minutes to make pause work, so pause is after the problem. I hope I get an idea what can take so long and also prevents pause in debugger which otherwise always works instantly.
  • I upgraded from Win7 to WIn10 and am experiensing the similar issue to what is reported here. THe program crashes hard and takes down the computer right as Repetier changes from the slicer to the preview. Even though the computer is totally unresponsive, the hard drive is churning away.
  • I was reading another thread indicating using Cura to slice worked. That is the case for me. I would still like to use Slic3r though
  • At least with big files i found that the garbage collector blocks the host for longer then I like until it starts working normally again. I'm now testing on how to make new "new" garbage collector introduced in .NET 4.5 faster. So if it looks if the program has crashed please give it 10 minutes to see if it continus afterwards. Then I know it is the same problem.
  • edited August 2015
    I have just been using the small Marvin model from 3DHub. It causes Windows to crash hard right after Repetier switches to the Preview window. This doesn't seem to impact MatterControl or Cura. I will let it run for a while now (I am logged in remotely to my printer) but if it is doing something, it didn't leave enough CPU cycles to keep the remote connection up.
  • edited August 2015
    Ok. Eventually the computer came back on-line (about 1hr later) but Repetier was hung (unresponsive). I was unable to kill Repetier with task manager.
  • Not sure if this helps but here is the error from the event log.

    Faulting application name: RepetierHost.exe, version:, time stamp: 0x55b091c5
    Faulting module name: KERNELBASE.dll, version: 10.0.10240.16384, time stamp: 0x559f38c3
    Exception code: 0x80000003

  • ijourneaux That module is part of windows. If it appears in a box with details the details might help. If it comes from C# it would contain a traceback with all functions called before so we can see where it comes.

    1.5.5 is now out. Here we made some bigger changes to garbage collection handling that could cause unwanted pauses. At least the tests where we knew this happened are now fast without long pauses. Hope this also fixes some other side effects. Also it is compiled with a newer compiler not containing a potential compiler bug.
  • I tried 1.5.5 last night. Unfortunately it didn't fix my problem.  When I slice (Sclic3r 1.2.9) the little Marvin figure, it slices then switches to the Preview pane and then hangs hard with lots of continuous disk activity. Not thinking ahead, I had upgraded both windows and the slicer at the same time. This time I got to see the Preview of Marvin but that was it.

    I am replacing the hard disk and Windows setup, but I am not sure that is going to help as Cura and MatterControl both seem to work correctly. 

    I don't get any error from RepetierHost itself only the error in the event log. Is there any way I could get you more debug info.
  • First MatterControl and Cura are completely different software - it is not to expect that they ever get the same problems. Each gets it's own set I guess.

    What keeps me wondering is your disk activity. If you could see the preview there is no need for more activity and slic3r is finished. So you should check in taskmanager or resource monitor who is doing this and why. Could it be swapping memory, which slows everything down? Marvin is a small figure if I remember so it should be no problem. Anyhow check how much memory the host uses.
  • edited August 2015
    I know they are completely different programs doing things completely differently but doing them successfully. I really want to stay with Repetier Host. Just want to help out to solve the problem.

    Here is some more information. 
    Marvin is a small model and it work before with earlier version of Repetier Host under 64bit Win7.  
    Today,I swapped in a new hard drive (SSD this time around). I loaded up Task Manager with Repetier Host side by side and  able to slice Marvin with Slicr and get to the Preview window. I  had not been able to do that before. Unfortuantely I clicked on the Preview window to try and rotate Marvin and immediatey the memory consumption in Task Manager went to 100% and Repetier host crashed. This laptop Lenovo T520 has an i5 processor and 4Gb of Memory running 64bit Win10.
    It shouldn't have any trouble doing this.

    PS I enabled logging to see if that resulting in any info but the log file is empty.
  • Not ideal but I returned to version 1.0.6 and the crash does not occur with slic3r 1.29
  • I will jump on the Windows 10 doesn't like RH 1.5.5 bandwagon.

    I *frequently* and I mean ever other print, get issues where RH will just stop doing anything.  Stops registering temp changes, wont print, wont start a print, starts but wont really start printing (does the home dance, warm up the hot end, then stops.)

    All this started after I updated to 1.5.5 and windows 10.

    i think I will go back to windows 8.1 anyway.

    Nothing else in my setup has changed.
  • Oh, and a lot of times it will do this:

    g1 x0 y0 z0 f7000 (no problem)
    then move to a tower (im using a kossel)...1 command waiting (doest move)
    move to the other tower (2 commands waiting) doesnt move
    emergency restart
    do it again, maybe it will work maybe not.
  • Just posting a status update. I tried version 1.5.6 with and without the legacy 3D option. After the models get sliced, RepetierHost crashes when start moving around in the program.
  • This looks like an issue with on screen graphics use causing the hang in Windows 10.  When it is configured to draw on the screen what is being printed, then it crashes more.  I set it to not allow draws to slow down printing (or something like that but I cant find what I remember in 1.5.6 anymore!), and I do NOT get to see what is being printed being drawn along with the print, then I do not crash.

    If you are using OpenGL as it appears, I think Microsoft REALLY screwed up the OpenGL draw performance or use and that can crash the program.  This really has to do with the visualizations I think. 
  • What OpenGL driver does host show on log? Maybe if everyone with crashes could post Opengl output in log and video card we see a common reason. I had a user where updating video driver made it work.
  • edited September 2015
    I'm running on a notebook- a Dell® 17R N7110 with an Intel® 2nd Gen Core I5 (I5-2410M) using the integrated Intel® HD Graphics 3000.  I believe I am running the latest Intel Graphics driver for 2nd gen and Win 10 but I will need to double check that and OGL driver listed after I am in front of the machine again.

    I had a hard crash again with 1.5.6 after I sliced an item and simply switched from the Manual screen to the print preview window while the printer was warming up.  ANY attempt to look at the preview or object placement eventually seems to cause crashes.

    When printing, it always shuts off the draw along with the print capability. 
  • You should start using the server for running the prints. That way a host crash will not break the print and you can reconnect afterwards. Just use the server connector in printer settings instead of serial connection and of course a configured server with your printer. That also takes a lot of load from your laptop while printing if you close the host. Could still watch print with web frontend.
  • With 1.0.6  here is the OpenGL lines in the log file

    08:13:13.893 : OpenGL version:3.1.0 - Build
    08:13:13.893 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_EXT_texture_swizzle GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_EXT_texture_snorm GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_INTEL_map_texture GL_ARB_vertex_array_object GL_ARB_provoking_vertex 
    08:13:13.893 : OpenGL renderer:Intel(R) HD Graphics 3000
    08:13:13.893 : Using fast VBOs for rendering is possible

    With 1.5.6 the OpenGL log entries are
    14:21:44.793 : OpenGL version:1.1.0
    14:21:44.793 : OpenGL extensions:GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
    14:21:44.793 : OpenGL renderer:GDI Generic
    14:21:44.793 : Fast VBOs for rendering not supported. Using slower default method.

    This is on the same computer running Win10. I am not sure why RH 1.5.6 would be using version 1.1.0 without fast VBOs while RH 1.0.6 is using 3.1.0 with VBOs
  • Another minor thing. When switching back to 1.0.6, I get the following error messages in the log. It doesn't seem to impact anything. Just wanted to point it out.

    14:26:39.912 : Plugin RepetierServerConnector.RepetierServerConnector:Could not load type 'RepetierHostExtender.basic.IPrintJob' from assembly 'RepetierHostExtender, Version=, Culture=neutral, PublicKeyToken=null'.
    14:26:39.990 : Plugin RepetierServerConnector.RepetierServerConnector:Could not load type 'RepetierHostExtender.basic.IPrintJob' from assembly 'RepetierHostExtender, Version=, Culture=neutral, PublicKeyToken=null'.

  • Ok, what I see so far is you all have a Intel 3000 graphic card.

    @ijourneaux also showed that it selected a different OpenGL driver for some reason, also there is no selector programmed by me. New 1.5.6 comes with 2 version of OpenTK. Default is newest version while 1.5.5 had the old legacy library which is now a optional feature. Would be interesting to see if they differ in the selected driver. Problem is the 1.1 version is a windows generic driver not meant for the intel 3000, just a software solution I guess. That is known to not work from other threads. More important is why it gets offered if a real hardware opengl driver is installed.

    The error message with 1.0.6 is easy. You still have the new module for the server connector in your plugin directory and this needs some funtions not defined in the old dll files. So you get a error message that loading failed. No problem until you select a printer with server connector. You could also simply delete that plugin to get rid of the message.

  • So, if I understand correctly,  this seems to be an OpenTK issue. I did have the same problem (crashes) with version 1.5.5 but I did not notice what the OpenGL log message were at the time
    Let me know if there is anything I can do to help.

    In the meantime, I am will keep using version 1.0.6
Sign In or Register to comment.