motor de-energizes

I have a rumba32. I was able to get firmware uploaded but on my test setup when I move the motor it de-energizes and when I kill motor power it energizes. I also wonder if my controller reprapdiscount gldc is supported because nothing happened there.

Comments

  • Not unusual. Some drivers need enable high other enable low to energize. For this the setting
    // For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1
    #define X_ENABLE_ON 0
    #define Y_ENABLE_ON 0
    #define Z_ENABLE_ON 0

    controls the level. There are also similar settings for extruder motors.

  • These settings aren't in configuration.h
  • That was a copy form the original config and the config tool also has that option in settings.

    But maybe you are not using Repetier-Firmware?
  • Where is it in dev2
  • I put the jumpers on for a4988 stepper drivers. I tried to enable 1 and or 0. I tried to disable eeprom and LCD. I tried different stepper driver and different stepper motor. I checked the main pwr voltage. I can't open eeprom but the info gets printed in the console with double letters. Lliikkee tthhiiss. Nothing I did changed the behavior of the motor.
  • I have an error in the file c cpp properties.json. it says, " cannot find c:... buildroot/boardfiles/rumba32/stm32f4xx/f446v(c-e)t. "

    where is this file?
  • Ok in dev 2 it is different. In configuration_io.h you have something like

    IO_OUTPUT_INVERTED(IOX1Enable, ORIG_X_ENABLE_PIN)
    or
    IO_OUTPUT(IOX1Enable, ORIG_X_ENABLE_PIN)

    The _INVERTED inverts the output logic as you need it.

    Double letters - you have probably selected 2 serial devices and both are the same?

    Tried compiling Delta Rumba sample. Except a small compile bug that I fixed it worked.
    Make sure platformio.ini has
    default_envs = RUMBA32

    Required framework should install automatically. Sometimes you need to clean compilation especially when switching targets that seems to sometimes confuse compiler.

    If it still exists please post full error message. I even have no buildroot/boardfiles/rumba32/stm32f4xx - that should be part of the stm32 compiler suite under different name. Make sure to use latest git commit.
  • Ok i got a motor to move with _invert :) . I still have double letters. Some of the words are like this ssppeeeeeedd mmuulltippllyy (5). Im using a pi for the server but the double letter is the same on the pc connection.
  • Are you using repetier server for displaying communication with double letters?

    Do you have
    #define BLUETOOTH_SERIAL -1

    so only one serial is active? As that is the only reason at the moment I can think of why it happens.
Sign In or Register to comment.