Second extruder


I use a XYZ Davici 2.0A DUO with a Repetier firmware 0.92.10.
There are many issues wuth this combination, but for me now are Important two things:

1. The X axis starts to print outside of the table - let say -7 (8) mm. I MUST put the part very carefully if it is a big one. How to solve this?

2. When I print with (let say) the LEFT extruder I also MUST heathing the right ones, becouse if the Right is cold, this may compromise the print results.
For this purpose I start the txtruder Manually and when the print finishes, I stop it Manually... Can't find a way to set this into the G-Code file.

IS there a way (some M-codes) to START the Second extruder and to stop it after printing Automatically?

Thank you in advance.



  • 1. In host quite easy. Set bed left to 8 so for host it starts at 8mm and you will place objects correct. Eventually you need to reduce width to fit. Bed size/position must fit into reachable coordinates!

    2. T1 in heat commands assign it to second extruder. So add in start g-code ob your slicer
    M104 T1 S200

    and in end gcode

    M104 T1 S0

    to disable it.

    If you always only print with first extruder you can also do this in hosts start/end scripts.
  • Thank you very much!
  • Hello again.

    Because with 2.2.1 twice the entire system froses and ofcourse the prints failed, I would like to print WITHOUT a Repetier host... 

    IS there a way to set this ofset for X in the printer? (I use CURA 4.9.0 for slising and then send the G-code to the printer via Repetier host or SD card)

    Thank you in advance.

    Best Regards

  • Yes, you can tell printer that xmin is -8 instead of 0 then 0 is 8 mm to the right of home position on the bed where you expect it.
Sign In or Register to comment.