Homing freeze

After several successfull prints, my printer can no more home.

It's not really a failure but there's a freeze on first endstop touch for each axis.

go backward
min endstop hit
freeze for about 2 or 3 seconds
go forward then go backward to do the second hit
immediatly go forward to untrigger endstop

Video showing this :

On X and Y it's not a problem but BL-touch needs to be fully released after first touch, Z freezes at this time so BL-touch fails (alarm).

I made 3 prints of several hours yesterday and one this morning without problem.

Tried to reboot Repetier Server without effect.
Unplugged USB connection and home via control panel with the same problem.
Uploaded latest DEV firmware with no more effect.

Console logs :
Send:17:17:14.183: N20 G0 X20 Y20
Recv:17:17:14.190: ok 20
Recv:17:17:41.217: wait (27)
Send:17:17:41.518: N21 G28 X0
Recv:17:17:41.524: ok 21
Recv:17:17:51.523: busy:processing (5)
Recv:17:17:52.166: X:-4.00 Y:20.00 Z:10.002 E:NAN
Recv:17:18:01.170: wait (10)
Send:17:18:02.043: N22 G28 Y0
Recv:17:18:02.046: ok 22
Recv:17:18:10.206: busy:processing (4)
Recv:17:18:11.832: X:-4.00 Y:-3.00 Z:10.002 E:NAN
Recv:17:18:17.837: wait (7)

Link to Configuration.h

Repetier uploaded on Arduino Due with RADDS.


  • Recv:17:17:52.166: X:-4.00 Y:20.00 Z:10.002 E:NAN

    NAN is Not a Number so E position is causing troubles. So first thing to do is check eeprom for things like steps per mm, jerk, acceleration to be 0 or NaN. Must be one if the settings that causes it to happen and then you might get other problems from that as time computations with nan make no sense.
  • You're right (as always), Extr.3 Weight 2 was filled instead of Extr.3 Weight 1.

    Problem solved.
Sign In or Register to comment.