skipping some lines in version 1.0.4

Hi, 
I'm using FW 1.0.3 and S3D slicer. It works perfectly.
After upgrade to 1.0.4 printer skips first retraction (just fillament in, out produces blob) and do not turn fan on in first layer.
It is the same g-code as before.
I have to add retraction and fan to starting script, after that it works well.
But why? When I look to g-code, it is now two same lines, but it did only one.
Otherwise it is excelent firmware.
Thank you.

Comments

  • Can you show the part with the skipped lines and your fixed gcode so I see the gcode you talk about. Haven't had that problem so far or not registered. But maybe there is something else preventing this. 
  • edited August 7
    Hi, yes. I have two delta printers, one with 1.0.3 and second with 1.0.4. 

    This gcode works in 1.0.3:
    G90
    M83
    M106 S0
    M140 S50
    M104 S220 T0
    M109 S220 T0
    M107 ; Fan off
    G28 ; Home all axes
    G1 X-62 Y-108 Z0.4 F6000 ; Go to purge position start
    G3 X62 Y-108 I62 J108 E14 F800
    ; process Process1
    ; layer 1, Z = 0.199
    T0
    G1 E-3.6000 F2400
    ; feature inner perimeter
    ; tool H0.199 W0.440
    G1 Z0.300 F18000
    G1 X17.267 Y-3.886 F18000
    G1 Z0.199 F18000
    G1 E3.6000 F2400
    G1 X17.313 Y-3.844 E0.0023 F1680
    .
    .
    .

    And this gcode works in 1.0.4:
    G90
    M83
    M106 S0
    M140 S50
    M104 S220 T0
    M109 S220 T0
    T0
    M107 ; Fan off
    G28 ; Home all axes
    G1 X-62 Y-108 Z0.4 F6000 ; Go to purge position start
    G3 X62 Y-108 I62 J108 E14 F800
    G1 E-2.8000 F2400 - this line I added manualy in starting script
    ; process Process1
    ; layer 1, Z = 0.199
    T0
    G1 E-2.8000 F2400 - this line was skipped in 1.0.4
    ; feature inner perimeter
    ; tool H0.199 W0.440
    G1 Z0.300 F18000
    G1 X17.267 Y-3.886 F18000
    G1 Z0.199 F18000
    G1 E2.8000 F2400
    G1 X17.313 Y-3.844 E0.0023 F1680
    .
    .
    .
    Fan start working fine, if it is from second layer.
    If it should be from layer one, situation is same as with retraction.

    Thank you so much for your time, as I mention, it can be solved in starting script in S3D.
Sign In or Register to comment.