V2 firmware endstop configuration



  • Or if on a Mac 
    I guess that would make sense, if I was to read the file literally it would be A1. Will Configuration_io.h read this literally or will it assign a value of 4 based on its' position?

    looking through the pins I don't see where assigning PA4/pin 4 to the servo would accomplish anything seeing as  PA4 doesn't have a timer channel or PWM cpu pin attached to it, unless it is assigned in another file, although assigning a pin that does have a timer channel or PWM cpu pin attached to it doesn't seem to fix it either. ¯\_(ツ)_/¯

  • arduino seems to be different to platformio version. in the platformio version it is as i wrote above . I'm running on win10
  • I'm looking through https://github.com/stm32duino/Arduino_Core_STM32/pull/1092 and it incorporates some changes to the arduino core stm32 some of which are seen in my last post, changed from #define PA4  4  //D4 to #define PA4  A1  //D4. Should I update the library with these changes?
  • Number is 4 for PA 4. We use arduino pin numbering. It is easy for STM32 A = 0+number, B = 16+Number, C = 32+ Number ...

  • I tried compiling with all the original config files from the rumba32 delta example and the bltouch still doesn't work. I know it's not the same printer but maybe the bltouch would work. Do you have any examples from a cartesian rumba32 printer that has a functioning bltouch? I'm so close to having a working repetier printer. I've gotten the printer running with marlin 2 with some issues...g29 locks the printer but the bltouch works as expected. MK4Duo I'm having a bunch of problems as well. This board is just not that well documented/used.
  • No this is the only printer with that board I have. But when you upload the sample and use same pin for servo as I do you can already use the M340 commands to control it. This is completely independend of any zprobe. So try that first. Upload sample and only use M340 to test servo defined in configuration_io.h as
    // Servo for z-probe
    IO_OUTPUT(Servo1Pin, 4)
    SERVO_ANALOG(ZProbeServo, 0, Servo1Pin, 500, 2500, 1473)

    and listed in configuration.h
    #define NUM_SERVOS 1


    #define SERVO_LIST \
    { &ZProbeServo }

    That is a config where you know servo works out of the box. Once that is working you can try changing the servo pin. And as last step copy the relevant settings to your code. If it then stops working in your code you might use the same pin for something else as well causing a signal conflict. That is normally the case if a function on a pin is not doing the expected thing.
  • I have the BLTouch working, thank you. I'm running into a heater issue now. It fails on M303 S200 C5 and M104 S200

    #define NUM_HEATERS 2
    #define HEATERS \
    { &HeaterExtruder1, &HeatedBed1 }
    IO_PWM_HARDWARE(PWMExtruder1_12V, HEATER_0_PIN, 1000)

    HEAT_MANAGER_PID(HeatedBed1, 'B', 0, TempBed1, PWMBed1, 120, 255, 1000, 10, 300000, 190.05, 37.12, 648.72, 80, 255, false)
    HEAT_MANAGER_PID(HeaterExtruder1, 'E', 0, TempExt1, PWMExtruder1, 270, 255, 1000, 20, 20000, 20.25, 1.13, 90.44, 40, 255, false)

    TOOL_EXTRUDER(ToolExtruder1, 0, -13, 0, HeaterExtruder1, E1Motor, 1.75, 500, 5, 30, 5000, 177, "M117 Extruder 1", "", &Fan1PWM)
    TOOL_EXTRUDER(ToolExtruder2, 0, 13, 0, HeaterExtruder1, E2Motor, 1.75, 500, 5, 30, 5000, 177, "M117 Extruder 2", "", &Fan1PWM)

    #define HEATER_0_PIN PC6 // E0 Timer 3 Channel 1 (hotend heater physically connected to HE0)
    #define HEATER_1_PIN PA1 // bed Timer 5 Channel 2 (bed heater physically connected to HB-OUT)

    It's acting as if I have the bed and the hotend heater outputs mixed up but everything looks 
    OK, is it?
  • Can you also show heater output power in diagram? Looks like it is heating but you don‘t seem to get enough power to heat the extruder. So after a while firmware thinks it won‘t rise any more with full power as it seems from message. Are you maybe running a 24v heater with 12v? That would explain why there is not enough power.
  • Not sure what you mean 
    Repetier said:
    Can you also show heater output power in diagram? 
    Where would I find the heater output graph? Isn't that what I posted?
    The heater is 12v and runs under both Marlin and MK4duo.
  • You only show target and current temperature. In temperature output you also see how much power the extruder gets on a scale 0-255 which is what i mean. Not sure if octoprint can show it, bur our host and server do. That way you see if you get full power as the question is why don‘t you reach target temperature. It might be that pid limits output because you have reduced max pid - see eeprom config, Or is more impossible. And that you see with the power output.
Sign In or Register to comment.