hot end temp plateaus before reaching target temp

this is picking up from this post https://forum.repetier.com/discussion/7749/v2-firmware-endstop-configuration#latest
I run  M303 S200 C3 but the firmware errors out at 120

configuration.h:
#define NUM_HEATERS 2
#define HEATERS \
{ &HeaterExtruder1, &HeatedBed1 }
configurationio.h:
IO_PWM_HARDWARE(PWMExtruder1_12V, HEATER_0_PIN, 1000)
IO_PWM_HARDWARE(PWMBed1, HEATER_1_PIN, 1000)

HEAT_MANAGER_PID(HeatedBed1, 'B', 0, TempBed1, PWMBed1, 120, 255, 1000, 10, 300000, 190.05, 37.12, 648.72, 80, 255, false)
HEAT_MANAGER_PID(HeaterExtruder1, 'E', 0, TempExt1, PWMExtruder1, 270, 255, 1000, 20, 20000, 20.25, 1.13, 90.44, 40, 255, false)

TOOL_EXTRUDER(ToolExtruder1, 0, -13, 0, HeaterExtruder1, E1Motor, 1.75, 500, 5, 30, 5000, 177, "M117 Extruder 1", "", &Fan1PWM)
TOOL_EXTRUDER(ToolExtruder2, 0, 13, 0, HeaterExtruder1, E2Motor, 1.75, 500, 5, 30, 5000, 177, "M117 Extruder 2", "", &Fan1PWM)

rumba32.h
#define HEATER_0_PIN PC6 // E0 Timer 3 Channel 1 (hotend heater physically connected to HE0)
#define HEATER_1_PIN PA1 // bed Timer 5 Channel 2 (bed heater physically connected to HB-OUT)

It's acting as if I have the bed and the hotend heater outputs mixed up but everything looks 
OK, is it?

Comments

  • edited July 20
    here are the configuration files...oh wait...how do I attach the configuration files?
  • You can‘t attach files here. But it is already clear that you will never reach 200°c - either your heater has not enough power because maybe the cartridge is for 24v running on 12v or the temperature sensor is reporting wrong values due to selecting wrong curve type. You see firmware sends full power and there is no more temperature rise and more power then 100% is not possible.
  • I must have the wrong curve type for the sensor, the heater works as expected with Marlin 2 firmware. Supposedly it has a Epcos 100k for an E3 V6 heater block and the curve I have selected is 
    IO_TEMP_TABLE_NTC(TempTableEpcos, Epcos_B57560G0107F000)
  • Epcos has probably a hundred different sensors with 100k, must not necessarily be that one. That one was used at the beginning of reprap printers a lot, but then they stopped producing that type as far as I remember.
  • I tried several different curves, NTC 3950 and EPCOS 550 with the same results so it's not the thermistors. The heater is definitely a 12v heater. Any suggestions?
  • As long as output curve shows it is using 100% it will not really improve. Exception might only be if some other function is also using that pin causing values to change. When you check the board do you see the output led is full on or is it flickering? If no flicker and full light then it has full power and it can not get more power to the extruder.
  • I haven't had a chance to test yet but I was looking through the pin assignments and this is what I found:
    configuration.io.h:
    IO_ANALOG_INPUT(IOAnalogExt1, TEMP_0_PIN, 5) pin 5 is listed as PA5 
    but in variants.h
    #define TEMP_0_PIN static_cast<int>(PC_4) // T0 pin is listed as PC4 which is pin 36 not pin 5
    and pin 5 is #define PIN_SPI_SCK PA5
  • should I change TEMP_0_PIN to pin 36, TEMP_2_PIN to pin 35, and  TEMP_1_PIN to pin 32?





  • 5 is oversampling rate, not pin number

Sign In or Register to comment.