Almost there.... and strange behaviour

So the dev time was nice enough to add the Open Motion Controller to the list and i copied over as many settings from marlin firmware i could

I got Repetier uploaded but its not quite working

All endstops report L as they should when not triggered.
Extruder Fan works
Heat bed works
Extruder works

Now the BIG but:

When steppers should be disabled they are enabled, and when they are not enabled the electronics fan are enabled even thou i belive the fan should not be automatic?

So after the idle time out it enabled the stepper... when i send it a G0 Z1 to move the Z it disables the steppers and turns on the fan.... the  steppers do not move

Its the same on the other axes....

The Open Motion controller uses the Toshiba TB6560AHQ drivers

Have anyone ever experienced this?


  • The enable signal can be inverted

    #define X_ENABLE_ON 0
    #define Y_ENABLE_ON 0
    #define Z_ENABLE_ON 0

    then need a 1, same for extruder motors. Also remember they all share the same enable signal.

    For your fan problem, write a simple sketch changing pin 10 (enable pin). See blink example and simply change 13 to 10 and increase time to 5 seconds. If then fan goes on/off with pin 10 you have simply a cross connection between pin 10 and fan pin 14 on your board.
  • I know they share the same pin.... 

    Will try the signal inverted... and might well be it...

    For the fan, no there is no cross connection... It works perfectly with Marlin firmware :-/

    But of course will double check that i have the pin definitions right
  • Also Digital Pin 14 should be the extruder right? that one is working perfectly.....

    Its Digital Pin 15 that is the issue... its the Print bed cooling fan right? and that one should only come on after the print is done....
  • We have no print bed cooling fan. 14 is the normal fan for cooling your model. But of course depends on your config file.
  • np, i'm print a few parts for my Mendel90 on marlin firmware right now but will give it another go once they are done... 

    once i get it working are there any good video guides you can recommend on how to tune the speed settings?
  • None I know. Tuning is more a personal taste as more speed gets printer more jerky and quality goes down. So it is more finding your point of personal like where you find quality acceptable and speed is as fast as it can.

    describes teh parameters in more detail and how they influence the print.
  • Thanks for that

    I also just tested your suggestions for settings.... they work great

    Only one thing left.... The steppers are noisy, are there any settings that can influence that?

    Sure that when you added the open motion board that you got the timing for the toshiba steppers right?
  • Ahh, just noticed that it also skips a lot of steps....

    Y is the most noticeable.... i can tell it to move more than 200mm and it cant move more than 210mm
  • in the video i move the Y carriage 100mm at a time and then 10

  • more obvisous there: 
  • edited April 2015
    could it be that the toshiba steppers are set to 16 microsteps? 

    I have jumpers for decay, torque, and microsteps

    microsteps are set to 16
    torque is set to 50
    decay is set to 50
  • Board selection never sets stepper timings. That has to be done independently.

    More microsteps give less noise.
  • In the marlin firmware there are stepper timing special for the toshiba steppers

    Where in repetier can i change the timing so they match?

    The noise are not there with the copy of marlin i have, so i must have forgotten to change something in repetier not obvisous to me

  • oh

    must be these ones right?

    #define STEPPER_HIGH_DELAY 0
    #define DIRECTION_DELAY 0
    #define STEP_DOUBLER_FREQUENCY 12000
    #define DOUBLE_STEP_DELAY 1 // time in microseconds
    #define MAX_HALFSTEP_INTERVAL 1999
  • Next problem is finding the right value... on a google hunt and so far only found this:

    "The problem with this was that Sprinter and Marlin toggles the step pin for only 1-5uS, and the TB6560 wants something around >60uS, if I remember correctly. "

    will try and find the right value
  • edited April 2015
    The value was correct, depending on what Capacitor used with the stepper chip it should be between 30 and 60 µS

    and if you look carefull that turns out to be a half truth

    page 10..... i have 100 pf caps so should use 10 μs width

    now where do i change that?

  • Just where you found it

    #define STEPPER_HIGH_DELAY 10
    #define DIRECTION_DELAY 10
    #define DOUBLE_STEP_DELAY 10

    or whatever timing in us you need,Just also adjust your max. feedrate that these timings are possible. So if you have 10 high to low that makes 20us per step => 1000000 / 20 = 50000 hz. But you also need some time for computations so reduce at least 20% i guess. Higher delays reduce speed more, but better slow then wrong.
  • So if i want 10 µS i should really say 5?

    but you are right, better play safe than wrecking something.

    Will give the new settings a go during weekend

    If they are right can you make use of a copy of the settings ? i was thinking if some of them could be default for the board?
  • So if i want 10 µS i should really say 5?
    but you are right, better play safe than wrecking something.
    Will give the new settings a go during weekend
    If they are right can you make use of a copy of the settings ? i was thinking if some of them could be default for the board?
    The rest of my settings for steppers are:

    Do they look right?
  • Not sure if you can handle the high travel acceleration, but could work.
    is quite high for screw driven z axis. Better use 100 like for traveleing.
  • yaa, now the steppers move noiseless :-D

    time to compare settings from marlin and match as close i can :-D

  • one thing noted thou... Repetier does not react on M84 (disable steppers)
  • also i searched the forum, but how do i tell the printer firmware that 0,0 is at the center of the bed?

    do i just set the min x and y to half of total lenght on each axis?
  • edited April 2015
    I spoke to soon... 

    i can move the printer manual in both pronterface and repetier host... i can turn bed and extruder heater on and off... the extruder fan also works... no faults there now...

    but when i load an object in repetier host and slice it and ask it to print it moves very strange... and at the time where it should print the object it does only move like 1 mm very sporadic.... not like a print at all...

    its the same if i slice it with kisslicer first and then load the gcode in repetier...

    small video:

  • Not sure I ever tried to move 0,0 to center, but yes xmin and y min must be -xlength/2 and -ylength/2. Not the minus! Length stays unaffected.

    For your printer problem that is very strange. First always check what log is saying. Watch especially for communication problems like resends. Bad connection can have weird results while printing.

    M84 normally works. You have a special problem with all motors sharing same enable pin, so all motors must want to be off including extruders.
  • edited April 2015
    I got the 0,0 issue sorted

    M84 simply just dont work, i have LED's on all of the stepper drivers so i can see if they are enabled or not. The LED's stay on when i send a M84

    Connections..... This one is strange.... I can move the printer arround manual in Repetier host without any problem...

    But as soon i send a printjob it behaves very odd.... 

    Is there any stl file i can slice and print that makes finding the issue any more easy?

    I know these toshiba steppers are a pain to drive.... they need a longer pulse width that normal...  but also they can only handle 10000 pulses a sec.... the pulses a sec is simple to handle... just keep the feedrate low enough... 

    if it gets to many pulses it will make a "clonck" sound when it makes non print moves. 

    but maybe i made the mistake of making a higher delay on the direction pin... it's only the step pin that need this special handing... 

    will a complete working copy of marlin make you able to spot anything?
  • As I already said, check your complete print log (the one written to disk if you have logging in host enabled). Check what happens when it starts stuttering. I guess you will see some problems in the log that explain it.
  • i had some time to check this out...

    i loaded up and gcode i know works (its a simple spacer ring for my extruder)

    In repetier host i see the X and Y change but nothing happens other than these small moves...

    Video of it: 

    the clonck at  52 sec are just the steppers that enable. the print starts at 1 min....

    What it should do is starting with a fat 5cm line to prime the extruder.... but it moves directly to where it should print.. and then these funny small moves.

    The log says a lot of wait but nothing gives me a clue
  • line 311 in the pastebin is what should makethe fat line at the edge of the bed

    i tried to slice the same stl with cura in repetier host and the outcome was the same....

Sign In or Register to comment.