Offset x,y, 47 steps out of centre can anyone help ?

First off my name is Michelle, last year a friend in the USA sent me a home made 3dp built using the following firmware from the printer was never set-up correctly from the get go, albeit it works, it has to be manually configured every time the printer is switched on with offsets Y-47, & X-47 otherwise the printer head crashes into the farthermost end-stop which does not have a end-stop switch and can be a disaster on the belts, motor, and stresses to the mechanical parts. If by some reason a reset occurs without my knowledge this is also bad. I am fairly new to 3D Printing I am at a loss on how to store the offsets to the firmware. what I would like to do is retrieve the existing firmware from the eeprom and make changes to the offsets and re-upload it, but I am more likely to completely destroy it if not guided on how to do this as I know nothing about arduino based programming. I have done some research online and tried to send the following some articles but it does not seem to work for me. Is it possible I have a deaf eeprom ? i.e. not accepting new values.

It would be much appreciated if anyone could help me solve this 10 month old problem that been driving me crazy.

Printer details: Prusa I3, Home Built, using firmware 0.92.6
controller LCD: RepRapDiscount Smart Controller

It has a red pcb extention board to interface with the LCD cables then to the LCD

Michelle xoxoxox


  • I made a youtube livestream video about my problem

  • If you home xy min then firmware limits position to x/y min plus x/y length. All values are stored in eeprom so just open eeprom editor in repetier-host and adjust coordinates. Set xy min so that 0 is over the bed and reduce xy length so that it is limited to what you can reach. Also set same limits to host so host will not move past the limits and gives warnings if models would do so. That way you would normally never try to exceed limits after homing (before homing it is still possible so always home first). Only way to exceed it now is if you loose steps, but if that happens nothing can prevent it except settings that cause no lost steps. Normally jerk, acceleration or max. speed are too high in that case.
  • Thank you for a quick response, before my x,y, min was set to minus -50 due to alignment issues with the virtual bed platter in software now I set x,y, min to 3 and max x,y, to 197 will test this but seems good so far at least in software plotting alignment. I will let you know how I get on thanks.
  • Thanks so  much its working great now tested on cura and Slicr3 both centred correctly now thanks :)


    PS, I did make a donation in August to Repetier for £15 will try and send a bit more thank you.
Sign In or Register to comment.