Firmware Configuration Issues

I have been having a heck of a time trying to get firmware to compile, originally i was trying to get firmware compiled for my printer, now i am just trying to see if i can make it compile without errors. Not sure if it is something I am doing, or something I am missing.
I go to the configuration site. Start with version 92.9 and Arduino 1.0.2  (since this is where my printer started)..
I started with pretty much everything at the default settings, added 2 extra extruders and the user interface. The extruders are left at default settings.
I get an error trying to compile the firmware (ext_temp_3..), so i removed all but 1 extruder. This compiled ok (using Arduino version 1.0.2)
I add an extruder (total of 2) and try to compile with Arduino version 1.0.2 and it compiles with no error
I add the third extruder and try to compile with version 1.0.2 and I get the error Temp_3_Pin was not defined in this scope. 
This is not using an existing configuration file, this is just setting up with the configuration tool.

 I switched to Firmware 1.0.2 and setup 3 extruders (same interface board) and try to compile with Arduino 1.0.2 and get an SDFat error. Could be Arduino version, so i try to compile with 1.8.5 and get an error Temp_3_Pin not declared in this scope.

This is with the config tool only.. 

What am i missing?


  • What Hardware do you use?
  • Sorry, what do you mean what hardware?
    I have a Dell laptop running windows 7.
    i have set the processor as "Atmel- 8-bit based board and a RAMPS 1.3/1.4 Motherboard. The board has been identified as a 3DYMY RAMPSPLUS2 board
  • Ramps only supports 2 extruders.
    that´s why you get error message for temp3 pin ,E2 pins etc.
    see pins.h in repetier firmware folder. there are no pin defines for 3rd extruder ,heater ,stepper.

    if you want to add third Extruder via configuration tool you have to select the pin numbers (f.e. digital pin ..    or analog pin...) and not the names as you did (temp_3_pin)

  • With this in mind.. I looked again at what the manufacturer sent me (this is for an HE3D EI3 printer).. 
    They had digital pin 7 defined as the heater pin for extruder 1 and heater 3 defined for the heater pin on extruder #2
    if this board does not support 3 extruders native, and i need to define this in the pins.h file, where would i find a pinout so i can correctly set this up?
    I looked in the pins.h file that they sent, but i am not familiar with how this was written and dont fully understand what i am looking at.

    any guidance would be greatly appreciated.

  • edited July 2018
    well what about sharing the firmware the manufacturer sent?

    is it this one?

  • here is the file that was sent (i tried to upload it before but it gave me an error).

  • edited July 2018
    Ok, found.
    the manufacturer changed repetier pins.h where the missing pins are assigned.
    but cannot see your uploaded file

  • you can try to copy manufacturers pins.h  to the repetier folder giving the compile error. should work then
  • how about these?
  • From the original rampsplus firmware you need to edit the pins.h file, motherboard 33 section and replace the relavent section with this.  I allso attached the whole pins.h file if you want to just replace the whole thing

    #if MOTHERBOARD == 33
    #define KNOWN_BOARD 1
    #define RAMPS_V_1_3
    #elif MOTHERBOARD == 34
    #define KNOWN_BOARD 1
    #define RAMPS_V_1_3
    #define AZTEEG_X3
    #elif MOTHERBOARD == 35
    #define KNOWN_BOARD 1
    #define RAMPS_V_1_3
    #define AZTEEG_X3_PRO
    #define KNOWN_BOARD 1

    #if !(defined (__AVR_ATmega1280__ ) || defined (__AVR_ATmega2560__ ))
    #error Oops!  Make sure you have 'Arduino Mega' selected from the 'Tools -> Boards' menu.

    // uncomment one of the following lines for RAMPS v1.3 or v1.0, comment both for v1.2 or 1.1
    // #define RAMPS_V_1_3
    // #define RAMPS_V_1_0

    #ifdef RAMPS_V_1_3

    #define ORIG_X_STEP_PIN         54
    #define ORIG_X_DIR_PIN          55
    #define ORIG_X_ENABLE_PIN       38
    #define ORIG_X_MIN_PIN          3
    #define ORIG_X_MAX_PIN          2

    #define ORIG_Y_STEP_PIN         60
    #define ORIG_Y_DIR_PIN          61
    #define ORIG_Y_ENABLE_PIN       56
    #define ORIG_Y_MIN_PIN          14
    #define ORIG_Y_MAX_PIN          15

    #define ORIG_Z_STEP_PIN         46
    #define ORIG_Z_DIR_PIN          48
    #define ORIG_Z_ENABLE_PIN       62
    #define ORIG_Z_MIN_PIN          18
    #define ORIG_Z_MAX_PIN          19

    #define ORIG_E0_STEP_PIN         26
    #define ORIG_E0_DIR_PIN          28
    #define ORIG_E0_ENABLE_PIN       24

    #define ORIG_E1_STEP_PIN         36
    #define ORIG_E1_DIR_PIN          34
    #define ORIG_E1_ENABLE_PIN       30

    #define ORIG_E2_STEP_PIN         42
    #define ORIG_E2_DIR_PIN          40
    #define ORIG_E2_ENABLE_PIN       44

    #define SDPOWER            -1
    #define SDSS               53
    #define ORIG_SDCARDDETECT     49

    #define LED_PIN            13
    #define ORIG_FAN_PIN            9
    #define ORIG_PS_ON_PIN          12

    #define HEATER_0_PIN       10
    #define HEATER_1_PIN       8
    #define HEATER_2_PIN       7
    #define HEATER_3_PIN       45

    #define TEMP_0_PIN         13   
    #define TEMP_1_PIN         14
    #define TEMP_2_PIN         15
    #define TEMP_3_PIN         12

    #else // RAMPS_V_1_1 or RAMPS_V_1_2 as default

  • how do i upload files?? they keep getting removed
  • renamed zip file
  • i must not be living right..
    I now get this error (using Arduino 1.8.5 and version 1.0.2 of the firmware)

    1.8.5/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld.exe: C:\Users\asd\AppData\Local\Temp\arduino_build_993135/Repetier.ino.elf section `.text' will not fit in region `text'

    c:/users/asd/downloads/arduino-1.8.5-windows/arduino-1.8.5/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld.exe: region `text' overflowed by 24122 bytes

    collect2.exe: error: ld returned 1 exit status

    Using library SPI at version 1.0 in folder: C:\Users\asd\Downloads\arduino-1.8.5-windows\arduino-1.8.5\hardware\arduino\avr\libraries\SPI 
    exit status 1
    Error compiling for board Arduino/Genuino Mega or Mega 2560.

  • FINALLY!!!
    Got a clean compile, AND i think i have a better understanding of this process.
    I copied the OEM pins.h file to the newly downloaded repetier directory and tried to compile, got an error about SDFat... So looking in the OEM directory, i found a file named sdfat.h and figured what the heck, copied it to the directory and got a clean compile.
    So.. if i understand correct, the *.h files are the files that are used to compile the firmware but are not created by the config tool. These files are created / altered by the printer manufacturer if needed to support their printers.
    Would this be accurate??

  • I have been able to compile without error on a Windows 7 machine, i am having an issue getting the USB drive to load.
    I have a windows 10 machine that I have been able to get the driver to load and have been able to communicate with the printer but, the firmware will not compile on it.
    Is there an issue with Arduino 1.8.5 on Windows 10? or is there a preferred version of Arduino that I should be using?
  • Is there a version of the Arduino software that would work better with Windows 10?
    I "was" able to compile on my Windows 7 workstation, but that machine is no longer an option.
    The same code (its on a usb drive), gives me a general error when trying to verify on a Windows 10 workstation.

  • ok.. I "think" i found the issue.
    I had left the processor selected as the ATMega1280, when i changed it to ATMega2560, the code compiled without issue.

    Is there a command that I can run on the printer to find which processor it actually has?

  • In the arduino software tools menu, click on 'get board info'
Sign In or Register to comment.