Issue with enabled "Z-Probing" on zonestar based printer with repetier 0.92.0

edited June 2018 in Bug Reports

I've got a zonestar (or anet) based printer using a Melzi 2.0 based board with an inductive sensor mounted next to the nozzle. this is the only z endstop indicator the printer has as there is no microswitch mounted on any of the z rods.

Everything is working great until I try to enable 'Z-Probing' in the configuration file.

Normally, when the printer homes it would slowly lower, trigger the endstop, raise a bit and then lower slowly until the z-endstop is triggered again.

However, when enabling Z-Probing weird behaviour is observed:
* The head lowers as before.
* When the sensor triggers, the head rises a bit.
* It would then start lowering slowly like before.
* When triggered a second time, instead of stopping it would instead increase speed without stopping.

I'm not sure if this is a bug or something I did wrong, my configurations file can be found here:



    1. #define Z_PROBE_X_OFFSET 0   These 2 values are how far the probe is mounted from the nozzzle
    2. #define Z_PROBE_Y_OFFSET 0
    3. #define Z_PROBE_SWITCHING_DISTANCE 1     < I would increase this to about 4 to make sure probe has chance to untrigger
    4. #define Z_PROBE_HEIGHT 0  This is the actuall Z distance from the bed to the nozzle when the probe triggers.
    5. used to set Z0

  • edited June 2018
    Thanks for the reply!

    I forget to mention that in one of my previous attempts, I tried setting z_probr_height to 0, that did not help however.

    I'll try the other suggested settings a bit later, but I still don't understand why they cause the printer to behave like that.

    Some things I forgot to mention:
    * I tried trigerring the probe above the bed manually with something conductive, the same behavior was observed without stopping (I had to power the printer down when it reached the build plate).
    * Perhaps even more important, the weird thing with this is that this happens whenever I try to home z, I didn't even start the bed leveling procces yet.
  • I suggest upgradeing to the ver 1.0.2 firmware as there have been many improvements to the levelling/probing
  • I tried that as well but am unable to use it since the firmware ends up being too large.
  • Use only one language and remove some features not necessary. I know it is tight, but it should fit if enough is disabled.
  • I've just tried with version 1.0.2 after disabling almost everything.

    The configuration file can be found here:

    However, the same behavior can be observed as before when homing Z (no bed leveling actions taken yet).

    As soon as z triggers twice, (second time after going up and then slowly going back down) the printer continues moving down faster, I've even tried retriggeting the z-stop to no avail.

    Maybe there's something wrong with my configurations?

  • I see you have
    #define Z_PROBE_HEIGHT 0
    for a inductive probe. That is in 99% wrong as the inductive probe will trigger before nozzle touches the head. That is the nice thing with these probes. Then when finished it would go down the z probe height. 

    So have a look what you have stored in eeprom as this overrides your values in configuration.h. The values there should not produce the problem. You can also run
    to copy config to eeprom and then test what happens.

    Also set 

    otherwise the position for homing z is ignored.
  • I have the same Problem, using Firmware 0.92.9. The 1.0.x are to big for the ANet 1.0 board, maybe if i disable things like LCD Display...but then the firmware is near useless. I have only 3kb to less, but no idea, what more i can drop.

    I have MIN Z Stop switch and NPN Sensor parallel on same input pin….but this is ok and work. Merlin can use it, so wiring must be right.

    Ok, back to 0.92.9:

    Homing work fine, if FEATURE_Z_PROBE is disabled, so i think about where must be the mistake and drink two coffee.

    Then i set Z_PROBE_PIN 10, is useless on this Board...but Z Homing work again. So the way to found this Bug is that for Z Probe and for Z Homing on ANet 1.0 is using the same Input Pin. And as ebuyum say, this happens in 1.0.2 day we found the reason and can hope for a bugfix on 0.92.x :)

    I want use repetier firmware with auto bed leveling, i hope i can found the mistake or a workaround self. Without have reading and unterstand the source, i should check at first the interrupts routine and global variable, there should be hide our trouble.

    Sry for bad english, i think german and try to translate in english.

  • a short very quick workaround, not full testing, special the autolevel function


    #define MIN_HARDWARE_ENDSTOP_Z false 
    #define ENDSTOP_PULLUP_Z_MIN true
    #define ENDSTOP_Z_MIN_INVERTING true

    i have to add the offset of probesensor to nozzle in Z_PROBE_X1, Z_PROBE_Y1 .... Z_PROBE_Y3.
    I may missunterstand, but Z_PROBE_X_OFFSET and Z_PROBE_Y_OFFSET not work for me. On the Z_PROBE_XY is the Nozzle, not the sensor
    Probing is prehaps on the wrong point now and may give a new problem...but the printer try to work with autolevel and homeing work too without fault smile.

    Z-HOMING is now just set the Z Pos as Z0.

    Before try it after UPLOAD the new firmware do 
    Look like is important.

    No more time, but i will try to found a real bugfix on the next weeks
Sign In or Register to comment.