Issue with enabled "Z-Probing" on zonestar based printer with repetier 0.92.0

edited June 2018 in Bug Reports
Hey,

I've got a zonestar (or anet) based printer using a Melzi 2.0 based board with an inductive sensor mounted next to the nozzle. this is the only z endstop indicator the printer has as there is no microswitch mounted on any of the z rods.

Everything is working great until I try to enable 'Z-Probing' in the configuration file.

Normally, when the printer homes it would slowly lower, trigger the endstop, raise a bit and then lower slowly until the z-endstop is triggered again.

However, when enabling Z-Probing weird behaviour is observed:
* The head lowers as before.
* When the sensor triggers, the head rises a bit.
* It would then start lowering slowly like before.
* When triggered a second time, instead of stopping it would instead increase speed without stopping.

I'm not sure if this is a bug or something I did wrong, my configurations file can be found here:
https://pastebin.com/ZgLHXjMR

Thanks.

Comments

    1. #define Z_PROBE_X_OFFSET 0   These 2 values are how far the probe is mounted from the nozzzle
    2. #define Z_PROBE_Y_OFFSET 0
    3. #define Z_PROBE_SWITCHING_DISTANCE 1     < I would increase this to about 4 to make sure probe has chance to untrigger
    4. #define Z_PROBE_HEIGHT 0  This is the actuall Z distance from the bed to the nozzle when the probe triggers.
    5. used to set Z0

  • edited June 2018
    Thanks for the reply!

    I forget to mention that in one of my previous attempts, I tried setting z_probr_height to 0, that did not help however.

    I'll try the other suggested settings a bit later, but I still don't understand why they cause the printer to behave like that.

    Some things I forgot to mention:
    * I tried trigerring the probe above the bed manually with something conductive, the same behavior was observed without stopping (I had to power the printer down when it reached the build plate).
    * Perhaps even more important, the weird thing with this is that this happens whenever I try to home z, I didn't even start the bed leveling procces yet.
  • I suggest upgradeing to the ver 1.0.2 firmware as there have been many improvements to the levelling/probing

    https://www.repetier.com/firmware/v100/index.php
  • I tried that as well but am unable to use it since the firmware ends up being too large.
  • Use only one language and remove some features not necessary. I know it is tight, but it should fit if enough is disabled.
  • I've just tried with version 1.0.2 after disabling almost everything.

    The configuration file can be found here:
    https://pastebin.com/ayJaC7Jk

    However, the same behavior can be observed as before when homing Z (no bed leveling actions taken yet).

    As soon as z triggers twice, (second time after going up and then slowly going back down) the printer continues moving down faster, I've even tried retriggeting the z-stop to no avail.

    Maybe there's something wrong with my configurations?


    Thanks!
  • I see you have
    #define Z_PROBE_HEIGHT 0
    for a inductive probe. That is in 99% wrong as the inductive probe will trigger before nozzle touches the head. That is the nice thing with these probes. Then when finished it would go down the z probe height. 

    So have a look what you have stored in eeprom as this overrides your values in configuration.h. The values there should not produce the problem. You can also run
    M502
    M500
    to copy config to eeprom and then test what happens.

    Also set 
    #define HOMING_ORDER HOME_ORDER_XYTZ

    otherwise the position for homing z is ignored.
Sign In or Register to comment.