TMC2130 direction and torque problem

I changed steppers from A4988 to TMC2130 (x,y,z-axis) on my Ramps 1.4. The z-axis is working fine,
but the x and y are having problems.

When home x, the direction is correct towards the x min stop, but when controlling from the host to plus (+) direction movement is continued wrongly towards x min stop. And vice versa when controlling to minus (-) direction the movement is towards x max stop.

Second problem is torque, there aren't any. The carriage barely moves and I can only control 1 mm increments, trying 10 mm only makes a noise and the carriage barely moves. Same with the y-axis. Z-axis is working just fine. Also with the A4988 I had no problems.

Any suggestions are welcome! 


  • Strange behaviour direction movement was caused by end stops. In sensorless homing config should be:
    #define ENDSTOP_PULLUP_X_MIN false  // for TMC
    #define ENDSTOP_X_MIN_INVERTING false   // for TMC
    -> directional problem solved for x-axis (same applied to y-axis)

    Not enough torque was solved by increasing the voltage from the pot. And I realized that the Watterot neede CFG5 & CFG4 to be soldered (Standalone was already open = SPI mode) for the SPI bus to come alive.

    Not properly moving sensorless homing needed slight increase in sensitivity value to become less sensitive.

    Thank you all those various posts and youtube videos to solve my problems:
    @Virtualchronos and @PioniSensei did you make any adjustments to the potentiometer on the step-sticks.

    If I understood things correctly, to have access to the entire range of current settings via SPI the potentiometer should be at it maximum value. Note that it has no physical maximum limit - you have to determine the maximum value with a multi-meter on the VRef pin.

    Sorry for not being more present here lately - the company I work for is being acquired and it's a little messy, eats up a lot of my time. Hope this improves soon.

  • edited May 2018
    Great info on the TMC2130s.  I've had to slow my steppers way down because of skipping.  I have pretty powerful 2 amp, 84 steppers and if the feedrate is higher than 80 or 100, they skip.  If they are too high they just vibrate.

    So all you did was turn up the POT a little?
Sign In or Register to comment.