Trouble with steps/mm settings

edited March 2015 in Motor Control

For last few days i have been trying to adjust my printer, but for some reason every time I cahnge stepss per mm count it does nothing.

I am using custom printer driven by M8 rods and even with 12000+ (given by calculation) steps per mm it only moves few mm, same as before(2560,3200,4200).

I don't know what to with it. I know it's unusual printer, but something would change with these settings, or have I made mistake in Repetier host? 

I must also metion that behavior of X and Y are the same, but Z even more slower does even less moves.



  • Assuming you have eeprom enabled, all you need to do is change values in eeprom.

    Also check your ptinter length settings in eeprom.

    After changing you might reopen eeprom settings to see if the values got set.

    If you have specialproblems with z remember that rods can only move very slow (2-5mm depends on motor, greasing,..) with accelerations of around 50mm/s^3. If you try more you get many loosing steps so speed is not what you say.
  • edited March 2015

    Eeeprom was enabled from start and setting were applied with each firmware flash.

    Lenght was set in firmware configurator, but I don't see that option in printer menu.

    Settings from last flash are there so that is right.

    I don't get that part with Z-it's the same setup as X and Y-same motors,same rod, same steps per mm,same acc-why would it go slower? Is any part of firmware disabling fast movement of Z?

    I can get good feedrate on X and Y-300 and they have no problem doing that, but as I said before-it refuses to move exact number of mm. I measured that X moved 1,64 mm for 50 mm command with any feedrate setting.

    Using formula for steps per mm (N=N*lenght in command/lenght moved) I got 128048 with previous stepps per mm 4200.

    Last night I reverted to original 2560 and it's same.

  • edited March 2015


    I tried to do something about this situation and results are weird.

    Using normal settings for M8 threaded rod (1/16, 2560 steps) I olaced jumpers on ramps and tied 1/81 1/4 and even half step. With half step I achieved 12 mm move for 50 mm command in Repetier host. Also, funny thing 75 mm/s for hlaf step is as fast as 300 mm/s for 1/16.

    Also, Z motors now doesn't want to move at all-they have stanrd settings and jumpers.

    So, what is the problem? Is is the host issue or this firmware is just no good for this type of printer?

  • M8 1/16 steps is 2560 steps per mm. There you can go as fast as 2-4 mm/s if acceleration is 50mm/s. Not sure why you mention speeds like 75 or 300mm/s these are very fast speeds and nothing to start testing with.

    What is your x-y drive? If it is not rod based but belt driven it is < 200 steps/mm on most cases at 1/16. Also here try starting with slow moves to see if it works. Then you can check how fast you get.

    It all sounds  like loosing steps for sending signals much too fast. Eventuelly combined with current set too low. You should see that if motors are enabled and you can still easy turn/move it is too low. With enable dmotors is quite hard to move the extruder/bed.
  • As I mention I tried default settings for all axes, but I can't get decent moves unless I bump the speed and acceleration.

    X and Y are also driven by M8 rods.

    I tried numerous settings but nothing works. Does Repetier firmware have problems with DRV8825?

  • I just tested Marlin firmware with Repetier host and everything is working fine with my settings.

    So, the error is in Repetier firmware.

  • DRV8825 work but you might need to set STEPPER_HIGH_DELAY 1 since driver needs a longer time to get signals.
  • I did it and it improved, but only a little bit. Should I put it 2?

    Also, what to input in Repetier host Travel feed Rate and Z-Axis Feed Rate? I think that also could be a problem.

  • I think they need 1,8us so I would expect 1 + program time would be enough, but testing never hurts.

    Speeds in host should match what your printer can handle. Just watch units - mm/min in host mm/s in firmware!

    Also try first slow moves and then see where you can go.
  • It took me some time to get it sorted out, but it failed again.

    Only thing I got was uber slow movement.

  • Based on available data I can not see where the problem is. I know it works but something must be set wrong in your case and since even long delays do not work it is not that the stepper is missing the signals. So if we assume steps per mm are set right you are loosing steps for some reason (acceleration/speed too high, current too low, ...)
  • Nothing is set wrong. As I said, Marlin is working fine with same settings.

    Repetier firmware is not working even with everything reduced. HW is working perfectly and all is tested.

    Every setting I did to Repetier FW was inside the configurator-each new setting was new FW download and flash.

    Do you want me to upload FW so you can check it?

  • Did you have eeprom disabled? Otherwise changing parameter has no effect,

    No, I can not check that problem without the same printer. Since the motors turn and always check endstops is disabled, only steppe rhigh delay, steps per mm, acceleration and max speed count and I assume you can set them.

  • Eeprom is enabled.

    AS I said (and I can wote it 50 more times)-I tested varoius settings-my own calculations, your recommendation adn even below you recommendation and Repetier FW is NOT working-but Marlin is.

    Why? I don't know.

  • I'm currently also out of ideas, sorry.
  • Sorry for late response, but I really don't have time to write about this topic anymore.

    Here are my settings,please check them and tell me if something is wrong:

  • So,zero response?
  • No ideas. I already said what I thought could be the reason. But maybe someone else has an idea?
  • I have no idea, but I have the same problem (X, Y are belt driven, 80s/mm works fine) but z is wierd (2mm/rev ACME screw), it behaves just like 3DMistery reported.
    It is a bug in the firware.. affecting only Z-axis (it appears that parameters in Configuration.h are not taken into account later).
  • They arent taken in account if you have eeprom enabled. Then you need to change them in eeprom only.
  • Yes.. However, the problem persisted until I went to older version(0.91). It is OK now.
  • I have the same problem with z axis, no matter what I put in as steps per mm in z axis movement distance never changes, yes I have made other changes that have worked, so the eeprom is enabled.
  • Just tested with 0.92.3 and I could change z steps per mm in eeprom and it had definitively an effect.

    If you change it and send it to eeprom and open eeprom again, does it show the new value? For some reason I heard some users had exactly this part fail also it is unclear why. If you sen

    M206 T3 X102 P11

    it should set Z axis steps per mm to 102. That should always work.

  • ok, I got it working, I have a Azteeg X3 Pro with SD8825 stepper drives installed on a rigidbot frame. I had 1/32 micro selected for all axis, I had to set z axis and both extruders to 1/16 micro. then I could change steps in them, before changing I could not.
  • So making a hardware change causes the software to work. Also I'm happy it now works that does not really make sense to me that this makes a difference. What steps per mm did you have before and to what did you try to set it? The M206 simply writes any value to eeprom so even if it later would cause a overflow it should at least appear in eeprom settings.
  • Sorry to revive this thread but I believe I might have some more insight.

    Got the same trouble as 3dMistery described, that changing steps/mm doesn't affect printer behavior.
    I poked around in uilang.cpp so it printed the actual values of steps/mm on the display
    and it confirmed that both x and y are hardwired to 4 steps/mm and z is 10 steps/mm. They don't change
    no matter what values I enter in configuration.h. I tried downloading a new version through the configurator
    too and it still got the same values.

    Haven't had time to look further into why the stepping values end up static but there is definitely something
    wrong here.
  • Did you try to change it in EEPROM settings directly? I.e. via Repetier host configuration tool? (Uploading a new firmware with EEPROM setting 1 will NOT change the values for steps/mm - in contrast to Marlin)
  • I haven't gotten that far yet, the printer is still under construction. My idea was to try moving around the parts to test the wiring.
    Anyway the eeprom_mode parameter was the key. The issue is correctly mentioned in the introduction as the "eeprom trap" :) Thanks for helping out!
  • No problem, glad to be of help! :) (btw: I do think 3dMistery had exactly the same problem but didn't realize)
  • edited April 2016
    Hi i had same problem with set STEP/MM .
     in code  - Configurations you try change in
     ################# Misc. settings ##################
    #define EEPROM_MODE 0     
     and start working commands
    ↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓   ↓↓
    #define XAXIS_STEPS_PER_MM  160                         
    #define YAXIS_STEPS_PER_MM  160
    #define ZAXIS_STEPS_PER_MM  8000
    I have home made 3d printer style prusa i3 built from components from ebay.
    Ramps 1.4 + arduino 2560 mega + DRV8825+ Display Reprap discout full graphic smart controller.......
    Jumpers on board ramps all 1/32
    Now all working. :)
Sign In or Register to comment.