Print offset reset after G28 in firmware 0.92.9

I had Repetier firmware 0.92.8 in my printer, levelled bed with measuring tool, and fine tuned by setting Z-offset (which can be different with different extruder/bed temperature combinations). However afrer upgrading to 0.92.9, I had some bad prints, therefore I checked what´s going wrong, and found that if I set Z-offset to something, executing G28 (home), resets offsets to zero. Which makes it of course unusable. I returned to 0.92.8 which works as I am used to.


  • You mean G92 offsets? These must reset to 0 on a G28 command for homed axis.
  • No, I mean offsets set by display controller. Today I tried upgrade to 1.01 firmware, the same behavior, i.e. offset is nullified by homing.
  • Don't get it, which offset you mean. The set origin offset in LCD is the same as G92 whcih I already told you gets removed when homing and that is a must.
  • In the 0.92.8 firmware, I was used to this: I have perfectly levelled bed. I have several glasses and mirrors, some of them 2mm and some of them 3mm, and I have found, that depending on temperature of the bed, used filament (PET-G or ABS) and minor tolerances in thickness of glass/mirror etc, instead of fiddling with Z-homing switch screw etc, I fine tuned my setup using UI - set print offset - Z offset. I use values of about -0.3mm for 3mm mirrors, and -1.20- -1.25 for 2mm glass. Minor differnces are also caused by using glue, green tape or kapton. So I tuned everything by Z-offset. Now, upgrading to newer version (first I noticed at 0.92.9 some time ago), this feature is gone, and setting Z-offset when on the beginning of print, after warming bed, then extruder, then homing XY then Z - my offset is gone, and I am unable to print anything well. I have no usage for G92 code, and removing G28 or adding G92 in every profile is bad idea. I even tried to comment out line 1767 (1.01) in the printer.cpp, saying  coordinateOffset[Z_AXIS] = 0; // G92 Z offset, but even offset look as remebered over Z-homing, it still does not work the way I was used to.

  • Guess you mean the UI_ACTION_SET_MEASURED_ORIGIN action. It sets z length based on the assumption you are at the bottom. But that only works on deltas with z max homing as far as I can see.

    The solution for this now is to set bed coating to the wanted offset. That way it also stays permanent across homing requests.
Sign In or Register to comment.