mini ir probe - G33 fails

edited November 2017 in Questions & Answers
i got one of these IR probes and it works fine with my bed

when i run G33 i get a fail when its 75% done, but it does not say why :-/

my config is here:

i have manuel tested that my probe can reach the points i have defined 

using the latest DEV downloaded today - the machine is NOT an delta, i just use G33 so i can store my beds disortion in eeprom and only do an G33 every other week

what could be wrong?


  • tried to run it again... it stops the same place

    X:14.57 Y:42.35 Z:30.000 E:0.0000

  • i tried to run it one more time just to check if it fails consistent... it does

  • What is the full output and what is the test area you want to measure?
  • full output? i want to probe the whole bed

    that is why i attached my config just in case i screwed up the config

    19:51:51.501 : Z-probe:12.617 X:83.98 Y:39.43
    19:51:51.505 : Error:Stopping distortion measurement due to errors.
    19:51:51.510 : RequestStop:
    19:51:52.380 : T:24.51 /0 B:25.00 /0 B@:0 @:0
    19:51:52.799 : fatal:G33 failed! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.
    19:51:52.807 : TargetExtr0:0
    19:51:52.873 : T:23.54 /0 B:25.58 /0 B@:0 @:0
    19:51:52.873 : wait
    19:51:53.432 : T:24.27 /0 B:25.00 /0 B@:0 @:0
    19:51:53.867 : wait
    19:51:54.534 : T:24.27 /0 B:24.86 /0 B@:0 @:0
    19:51:54.870 : wait
    19:51:55.630 : T:24.27 /0 B:24.86 /0 B@:0 @:0
    19:51:55.874 : wait
    19:51:56.729 : T:24.27 /0 B:25.00 /0 B@:0 @:0
    19:51:56.873 : wait
    19:51:57.828 : T:24.27 /0 B:25.00 /0 B@:0 @:0
    19:51:57.877 : wait
    19:51:58.876 : wait
    19:51:58.928 : T:24.15 /0 B:25.00 /0 B@:0 @:0
    19:51:59.879 : wait
    19:52:00.024 : T:24.15 /0 B:25.00 /0 B@:0 @:0
    19:52:00.883 : wait
    19:52:01.128 : T:24.15 /0 B:24.86 /0 B@:0 @:0
    19:52:01.882 : wait
    19:52:02.225 : T:24.51 /0 B:25.12 /0 B@:0 @:0
    19:52:02.886 : wait
    19:52:03.326 : T:24.51 /0 B:25.35 /0 B@:0 @:0
    19:52:03.889 : wait
    19:52:04.425 : T:24.51 /0 B:25.23 /0 B@:0 @:0
    19:52:04.888 : wait
    19:52:05.520 : T:24.51 /0 B:25.23 /0 B@:0 @:0
    19:52:05.782 : N19 M999*18
    19:52:05.782 : N1 M110*34
    19:52:05.786 : ok 19
    19:52:05.790 : DebugLevel:6
    19:52:05.790 : info:Continue from fatal state
    19:52:05.790 : ok
    19:52:06.622 : T:24.51 /0 B:25.23 /0 B@:0 @:0
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.782 : N1 M110*34
    19:52:06.784 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.788 : ok
    19:52:06.792 : ok
    19:52:06.792 : ok

  • its one of those mk42 beds like on the prusa mk2, only i have mounted it on a mendel90

    it has a mat black surface like recommended for these ir probes... only in the corner there are some white logos to prevent stupid people from getting burned... on top i have a PEI sheet

    i have tried to use a black permanent marker to cover those logos to see if it makes a difference..
  • that did not help anything, and i have no clue whatsoever why it fails

    it does about 75% of the 22x22 probe points and then fails
  • I dont think your P1 P2 Y probing positions are reachable.
    You have a Y min= 23.5
    You have probe Y offset=28
    You min P1 P2 Y =28-23.5  = 4.5

    Allso, looks like you have coma's instead of fullstop in the bed dimension settings (not sure if this may cause errors).

  • edited November 2017
    hmm... you might be on to something

    it fails arround those positions anyway

    when homed the nozzle is at Y-23.5 and the probe is then at Y4.5

    since this is an IR probe it can be picky about things and give false signals... just as a test i have placed some black duct tape arround the board as to give it tunnel vission downards and to minimize ir light going direct to the board

    22x22 points take a long time but so far it looks good
  • edited November 2017
    ohh... about the comma's

    i tried to replace them with periods in the online config tool but it seems to replace them back to comma's

    if my current test runs good i will try and replace the comma's back to periods once more

    and from there slowly enlarge my probe field so i get as close to the border i can

    current settings are:
  • the black duct tape helps

    but it still fails near the end.... it could have been nice that the error box in repetier host told why it failed

    was it because it could not reach the next point or was it something with the probe trigger

  • a side thought.... if i did enter wrong probe pos would the arduino ide not throw an compile error?

    or would it in fact start to probe and fail when it tries to go to the pos?

    then its strange as the fail happen only when it goes in the x direction... never when it goes from one y pos to the next... i could understand if the fail happen at the last point on X before it goes to next line on Y and starts over...

    hope that made sense
  • first success....

    i lowered number of points pr axis to 11 and it worked, will repreat 2 mor times to see if it is a success each time

    after that i will try and expand the area so i get closer to edge
  • hmm... after that success run i tried to home the axis as i wanted to try the build heightmap feature

    it did home but it then it tried to home again without respecting the endstop... what a loud noise

    i do have a few older versions of the dev firmware but i doubt it will change anything
  • repetier host crashed during the build of heightmap... but it was just for the fun of it

    now i have enlarged the area just a bit and it had one fail... on the 2nd attempt now

    is there any setting i can use to make it a bit more imune or forgiving to false triggers? like more probe repeats ??
  • Glad your making progress, i have read , this is a downfall of using an IR probe,you get false reflections,maybe a matt black surface would be better.
    I know on the reprap forums, ppl have tried painting the underside of their glass bed with black paint.
    As a side note,maybe 22x22 probe points is too much for the memory available in eeprom, i would try 6x6 and work up from there if successful.
  • my bed is matt black with a PEI sheet over it (the bed is the same as on prusa mk2, but just mounted on a mendel90 instead)

    right now testing with 11x11 points but will lower it and try again

  • oh btw.... when i used a clip on probe with a micro switch 22x22 worked fine

    its just a pain to use since i have to remove the hotend while i use it (takes up to much space) and the downside to that probe is that i cant get close to the edges... 

    the ir can get alsmost to the edge and i have checked with manual moves that i can to the points i have in the config.

    more laters
  • edited November 2017
    more testing...

    there are one corner where it triggers early for some reason... its the same every attempt so i would rule out false triggers

    sadly that corner is the first point for the last row so i dont know if the rest of that row is ok

    there is about 12mm difference on that corner and the only numbers i can think of is that it goes up 10mm between probe points and i have set it to go up 2mm to untrigger the probe

    the 10mm is also time consuming so i will try and lower that to like 1 as it would allready go up 2mm to untrigger and 1 extra is plenty in my case

    also placed a kitchen towel arround the bed at that corner to rule out that the surrounding machine parts reflects ir
  • i set the Z_PROBE_BED_DISTANCE to 0, but still it goes to far up between probes

    i checked that if the probe stays under 6 or 7 mm it will not trigger false in that corner

    will try with sandpaper on the pei in that corner.... i bet if those stupid white logos was not there it would not have been a problem

  • Actually G33 has only a position test when activating probe, so if it stops when because IR probe is triggered before going down, which is forbidden. So I also guess that it is reflection. Maybe you can reduce sensitivity so it needs to come down more to trigger.

    Also a 22x22 grid is a bit overkill even though it fits, so regarding your success rate I would go with 11x11 or 10x10 you you have a realistic chance to finish.

    Height map in host is tricky if it failed. It is counting responses so you need to restart host if measuring fails.

    Remember that z probe bed distance is also set in eeprom overriding your config.
  • edited November 2017
    i did set probe bed distance in eeprom directly... and when that failed in firmware also and it still failed

    and every time i flash firmware i do a M502 followed by M500

    probe cant be adjusted :-(

  • it seems it uses a Z ref of 20mm and that might explain why it moves up even thou i have set bed distance to 0 or 1

    some info from the serial line:

    20:25:59.685 : Info:Configuration reset to defaults.
    20:26:03.867 : Info:Configuration stored to EEPROM.
    20:26:25.474 : X:-4.00 Y:-23.50 Z:217.279 E:0.0000
    20:26:41.181 : Z correction disabled
    20:26:41.185 : Reference Z for measurement:20.000
    20:26:48.954 : Z-probe:20.683 X:18.00 Y:187.00
    20:26:52.612 : Z-probe:20.720 X:71.25 Y:187.00
    20:26:56.282 : Z-probe:20.764 X:124.50 Y:187.00
    20:26:59.959 : Z-probe:20.843 X:177.75 Y:187.00
    20:27:03.645 : Z-probe:20.894 X:231.00 Y:187.00
    20:27:08.228 : Z-probe:20.388 X:18.00 Y:146.00
    20:27:11.853 : Z-probe:20.504 X:71.25 Y:146.00
    20:27:15.494 : Z-probe:20.546 X:124.50 Y:146.00
    20:27:19.171 : Z-probe:20.635 X:177.75 Y:146.00
    20:27:22.820 : Z-probe:20.689 X:231.00 Y:146.00
    20:27:27.301 : Z-probe:20.251 X:18.00 Y:105.00
    20:27:30.917 : Z-probe:20.422 X:71.25 Y:105.00
    20:27:34.538 : Z-probe:20.480 X:124.50 Y:105.00
    20:27:38.187 : Z-probe:20.659 X:177.75 Y:105.00
    20:27:41.926 : Z-probe:20.691 X:231.00 Y:105.00
    20:27:46.431 : Z-probe:20.405 X:18.00 Y:64.00
    20:27:50.100 : Z-probe:20.329 X:71.25 Y:64.00
    20:27:53.827 : Z-probe:20.458 X:124.50 Y:64.00
    20:27:57.526 : Z-probe:20.585 X:177.75 Y:64.00
    20:28:01.184 : Z-probe:20.719 X:231.00 Y:64.00
    20:28:03.907 : Z-probe:8.826 X:18.00 Y:23.00
    20:28:03.915 : RequestStop:
    20:28:05.198 : fatal:G33 failed! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.
    20:31:33.534 : DebugLevel:6
    20:31:33.538 : info:Continue from fatal state

    i reduced to 5x5 just to make it happen faster

    is there somewhere i can force it to use a ref of say 10 or less? just to test if that is what determines how far it goes up
  • found it...

    in disortion.cpp

    float z = RMath::max(EEPROM::zProbeBedDistance() + (EEPROM::zProbeHeight() > 0 ? EEPROM::zProbeHeight() : 0), static_cast<float>(ZHOME_HEAT_HEIGHT)); //EEPROM::zProbeBedDistance() + (EEPROM::zProbeHeight() > 0 ? EEPROM::zProbeHeight() : 0);

    only one of them could give an result of more than 5 and that is ZHOME_HEAT_HEIGHT, funny enough in configuration.h that is set to 20, but on the online config tool i searched all pages for "ZHOME_HEAT_HEIGHT" but it was no where to be found... is this a static set number or is it just called something else on the config web page?

    will try and reduce it to 6 just to see if it makes a difference
  • that made all the difference, now it only goes up slightly and no false triggers in that corner

    now i will push my luck and try and get to extreme edge of board and see what happens
  • ZHOME_HEAT_HEIGHT  this is in the mechanics tab on config tool, but on shows iif you choose one of the homing options with pre-heat.

  • i only see Z_PROBE_REQUIRES_HEATING on the features tab

    where are the homing options with preheat? and do it require that i have a delta?
  • i'm a bit in to trouble again.... it seems that the probing fails if the points differ to much

    for some reason the probe at some few spots report a bigger difference and that makes it fail.

    i have tried to shrink the probe area and change the amount of probe points pr axis

    what would it take for me to change the code to ignore these cases and replace the value it got with something that is between what it got at the point before and the one after?

  • are there any alternatives to G33 that is not so sensitive?

  • if i repeat G33 where it fails it will slowly near the same values

    so something is wrong and i bet if there was an ignore parameter it would work

Sign In or Register to comment.