First Layer issues... (still)

Can anyone point me in the direction of a fix here? 
I have an EH3D 3 extruder printer (looks exactly like a tevo Tarantula)
When i printed a very small calibration box, it seemed to go ok, I am now trying to print a corner bracket to secure this to a board.
I set it to print a skirt and a raft, while printing the raft, the pint lifts off of the bed as the print head lays down the adjoining row. I believe that I am fighting a first layer height issue (possibly a Z offset issue)..
When I home the Z axis, I am able to just slide a bit of paper between the nozzle and the bed (in all 4 corners), but when it prints the nozzle seems too high. 
I have tried to adjust the z offset on the printer itself, but when I make the change and save it to the EEProm, the value of the Z offset shows zero again, but it does appear to change the offset as this is how i adjusted the space to allow the paper to slide under it.
I have considered switching to print on glass, but not sure where to even begin..
Would I disable the heated bed when printing on glass?
Do i need to re-adjust the Z-Offset for glass? 
this unit has an inductive sensor installed, do i need anything different for this (i have seen where people put metal tape on the glass for this)...
Should I work on getting this printer to print on the aluminum plate first?
I have attached a pic of the temps I am running, but cannot seem to attach the video of the print fail..



  • Did you calibrate with cold bed/extruder or hot? The result often differs. Cold extruder may have a PLA drop making it higher so it touches be earlier. Also hot bed often has a slightly different height.
  • calibration was done with bed and extruder heated (and the extruder was clean). Here is a screen grab of the video where it all fell apart...

  • It is hard to say why it does not stick to bad as there are so many reasons why it might happen. Bad surface, bumps on bed so distance varies,  bed is not 100% leveled so some parts have bigger distances, printing with a too high distance, wrong bed temperature as it depends on materials used for bed and printing, .... 

    One general trick is to print first layer with 200% extrusion width and 0.3mm height. That way you normally have good contact and some play room for small deviations. The smaller the extrusion gets the more problems you will get with every unevenness.
  • ok.. I went back to try this again.
    Printing PLA, Bed is set to 60, extruder temp is set to 210 for the first layer and 205 for the reset of the layers.
    I did notice that in RH, there is a Slic3r and a Slicr3 Prusa versions. I had been setup to use the slic3r Prusa version. 
    I changed it to the Slic3r version and was able to locate and the first layer option for 200%
    I also slowed the first layer down to 20.
    This time the skirt printed, but when it started to print the raft, that started to lift. 
    It does appear that the bed may be not level in the middle (i have no way to level the middle)..
    If I add a piece of glass to print on, do I need to reset the Z-Home sensor, or place metal tape bits on the glass and try to get the auto level process to go to those points?
  • Did you try to manually move to the center of the bed and see what the gap is when Z=0 to see how far the bed might be off?
    You might try an object of known thickness, lets say 10mm or whatever and move the hot end around to different points, corners, center, midway,  to see if your bed is really off a lot, also it should be clean.
    I have used hair spray at times for a better "stick" but I haven't needed it for quite awhile since I did a few tweaks.
  • i have not yet taken manual measurements on the bed (i will do this tonight) to see where the discrepancies lie.
    I was hoping that I could get the autolevel process corrected so it would account for that (if i could set it up to use a mesh-map (i think that is correct)...???
    I have also considered getting a piece of glass to put on the bed, but I am somewhat hesitant to introduce another variable at this point..

  • If you put something atop the endstop needs to be adjusted and heating will be slower.

    There is a firmware function called distortion map. That is made to follow bumps of a bed on first layer. You will need a endstop to compile it, but you can use a fake z probe if you do not have one. Trick is to run
    G33 R0
    to delete map, activate it and set corrections to the grid manually with
    G33 Xpos Ypos Zcorrection.
    If you are then close to the bed it will follow the added bumps and hopefully better stick.

    I don't know what your surface is. But using some sticky surface like BuildTak could also help since it sticks better then many other surfaces.
  • Ok..
    I have found a source for BuildTak (at my local MicroCenter) and i have a piece now.
    One thing that has kinda stuck in the back of my head through this process is a question.
    If my build layer is set to .2 and the first later set to .3 with a 200% extrusion (as i understand to extrude more material to the surface to get more of a surface to stick to)...

    When I set the Z-Probe distance, everything I find in the the way of instructions tells me to put a piece of paper under the nozzle, set the z-probe until it just triggers, home the z axis, then go through the process to get the exact distance from the bed to the nozzle...

    I have 2 questions about this ...

    #1 Why would i not bring everything up to temp, clean the nozzle, set the nozzle on the actual bed, then set the z-probe until it triggers? If .1 mm would make that much of a difference in the print adhesion and quality, would it not be better to set the Z 0 to be actually on the bed??

    #2 Right now the z probe in the firmware is set to -.1..
    I found my feeler gauges late last night and measured the distance (when I home the Z axis) between the nozzle and the bed, and I get .028..
    From my understanding, using .028 as the actual distance, I should enter -.028 in the Z probe entry (is this correct)???

  • What kind of z probe do you use. Negative values mean it triggers after the bed is hit by nozzle. Force feedback ond switches integrated in nozzle tip do this, all other probes have a positive values assince the probe triggers before nozzle hits bed.

    Be carefull with buildtak to be not to close to bed ot it will stick too well. Also do not leave hot nozzle on bed height for long or it will melt the buildtak!

    Paper sheet mesurement is nearly zero. Beds are a bit flexible due to the springs so if you have a small friction bed is a bit down already.
  • I have an inductive probe.. (seen here)..

    If i set a piece of paper under the nozzle, then set the probe until it triggers, then re-home the printer. there is .028 between the bed and the nozzle..i add .028 to the z-probe height in the firmware..
    I should in theory, be able to then issue a g0 z0 and the nozzle should just touch the bed right??
    then if i slice a print, the first z code where it will print should be somewhere in the area of .3 if my z offset in the slic3r is set to 0...

    am i missing something?
  • When homing to z min using z probe as well that sounds right, yes.
  • I must have something configured incorrect....
    using Slic3r and .028 in the z-probe setting in the firmware.
    Setting the first layer in slicr3 to .3 and 200% with 0 in the Z offset for the configuration in slic3r, when I slice a print and look at the G-Code, the first Z move to print shows that z is going to .623.
    If i send a G0 Z.623 to the machine, the nozzle ends up at around .62..
    So i believe my issue now is with the slic3r config, but i do now know were it would be as the z offset is set to 0.. Where would slic3r be configured that would double the distance for the first layer??
    I would assume that if the z probe distance is set to .028, slic3r is set to a z offset of 0 and the fist layer is set to .3 that the first g code to position the Z axis to print should leave the nozzle at .3...???
  • are your values mm or inches?
  • If slic3r has a g1 Z0.63 move it is clearly in slic3r. Can be in your personal start gcode or first layer height is set to that.
  • The first layer height in slic3r is set as .3 (i did not change that) and as far as I know there is no personal start gcode anywhere.
  • Have you tried the CuraEngine in RH? I use that as my main slicer (just a personal preference).
  • I just found the Cura engine last night and started to look into it.
    There seems to have been a step learning curve (for me anyway) with slic3r, I don't want to have to repeat all of the issues i have already had. 
    I have a 3 extruder unit, so it took a bit to get the issues there corrected, and as long as the autoloevel mapping stays with the unit and not the slicer software I should be able to work my way through it..
    I have it now setup with the 3 extruders, I am looking to make sure the temps are all the same as well as the supports and layer heights.
    I have not yet been able to print anything more than strands, if Cura works, i would be happy to get there instead.

  • I was just suggesting it to see if your mysterious 1st layer issue might disappear.
  • i have started using cura (to see where it takes me)...
    for some reason, i tell it to print the part with extruder 2..
    All other settings i can find are set to extruder #2.
    when this starts to print, it heats all 3 extruders and not just #2
    Am i missing something, or is this normal?
  • I am still not getting the first layer low enough, it lays the first layer down, does not squash it to the bed
  • One other thing I found is that for some reason the settings I choose do not stay selected. Usixng cura proper (not from within repetier-host). I selected the first layer speed, and try to select the first layer at .23.
    For some reason, when it prints, it appears to be closer to .5, the nozzle is a .4 and when it prints, the filament is getting laid down on the bed and not forced to the bed.
    This is the same issue i have with slic3r.
  • I was talking about the one in RH, I did not mean to magnify your problem by introducing a new one, you shouild probably go back to what you were working with originally and figure that out.
  • It seems I have the same issue no matter what I am running.. I cannot seem to get the first layer down correct.
  • Can you clarify if host is showing z = 0.3mm when printing the first 0.3mm layer? It seems you start mixing different z values liek real z, measured z, send z so clearifying what z you have after home and G1 Z0.3 would help. Only if
    G1 Z0.3
    results in ca.0.3mm real distance you can expect slicers to produce good code. If it then is too high it is in slicer config and not firmware/hardware setup any more.
  • since i am getting the same results with Cura (and from what I can find, Cura does not support 3 extruders). I am back to using slic3r.
    With no changes made, i re-sliced a .stl file.
    I am not in front of the printer right now, but I have my laptop with me to generate the code.
    I believe I may have found where the issue is..
    In the slic3r config, on the layer settings, i have the layer height set to .3 (just below that entry is the first layer height.. when I hovered over it, i read the pop out menu that said to get better adhesion, i could make this a bigger number (and the suggesting in the box mentioned 200%)..
    In an earlier post it was mentioned that I could use 200% (i failed to verify that the 200% mentioned was EXTRUSION, for which there is a different setting that I found this morning.
    When I re-set the first layer to .2, and re-sliced the file, the G-Code sends the extruder to .2 instead of .6 where i had seen it earlier..
    now i cannot wait to get back to the house to try the new code...

  • !! Printed my first part last night.. Although i do not believe it was because i corrected the first layer issue, i believe it was because I added a sheet of buildtak to the bed. I did learn though that the printer probably should not be on a portable table...  :( the first attempt to print was for 2 parts.. and the supports were shaken lose as the printer moved, completely destroying the prints (1 1/2 hours into a 5 hr print..) Live and learn i guess..

    The first layer still seems a bit fat and not where it should be.
    Here are the pics that I have..
    This is the first attempt to print parts. the structure in the front right broke free during print...

    This is the second print, i decided to print just one part this time.. This is showing the underside of the first layer.

    This is a side view (fist layer to the left)

  • Probably a dumb question, have you calibrated your Z steps/mm?
  • I made no changes to the z steps/mm.. 
    I did run though the process of marking the filament, extruding 100mm (while not going through the extruder) and retracting 100mm.. 
    it appeared that I had 100mm of out as well as back in.
  • still looks not "squishhed" enough.

Sign In or Register to comment.