Y-axis crashing

I've recently moved to Repetier firmware from Marlin. I'm having very strange behavior during the print. Past two prints have failed due to my printer head suddenly starting to bounce back and forth on Y-axis. Both of these times it eventually crashes to end of the rail (same direction on both times). Any suggestions on what could cause this?

Printer: D-Bot
Electronics: RAMPS 1.4 with DRV8825 and RepRapDiscount Full Graphic Smart Controller
Using Octoprint for controlling prints (not printing from SD-card)


  • I forgot to add that I'm using the latest firmware of repetier (0.92.9). I also checked that there's no this kind of movement involved from my sliced file (did with Simplify3D). I also tried to reason that the problem doesn't happen from skipping belts since these weird back and forth movements are happening in Y direction which in CoreXY printer involves two simultaneous motor movement. I think it's not very likely to have both belts skipping same amount of steps at the same time.

    Also the second model that I printed with Repetier firmware had these strange movements involved where it suddenly moved hotend away from printed model but it eventually made it way back to where it should be. I guess I need to try to print directly from SD Card to exclude possibility of Octoprint being the cause of the problem.
  • Try disabling ALWAYS_CHECK_ENDSTOPS - might be false signals from crosstalk stopping moves in one direction. Also your description sound more like loosing steps but on both motors same time is unlikely as you already pointed out.
  • Thanks for the reply. I'll try that one out right away. If the problem won't go away, I'll be troubleshooting other possibly causes.
  • First print after ALWAYS_CHECK_ENDSTOPS made with success. I'll be doing couple more tests before declaring this one solved. However my hopes are high.
  • Nope, still have it. I managed to make couple successful prints after making change on ALWAYS_CHECK_ENDSTOPS. However I just got my Y crashing to the end of the rail (this time to the back of the printer).
  • Changing direction of problem shows that it is not endstop related but skipping steps, slipping belt or pulley. Try reducing acceleration a bit. Alternatively if using dev version you could also test 

    which adds slowdowns on small moves with direction change that can cause bigger jerks then visible.
  • Once again, thanks for the help. I'll be doing some test prints with less of an acceleration. Reducing on small segments sound like smart feature however I'm not using development version so need to leave it for later option.
  • edited March 25
    Ok, testing out with new settings. I lowered printspeed from 60 mm/sec to 50 mm/sec and acceleration from 2000 (X & Y) to 1600. First print went fine but with the second print I just got this strange movement of back and forth along Y axis. I'm excluding belt slipping since during the print it suddenly moved Y to almost the end of the rail and after that went back to printing where it should be.

    A ) It's unlikely that slipping belt would cause this since it's always in Y direction (why not ever in X?).
    B ) CoreXY printer needs two simultaneous motor movement in order to move in Y direction. It's not likely that both belts of the motors are slipping same amount at the same time.
    C ) Also seems that even after these weird moves the printer knows that it should move back to the printed part. If it would be slipping it would continue from somewhere else as it wouldn't be aware of the misaligned position.
    D ) Besides even lower settings of acceleration and print speed won't help.
    E ) Problems began after moving from Marlin to Repetier.

    As a next thing I'll be checking out that either Octoprint nor Printoid won't be interfering with the prints. First I'll be doing some prints without Printoid activated and if that won't help then I'll be testing if the problem solves on printing directly from SD-Card.
  • Possibility of Octoprint interfering is excluded. Did crash again along Y rail during the print. I'll be making another tryout printing directly from Simplify3D to make sure Octoprint doesn't have any effect on my printer. If this won't help it has to be Repetier related issue.
  • Does it move always in small bits from correct position or all in one move? Assuming you are printing small objects it sounds like a far distance to git y endstop in one lost step. If that happens in one move it might been receiving wrong coordinates also checksums should prevent this, but the normal checksums are easy to fool. But that means you should see some communication errors during print.
  • I'd say it around 70mm - 100mm of movement. Then there are these crashes to the end of the rail. It doesn't happen every time. I can have one or two successful prints before it happens again. Previously I was printing parts of a cable chain which has rather small dimensions. Last one I was trying to print MPCNC roller part (not so tiny part) before it crashed to the end of the back rail.
  • And to add to your previous reply. It seems to make these moves in one movement back and forth. However I'm not standing beside my machine all the time, so I'm not totally sure about it.
  • Did you already do the sd print test? This would eliminate the communication errors as reason, also I find it unlikely that always y axis is affected by a communication error. Distances are also too big for simple lost steps and endstops are already ruled out since you disabled them during print. So the last thing I know that can do it would be y axis driver overheating but with core xy it would then be a diagonal offset. So maybe still test sd card to rule out communication.
  • Thanks for suggestions. I haven't tested from SD Card. I've bought RADDS board a while ago and it should be mailed to me by next week. I hope that this will eliminate whatever problem I'm having. Because I need to run print some important parts I had to change back to Marlin. Since then the problems have disappeared. At least there no crashes or weird movements yet involved.

    So to speak seems like this problem is Repetier firmware related. It can have something to do with Octoprint communicating with the printer (I've been printing via USB). It's also totally possible that I've made some stupid configuration error on firmware settings.

    I'm really liking Repetier over Marlin and seems like I'm even getting a bit better prints with it. However I wouldn't want to monitor my printer constantly for possible crashing. It's getting rather late so I need to come back on this issue a bit later. I will add a link to my firmware settings below if you could check for possible cause of my problems from there.
  • Here's the link for used firmware.
  • Settings look normal and the problem is not common, but I can not say why it is happening. Hard to say remotely which of all possible reasons is here present. Hope radds does a better job. Have several RADDS printers without the problem:-)
Sign In or Register to comment.