Disabling in Configuration.h DECOUPLE_TEST ????

HI, morning.  I am having the problem of stopped printing beacause of message:

 "Error:One heater seems decoupled from thermistor". The problem is randomly sometimes I get 7 hours printing without problems and sometime 30 min. I have verified wiring and it´s ok 

It Is the extruder´s heater beacause i don´t use heatbed.  I have seen in others threats where is recomended disabling the decouple_test for testing porpouses, but I dont find the line in order to deactivate this feacture.

So I have modified the parameter Decouple hold variance  to 999 but there is no diference. 

Could you tell me how is disabled  Decoupled_Test ?

Thanks in advanced


  • Setting decouple time 0 disables the test.
  • Thanks a lot of.
    I have read this phrase sometime in anothers threads but there is no parameters in configuration.h .
    So I have arrived to conclusion the line to modify in Configuration.h is  this

    #define EXT0_DECOUPLE_TEST_PERIOD 12000
    #define EXT0_DECOUPLE_TEST_PERIOD 0          -----> Disabled

    Could you confirm that my  assumption is correct ?

    Thanks in advanced

  • Yes, that is the one supposed to work.
  • Thanks a lot of. 
    It worked like a champ
Sign In or Register to comment.