Manual Pause VS Filament Sensor Pause Not Working Right


So i was all happy to get my filament sensor hooked up and working, but last night a print failed, and the extruder seemed buried in the print...
Needless to say I was perplexed.... I had used the pause function many times, and had tested with the filament sensor and thought it was working fine.

Did some testing this afternoon.
My pause G code is:
G91; Set Relative positioning
G1 E-8 F1800; retract filament
G1 Z30
M104 S130
G90; return to absolute positioning

This works perfectly fine if I hit pause from Repetier Server. Head moves up 30mm, 8 mm of retraction and set the temperature down, in case its sitting for a long time till i get to it.

However, If the filament sensor detects a Jam, the extruder moves to Z30 absolute and there is about 40mm or so of retraction. Needless to say, this can break thing by jamming the extruder into the print.

Why does this happen and can it be fixed?
I am about to test with specifying a safe absolute coordinate system position, but I shouldn't have to. In general i would think short moves for the pause mean less potential error, but thats probably irrelevant.

FYI I am printing on a Kossel Clear with 0.92.9



  • edited July 2016
    So I thought maybe I could just use an absolute position for the pause, so I tried
    M601 S1
    G1 E-8 F1800; retract filament
    G1 Z295 X0 Y0 F2000

    Pause worked fine, but on continue, it was printing way high, (I think 245, which is my max Z, didn't check so not sure)

    Then i tried
    M601 S1
    M600 X0 Y0 Z50 E-8
    I like what the filament change function is trying to do, but the intial pause Z height isn't 50 mm higher relative, and then once i click to continue printing, it goes to a Z of 245....

    What in the world

    I would really like to be able to use the filament sensor, but the pause isn't working like it should
  • Note: Upon further testing, it appears the M601 command is what was sending the extruder to Z245. Once i remomved M601, and went back to M104 to set temperature, my manual pause is now working as expected. And the jam sensor is once again sending it to Z30 in absolute coordinates.
  • Futher Experimentation shows that
    Pause Code:
    G1 Z240 X0 Y0 F2000
    M104 S130
    Continue Code:
    M402 F2000

    Does appear to work for both manual pause and filament sensor pause, and does move the extruder to a safe position.
    The move to Z240 is fine.
    The move back is very very slow... It appears to move fast over to the X/Y coordinate, then very slowly all the way down to the print level Z.

  • I think the move back down has the %speed modifer from my Slic3r settings, (AKA 30%) when i did the resume when not on first layer, it moved real fast back to printing.
  • So using the following G Code seems to be working ok. Still seems to randomly go slow back to printing Z at times, and fast other times... Not sure why. Haven't bothered trying to add back retraction. At these speeds it leaks too much anyways, but at least it works. Would be lovely if a relative lift actually worked.

    Run on Pause:
    G1 Z245 X0 Y0 F1200
    M601 S1

    Run on Continue:
    M601 S0
    M402 F1200

  • If I understand you, both use the pause function from server, so there should be no difference between started pause from server and requested from firmware.

    Pause remember starting position so M401 should not be necessary.

    I have to check that when I'm back from my trip.
  • you understand correct, and I agree, they both come from server and should be the same.
    For whatever reason, on my printer, i assure you they do not do the same thing.

    I can send you my firmware files if you would like.

    I am happy i got the pause to function with the above, but the pause movement takes forever.

    Thanks for taking a look
  • How do you have this setup?  I'm trying to do the same thing and would appriciate any info you could share!
Sign In or Register to comment.