Virtual Z home in development version

Linux Mint 17.3 Rosa KDE
Repetier-Host V1.6.1
Firmware 0.92.9 vs. development version

Whilst looking for the solution of a problem with the z-axis (perfect when going up and when homing, early stopping when going down, in manual and when printing) I tried the development version.
New problem: it found a home on a distance from the endstop (did not even touch the switch). Repeatedly. Never found the switch.
Next try: I did set the ALWAYS_CHECK_ENDSTOPS to 0 in Configuration.h and my first problem seemed solved (although I am still wondering about the apparent sudden appearance of cross talk after months of being ok).
But the virtual home stayed on.

Afraid from so much magic I fled back to the 0.92.9 version and indeed, with ALWAYS_CHECK_ENDSTOPS 0 the original problem was still solved and the z-axis found its appropriate home also. Which is nice.

Anyway, I thought to mention it to you, being the magician. ;-)
And thanks again for your beautiful software.


  • Do you have a z probe that also works as z min endstop and are you homing to min or max z? I only remember that z min = z probe had some changes, the rest should behave the same. Will test for a normal printer with z min.
  • I don't have a z probe and I am homing to min z.
    It really was an eery sight when it suddenly went through all those homing movements in midair. ;-)
  • At the moment my computer acts weird, like freezing (in linux mint) and then after resetting bleeping 5 times and just showing a black screen. Repeatedly, even after powering off.
    And then not recognizing /c (windows partition) when booting in linux. And then acting normal again.
    Of course, I do not have any idea whether that was an influence on the 'magic' (the computer did act normal at the time, as far as I know, which is not much).
    I am sorry if it is confusing things but it seems worth mentioning.
Sign In or Register to comment.