Not Able to Configure a 2-to-1 Mix/Switch Extruder

I have been successfully using Repitier FW in a dual extruder configuration with two nozzles/heaters and steppers.  I replaced the separate nozzles/heaters with a 2-to-1 heater/nozzle and cannot get a configuration that does not result in an error with used on the printer. 

I have tried about every combination of the mixing/sharing selection available and even tried to manually disable the second heater and use the extruder 0 sensor.  Every combination I have tried has resulted in what must be undefined extruders and a repeating error buzzer.  The extruders show up as def in the display. 

I have been using the Dev version of the FW, but I've tried both .929 and Dev and get the same results.  At one point it looked like a mirrored stepper would be the answer, but that results in a compiler error, flagging something that is undefined in the .H config files.   

Comments

  • You define 2 extruder just as before, only with second extruder having heater pin set -1 and sensor not defined. Set mixing extruder flag and thats all the difference to normal dual extruder setup. Then make sure to setup virtual weights for your 16 virtual extruders - having other config before they are most probably not initialized correctly.

    See also
    for more details.
  • I am not able to do what you suggest using the configuration tool.  Using the Config tool, I can set Ext 1 heater and sensor as you suggest, but these settings are not present if the mixing extruder flag is checked. The Extruder 1 settings that remain after the mix check box is set are only the settings of the extruder stepper motor and the three check boxes (ending with the one about motor mirroring). All other extruder settings are not present. 

    I can do as you suggest if I modify the configuration.h file, if that is what you intended. 

    For starters, I am less interested in setting up a mixing setup than a switching setup (a shared extruder?).  What I was hoping to setup is essentially a dual extruder using a 2-to-1 nozzle and changing extruders with either with the TOOL CHANGE g code command, or let Repetier Host operate as a normal dual extruder with a two color model (and let the color transition happen as it will in the 2-to-1 nozzle).

    It looks like I can take a configuration.h file that is proven to work as a dual extruder and make minor changes as suggested above to achieve either a mixing setup or a shared extruder.  Maybe it is that simple, but I have no clue what the firmware actually does with either of these check boxes. 

    I don't believe that I will be the only person that will be trying to understand this.  I would be more than happy to help expand the documentation if there is anything I can do. 
  • I got it working as a single nozzle dual extruder with a shared heater. 

    I modified the configuration.h file:
    set shared heater to 1
    set ext 1 sensor to ext 0 sensor
    set ext 1 heater pin to -1

    When I get this working as well as I can, I'll try the color mix.

    In the instructions above, I think you meant to say to set the heater pin to ext 0 rather than undefined. The stepper motor didn't work with the sensor undefined. 
  • Ok,have rechecked the code. Latest releases should not require setting heaters. They are not set regardless of what you set for mixing extruders just like shared extruder. So disable shared/set mixing and set weights to 100/0 and 0/100 to get T0/T1 for 100% left/right filament.
  • Thank you for the help.  I think I have a better understanding of what is going on, and how to proceed. The copy of dev fw I was using may have been out of date.

    In my experiments with a dual extruder with one nozzle last night it became clear to me that you cannot allow one stepper to be shut down while you use the other.  When this is the case, the pressure from the driven extruder forces material into the non-operating side of the block and that requires an undesirable amount of flow from the other extruder before you start seeing the second color after you enable it.   

    Geeetech(.com) offers a M201 printer with this extruder and they permit changing the mix ratio from the control panel (as I understand).  A ratio of 96/4 is the maximum permitted and I think I know why now. 

    When/if I get something that might benefit anyone else that goes down this path, I'll post an update.  Thanks again!
  • I'm going to give the E3D Cyclops clone another try with new hardware.
    When I took a config.h for a working dual extruder setup and modified it to a MIX extruder using the configurator and V1.0 Dev firmware, the result was an undefined EXT0.  Checking the Mix extruder setting resulted in removing all setup for Ext 1 other than the stepper motor in the configurator, and that was about the extent of the changes I made to the setup other than the end stop relationship to the single extruder.   

    I did not edit the config.h as I did a 3 postings previous because I understood that selecting the Mix Extruder setup would take care of the heater setup for EXT 1. It doesn't look like it did.

    I believe the config.h file I used did not rewrite the EEPROM settings, but I didn't recognize anything in the EEPROM data that looked like was pertinent to a MIX extruder. 

    Later, I modified the config.h file as I did before, but still didn't manage to remove the DEF error for EXT0. I believe I was doing the same thing as before, but the error was not removed.  I'll try again tomorrow. 
  • I was able to get the 2 to 1 mix extruder to work with FW .929.  I am hesitant to say how, because I couldn't get it to work by just checking the MIX extruder in any of the variations I tried using the DEV FW.  Sorry to say I didn't take notes on what I tried. 

    I'm sure it's no surprise, but in the config.h file, I manually set the mix extruder to 1, set EXT1 heater to HEATER 0, and set EXT1 heater pin to -1. 

    If there's something I'm missing, please let me know, but I didn't have a configuration that worked with a simple check box in the configurator.  Mabe it was because I didn't disconnect the extruder for EXT1 until I had something that appeared to work. 

    I printed a sample using the mix extruders I defined last time using a 50/50 Extruder fed with red and blue.  It produced a decent looking purple color.
     
    I'm still curious as to why I couldn't get the results you expected I would.  I may try a few more config files and see if they work any differently. 
  • I tried again using the configurator and checking Mix extruder using V.929 and V1.0. The config files were correct, and everything worked as it should. The only thing I can think of is that it is likely in the early tests the EEPROM was not rewritten. I don't have any idea why one extruder was undefined.
  • So it is now working?
  • Sorry for the delay in responding. Things started working, and I didn't check back again after a day or several.  As I said above, the only thing I questioned was if the EEPROM was not updated and then I managed to have it updated in a later download (somehow).

    In fact, things have been working very well with the 2-1 mix block.  It's really not a mixer, since the extruded filament shows a definite color bias from each filament on one side or the other of the extruded material, but it is an interesting capability.
  • edited December 5
    I've two extruder and single nozze, with "y swapper".
    In the configurator there's no way to not set the second heater and termistor pin to -1, please fix it with something more understandable.
    The "single nozzle" or "shared heater" option is missing, which should disable the whole section of the second heater.
    I use the 1.04 DEV.

  • It is there:
    Extruders share same heater from extruder 0 definition (SHARED_EXTRUDER_HEATER)

    and -1 is same as "Disabled/no pin assigned" which you can set already.  For sensor use same pin/type as for extruder 1.
Sign In or Register to comment.