Missed Lines / Stuttering during print

edited April 2016 in Repetier-Firmware
Hello,

I keep getting a "Warning: Missed line detected - correcting buffer usage." message every few seconds. Also during printing, the printer stops sometimes for 1-2 seconds and then continues. This mostly seems to happen when printing circles. I have tried different baud rates (115200 and 230400) but nothing changed. I also noticed that the temperature is displayed wrong sometimes, I guess this is also due to the missed lines, for example Repetier-Server displays 2000°C instead of 200°C.

I am currently running Repetier-Server 0.70.1 and Repetier-Firmware 0.92.8 or 0.92.9 on a Arduino Mega and RAMPS 1.4.

Here is a log. The printer was idling and I sent @debugcon at the end.

Comments

  • Try using a short cable an regenerate the g code, had the same problems ordered a card reader for ramps
  • I actually just completely reinstalled Repetier-Server because I had a problem during updating with my Raspberry Pi and the problem seems to be gone for now in idle mode. I hope it stays this way, otherwise I will use a shorter cable.
  • What you see are communication errors and resulting delays or wrong information (temperature). Better usb cables/shielding normally helps.
  • edited April 2016
    I tried printing again today and unfortunately the problem appeared again. On Thursday after I completely reinstalled Raspian and Repetier-Server, there were no errors like i wrote earlier. I only let it run in idle mode though and only for a few minutes. Today, I get multiple missed line errors in idle mode again and wrong temperatures multiple times every minute, like in the log in my first post.

    I have tried multiple USB cables and nothing changed. I then connected my laptop to the printer instead of the Raspberry Pi without changing the cable and in Repetier-Host everything runs perfect. No missed line warnings and no wrong temperatures.

    So either there must be something wrong with my Raspberry Pi 2, or it is Repetier-Server related.

    Edit: I have installed Octoprint again and there also seems to be everything ok, no warnings in the log and no wrong temperatures. So it seems that Repetier-Server is the source of the problem.

    Edit2: Well and now Repetier-Server suddenly runs without problems again.
  • Ok, I can reproduce the problem now.

    When I start Repetier-Server, the first time I connect to the printer everything is ok. Once I deactivate the printer and activate it again while leaving Repetier-Server running, the problems occur. Every time I deactivate it and activate it again, the problems always occur. When I stop Repetier-Server and start it again, the first time I connect to the printer everything is ok again until I deactivate and activate the printer.
  • I updated to Repetier-Server 0.75.1 today and the behavior is still the same. The first time I connect results in no problems and every time I connect after that I get communication problems until I restart Repetier-Server and the cycle continues.
  • Sounds like multiple instances access the port. One thing that is not so clever is that in linux several programs can talk to the same port at the same time. That of course creates lots of errors.

    So what I think is that either octoprint also runs on the port or old repetier-server did not stop correctly and you get 2 servers talking to the printer. Check with 

    ps aux

    if you see more then one instance. WOuld not really explain the disable/enable pattern if that is what youmean with connect. Or did you physically pulled usb out and in and it stopped working?
  • This problem also occured before I installed octoprint.

    ps aux shows only one instance of Repetier.

    With connect I mean activating/deactivating the printer in Repetier-Server.
  • Will try to reproduce this, also I never had it but normally restart the server, In any case yould you enable logging and post a excerpt of the log where the problem occurs.

    One other thing is what board are you using? Some boards do not reset on connect and that can also create such problems in some casesm whcih is why we always try to reset. But due boards on native usb or printrboard do not reset.
  • Ok, I will restart the server for now. I posted a log in the first post, here is another one where I activated and deactivated the printer a few times. The password to view is "repetier".

    Board is Arduino Mega + RAMPS 1.4
Sign In or Register to comment.