The Z-Probe ran fine but impact with my glass when print!

Hello! I want to use Repetier Firmware for my new 3D printer, but i faced a problem with the Z-probe function.

Here is my Probe system:
- I use a aluminum hot bed, solded a wire between the hotbed and connect it to GND on my Ramps.
- I use an other wire to connect the extruder with Z-min Pin on my Ramps. So when the extruder touch the hotbed, this system act as a mechanic switch and can be use for Z-probe.

- I use Z endstop on top of my machine and config it in Repetier firmware (0.92.8) as Max Z endstop. Also i disable the min Z min endstop and Z-min pin on Ramps.
- I use the Z-min pin on my Ramps for Z-probe.

What i want to do:
- I want to Z-probe and save on eeprom so i don't need to auto leveling every time use the machine to print.
- I want to have a LCD menu that i can use to do the Z-probe when i need.
- When Z-probing i will remove the glass (so the extruder and the aluminum hotbed can touch together) and will put it back when i print. The glass thickness is 4mm so i want the Machine offset this thickness when print.

The problem are:
- The default LCD menu don't have Z-probe function so i have use Repetier Host to do this.
- On Repetier Host i use "G32 S2" to start the Z-probe. The machine z-probe ran smooth and completed.
- I set the Z_PROBE_Z_OFFSET to 4mm (the glass thickness), set the Z_PROBE_HEIGHT to 0 mm (the extruder touch the hotbed when triggers).
- But when put back the glass and print, the extruder go down and impact with the glass.

Please help me:
- How to fix this problem and get a correct config?
- How to put a LCD command to do the Z-probe?

I'm not the coder so please tell me simple!

Thanks you!


  • edited March 2016

    as the level after mounting the glass panel is 4mm higher as the level you probed before you have  to set 
    Z_PROBE_Z_OFFSET 0  and Z_PROBE_HEIGHT to - 4mm.(the probed level is lower than the glass surface which should be 0 ).
    I tested it on my printer with G29 S2 , works well.

    best regards,

  • Great, it worked like a charm :)
    Anyway, how to add a command enu on the LCD? Could you help me more?

  • Sorry, not at the moment. I´m working on this but i´m low on spare time

  • just a question to your probe setup..
    do jou have an optocoupler installed on your probe pin?
    just for the case your heating nozzle will break and the +12V or 24V have contact to extruders nozzle
    you will toast your controller....

    unfortunately I´m very experienced in this special case... i killed 2 DUE´s that way

    what type of controller do you use? are there buttons for free use?
    it would be easier for me to assign the zprobe function to a button without displaying it.
    I´m not shure to get the UIMenu done.

    best regards
  • Oh thanks :)
    My probe mechanic is very simple:
    - The nozzle is connected with Probe pin (i use Zmin pin for probe).
    - The hotbed connected with the GND pin.
    - When the nozzle touch on the hotbed, they act like a simple mechanic switch (close the GND pin and the probe pin and change the logic on the probe pin).

    I use RAMPS 1.4 controller.

    Can you tell me more about use a button to start the probe?
    Thanks you again :)
  • I think that is the answer to your question:
    The example shows exactly the menu you need.

  • The bed coating trick did not work because the correction of z length was missing (assuming you home z max). I have fixed that now. So now it should think it is 4mm lower preventing the crash.
  • @Repetier:
    Oh i did some tweak when probing and it work:
    - First, i reset all setting (factory eeprom)
    - Second, i set the bed coating value back to 0mm
    - Third, run G32 S2 (probe)
    - Fourth, set bed coating go to 4mm
    And then save all setting.
    It worked very good!
Sign In or Register to comment.