Extra stepper motor don't move

I use the version 0.92.9 and a Mega / ramps 1.4 card
I added a step motor and when I run the gcode G201 P0 X10 engine does not move and gets stuck.
In config.h

#define MOTOR_DRIVER_1 (var) StepperDriver <42,44,40,0,0> var (2560.100)

I tested with var (200,100) also.

Do you have an idea.
Thank you


  • edited November 2016
    #define NUM_MOTOR_DRIVERS 0
    // #define MOTOR_DRIVER_x StepperDriver<int stepPin, int dirPin, int enablePin,bool invertDir, bool invertEnable>(float stepsPerMM,float speed)
    #define MOTOR_DRIVER_1(var) StepperDriver<E1_STEP_PIN, E1_DIR_PIN, E1_ENABLE_PIN, false, false> var(100.0f,5.0f)

    Some motors need invertEnable true.
    Also in brackets you need to separate with , not with . as you did. Last thing is speed. This all works without acceleration so only slow speeds are supposed to work, not speeds like 100mm/s. That will give you only a humming motor and loose all steps.
  • Thank you for your reply but with #define NUM_MOTOR_DRIVERS 0
    I get Unknown command: G201
    So I tested with #define NUM_MOTOR_DRIVERS 1
    and invertEnable true and false, the engine still does not move; + (

    "#define NUM_MOTOR_DRIVERS 1
    // #define MOTOR_DRIVER_x StepperDriver <int Steppin, dirPin int, int enablePin, invertDir bool, bool invertEnable> (float stepsPerMM, float speed)
    #define MOTOR_DRIVER_1 (var) StepperDriver <59,64,63, false, false> var (100.0f, 5.0f) "

    I use G201 P0 X10 to test with Repetier-Host V1.6.2

    Thank you

  • Sure, NUM_MOTOR_DRIVERS 1 is correct. I had it on first enter and forum destroyed it and on recopy I forgot to correct.

    Just had a look into code and M201 does NOT enable/disable motors. You do this with
    G204 P<motorId> S<0/1>     - Enable/disable motor
    So run first
    G204 P0 S1
    then it should move.
  • I tested "G204 P0 S1" and "G204 P0 S0" with "G201 P0 X10" still nothing!

    I'll test by adding a third extruder.

    Good Sunday
  • Hello,
    this is it works!
    by creating a third extruder.
    I added in pin.h

    "#define ORIG_E2_STEP_PIN 63
    #define ORIG_E2_DIR_PIN 64
    #define ORIG_E2_ENABLE_PIN 59
    and changed the configuration EEPROM.

  • // #define MOTOR_DRIVER_x StepperDriver <int Steppin, dirPin int, int enablePin, invertDir bool, boolinvertEnable> (float stepsPerMM, float speed)
    #define MOTOR_DRIVER_1 (var) StepperDriver <63,64,59, false, false> var (100.0f, 5.0f) "

    would then be the correct solution. You have toggled order for step and enable pin!
  • The final version is:

    #define MOTOR DRIVER v1 (var) Stepper Driver <63,64,59, false, false> var (200.0f, 1.0f)

    because 200.0f  for one revolution and 5.0 is too fast.

    Thank you
Sign In or Register to comment.