Repetier Server 0.80 will not start on boot RPi3

I'm sorry for the basic question, but I am new to linux and I don't know where to look for some simple things.

I put the Raspberry Pi Repetier-Server 0.80 image on an SD card and booted it in my RPi3. Everything seemed to go well. I was able to connect Repetier-Host to the server (had to work through the "too many items in the combo box" error, but eventually got through) and upload a config for my printer. The last thing I did was install ffmpeg with these instructions (I had previously followed these for 0.75) 
And then I edited extcommands.xml to add some Printer On and Printer Off commands.Then I rebooted the RPi to see if the new commands would show up, and Repetier Server does not start. When I try manually starting it with:
/etc/init.d/RepetierServer start

I get the error:
-bash: /etc/init.d/RepetierServer: No such file or directory

All I know is to reboot and hope the server starts, but it doesn't. I could start from scratch from a new image, but the server was working before, so I'd like to figure out how to fix it. Also, I activated one of my 5 pro installs on it, and I am not able to unactivate it.
I appreciate any help. Thanks.


  • Our image uses the newer Jessie linux having systemd. So restarting server is done like this now:

    sudo service RepetierServer restart

    From your description I guess your extcommands.xml is no valid xml file any more that might crash the server on startup. Open it in chrome/firefox and it will show you the error position. You might also check /var/lib/Repetier-Server/logs/server.log to see where the server crashes.

    Don't bother about license. It is hardware bound so activating on same machine does not count and we can always fix things if it is caused by problems.
  • Ok, thanks for the correct command. I was following the instructions in the manual here, it has the command that I tried previously:

    I did restore the original extcommands.xml just in case I had messed up my edited file. Still no luck restarting the server. I tried the restart as well as the start commands. It gave the following error:

    pi@RepetierServer:~ $ sudo service RepetierServer restart
    Job for RepetierServer.service failed. See 'systemctl status RepetierServer.service' and 'journalctl -xn' for details.
    pi@RepetierServer:~ $ systemctl status RepetierServer.service
    ● RepetierServer.service - Repetier-Server 3D print server
       Loaded: loaded (/lib/systemd/system/RepetierServer.service; enabled)
       Active: failed (Result: start-limit) since Sat 2016-11-05 22:23:05 EDT; 11min ago
      Process: 1242 ExecStartPre=/bin/chown -R repetierserver /var/lib/Repetier-Server (code=exited, status=1/FAILURE)
      Process: 1239 ExecStartPre=/bin/mkdir -p /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)

    pi@RepetierServer:~ $ sudo service RepetierServer start
    Job for RepetierServer.service failed. See 'systemctl status RepetierServer.service' and 'journalctl -xn' for details.
    pi@RepetierServer:~ $ systemctl status RepetierServer.service
    ● RepetierServer.service - Repetier-Server 3D print server
       Loaded: loaded (/lib/systemd/system/RepetierServer.service; enabled)
       Active: failed (Result: start-limit) since Sat 2016-11-05 22:43:36 EDT; 28s ago
      Process: 1423 ExecStartPre=/bin/chown -R repetierserver /var/lib/Repetier-Server (code=exited, status=1/FAILURE)
      Process: 1419 ExecStartPre=/bin/mkdir -p /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)
    pi@RepetierServer:~ $

    The last entries from the server log file look like when I shut down the server from the ext commands in the menu. There are no recent entries in the log, so the server doesn't seem to be logging anything currently. If it seems to be too much trouble to recover, I can start over with a new image on the SD card.
  • I wonder why
    /bin/chown -R repetierserver /var/lib/Repetier-Server

    fails. That is a very simple command. It would mean
    a) folder /var/lib/Repetier-Server does not exist but it gets created as you see in line below.
    b) no user repetierserver exists.

    Maybe try running manually
    sudo /bin/chown -R repetierserver /var/lib/Repetier-Server
    and see what exactly the reason is.

    This week we release our V3 image with some improvements and new server. So maybe switch to that when it's out.
  • Ok, I'm not really sure what happened. I ran the command that you listed:
    /bin/chown -R repetierserver /var/lib/Repetier-Server

    Nothing happened, just got a new prompt. I didn't know what to expect, but I thought it would show me some diagnostic information. So I tried:
    sudo service RepetierServer start
    and the server started without error. I restarted the PI and the server started on its own. It seems to be fixed. What does that command do that you recommended? It looks like it sets the ownership of the directory /var/lib/Repetier-Server?

    I may have a clue, when I edited the extcommands.xml file, it would not let me save it, said I did not have permission. So I saved the edited file in a new name. Then renamed the old file to extcommands.old, and corrected the new file name. That's when the error started. But it persisted when I changed the old file name back to the correct file. Did I change the ownership of the extcommands.xml file?

    Thanks for the tip on the new version coming out. Hopefully I will just be able to upgrade and not start over.

  • The command changes ownership of all repetier server data files to repetierserver, the user the daemon runs with.

    From your description I think it was a permission problem reading the file, also the log showed that exactly that command failed. So I guess in systemd that command is already run as repetierserver which can not change ownership of non owned files. So will see if it is possible to run that part as root so it succeeds always.
  • Thanks for helping.
    How should I edit the extcommands.xml file so that the ownership stays correct/ Typically I am logged in as Pi, and I edit the file with nano. Should I be doing something differently?
  • As it already has repetierserver as owner use
    sudo nano extcommands.xml

    then you have write permission as you edit as root and user stays the same.
  • will try that, thanks!
  • Hi,

    because it failed in compiling from git, I installed via debian package.
    Now, all works fine, even the extcommands for switching on or off the printer are working
    Only the shutdown and reboot does not do anything, nor helps my sweet workaround to kill the gui by external command (in wich case I could point to a on the pi desktop)
    log says that the extcommand was executed, but it does not do anything.
    All failing commands have a 'sudo' in common, wich the working commands (gpio) does not need.

    Is this an access-rights problem? How to fix it? Add RepetierServer to the sudoers or something?

Sign In or Register to comment.