radds 1.5 thermister problem

hey guys. 

maby some other people have the same problem but i have a problem with the 100k epcos thermistor with radds 1.5 running on 24 volts. 
themps are reading normal until i heat up the hotend at around 90 degrees, then i see the themp is going to stabilize and around 110 it stops going up, when i look at my hotend, ABS is oozing out wich has a temp arround 245. 

first i thought it would be my temp sensor replaced it, but stil got the same reading. (did also added some themal paste, but still the same reading) 

did the thermistor table changed some how or does someone has a idee what is happening here, 

what i did so far at problem solving . 

dismounted the cooling fan, heated the hotend to see if that had any effect, none 
changed sensor, no effect
used other wiring, no effect
added thermal paste, no effect

what i am currently running, 
repetier 92.9 diamond hotend setup
radds powered with 24 volt, 
power supply 24 volt 16.7 amp


  • First check if the epcos type matches the one from firmware table. There are several 100K epcos thermistors but only one will match temperature curve.

    Then check temp. Reading at room temperature. for 25°C they all have 100K so firmware should give the right temperature here.

    12V or 24V makes no difference as sensor is using 3.3V from due power.

    You already thought about heat transmission as I see. Do you have a multimeter with temperature sensor to compare if that part where you measure gets as hot as you think.

    M105 X0 returns also raw measured analog value (0..4095) so you could do some math yourself to see if conversion is wrong or measured value is wrong. In latter case measure the 4,7k resistor used to measure. Maybe it is not 4.7k. Would also cause wrong temperatures.
  • the resistor is 4,7k, but what i find strange is that the sensor is reading normal at room temperature, but when hitting 90 degrees it stabelizes and wont go up further then 110 

    but shall heat up the hottend and meassure both resistance and raw data to see wat the problem is, maby its the due. 
  • oke did find the first problem m105 x0 only returns the raw value of the heated bed, not of the hotend. any idea?

  • What version are you running? Maybe a old firmware. In dev version I get this

    14:24:35.444: T:22.50 /0 B:21.25 /0 RAW2:3939 B@:0 @:0 T0:22.50 /0 @0:0 RAW0:3930 T1:22.36 /0 @1:0 RAW1:3931

    raw 2 = NUM_EXTRUDER is bed, others are extruder 1 and 2.
  • this is what i see

    15:04:46.997: N1450 m105 x0
    15:04:47.002: ok 1450
    15:04:47.007: T:29.30 /0 B:-55.00 /0 RAW3:4095 B@:0 @:0
    15:04:48.002: wait
    (bed thermistor is decoupled, no worries there)

    im running 92.9 shall try dev. but did some testing. i get closer to real numbers when i remove the 4.7k resistor. 

    radds 1.5  doesnt has resistors on the print? i couldnt find them. 

    i ordered a temperature measuring device so i can see what the temp really is and what the Ohms is of the thermistor, then i will make my own table and see how that works out . 

    what i tried so far 

    changed the thermistor to a epcos EPCOS B57540G1104F000, no results hangs at the same degrees as a B5760G104F.
    changed cabeling without the resistor, getting better results but ABS is oozing out at arround 170 (package says 220 to 250, also on the other printer i must hit 200 before its going to ooze out) 
    measured the voltage of the thermistor pins they are 3.3volt and the other is ground
    changed due boards but no effect.

    im now going to instal the dev version and if that not works i will wait and make my own table. (also i need to clean my workspace, a 3d printer overhaul makes a big mess :D)

  • dev version has the same problems a the 92.9 version 

    i have this enabled in the config because of the diamond head setup
    Extruders share same heater from extruder 0 definition (SHARED_EXTRUDER_HEATER)

    Mixing Extruder (1 Nozzle/heater + 2 or more filament feeder) (MIXING_EXTRUDER)

  • I see that Commands.cpp-> printTemperatures has a error. Near end of function you have

    #elif NUM_EXTRUDER == 1 

    which should be


    to show raw values also for mixing extruders.

    Hope that gives more insight.

  • thanks :D

    17:50:44.210: N26 m105 x0
    17:50:44.217: ok 26
    17:50:44.221: T:24.58 /0 B:23.75 /0 RAW3:3921 B@:0 @:0 RAW0:3915
    17:50:45.216: wait
  • So at least on rrom temperature you get the right reading:-)

    Here the used table
    // Epcos B57560G0107F000
    const short temptable_1[NUMTEMPS_1][2] PROGMEM =

    first is raw value second is 8 * temperature so 25°C => 200 => 3912 raw value. Values in between get interpolated.
  • temps seem normal at {0,4000},{92,2400}, atleast what its showing now that room temp is 21 degrees, also when i see raw data at 110 its between {105,2320},{121,2240}

    im going to make a table of the datasheet, i still dont know what is happening here. the only thing i see is when i do a emergency stop temps shoot up to 65 degrees and then come down to 21.

    could this mean faulty board?
  • owww think its a server issue, dont see those temps in the log
  • edited September 2016

    8-}  so.........

     i found the problem.......... 8-} dumb me..... radds 1.5 has 4k7 resistors already on the board
  • All boards have 4,7k thermistors included for thermistor connectors. Never thought about adding them again :-) That is also why thermocouples never work on these places.
Sign In or Register to comment.