Hotend and bed thermistors crazy values

Hi, I have a weird situation: I'm running Repetier firmware on my Kossel XL from (, controlled by Arduino Mega 2560 + Ramps 1.4. From one moment the printer always runs into dry mode and stops printing on every print. I noticed that the reported temperature of hotend and the bed is jumping like crazy. For example hotend from 200°C to 181°C and then back to 200°C, bed from 60°C to 34°C and back. This happens during 1 seconds and repeats randomly maybe every 3-5 seconds, so I assume it's not a wiring or contact issue, but rather some kind of software problem. The weird thing about it is, that it happens only when the RAMPS is powered from a PSU. When it's powered only through USB, the values are exactly as the room temperature and stable. Therefore I first thought it could be some crosstalk from the stepper motors, even thought the machine operated several days normally. So I twisted the cable of the bed thermistor and isolated it with aluminum foil, but the problem remains. Actually the printer was running normally for months, but I've replaced the Arduino and RAMPS a week ago, therefore I'm speaking only ofdays of normal activity. I've tried M303 and used those values for the PID, also tried other options of thermal control in the firmware, but nothing helps. Do J have to replace the RAMPS again?


  • Sounds like a hardware problem. Firmware is the same if powered with or without PSU. You need a stable 5V to keep reference voltage stable. Form your description it comes from PSU but could also be the 5V converter. PSU could drop voltage and this could go through to 5V. But if it worked with same PSU before new Arduino I guess the new component is the problem.

    If it would only be extruder it could also be a defect thermistor, but it's unlikely that bed and extruder are both affected and I assume the drops are at the same time?

  • Wow, thank you for the super fast response! It was indeed a hardware problem, but I wouldn't even dream it could be what it realy was. I have a Raspberry Pi with repetier-server connected to the printer via a USB. And the cause was in the cheap power-supply of the Raspberry  :-O Replacing the crap solved the problem apparently. Thanks again for your great work and even greater support! :)>-
  • I should really add pi power supply to my top 10 failure reason. You are second one today with that solution.
Sign In or Register to comment.