Extruder not feeding correctly

Hi all,

My issue is that when I tell my extruder to feed 100mm from the manual control, it only feeds about 80mm. So consequently I an under-extruding on my prints. I marked on the filament 100, then I measured what was left. So how and where in the software/firmware do I tell the printer to print the correct amount of filament? and how do I figure out that value to enter?

Thanks in advance!!


  • In eeprom you have steps per mm for extruder. Update like

    new_value = old_value*wanted_extrusion/measured_extrusion

    Note that you need to extrude slow to not slip on filament due to not fast enough melting. 
  • Thank you for the info. But the question remains....

    What do I need to access the eeprom?  Or is it part of the Repetier application, if so , where?

  • Repetier host and server have a nice eeprom editor. In host it is in config and selectable once you have printer connected. In server it is the printer context menu.
  • Hi again!

    Where do I slow down the extruder?  At the same config pulldown for the EEPROM? Or the feedrate on manual control?  Also, when you mean slipping, is that the slight thumping sound I hear when feeding the filament?  Last question, (I hope), I think I should ensure that there is a clean nozzle before I do this, true?  Or how about if I feed without a nozzle on? I just I need some more direction.



  • I've read of  the extrusion feed being adjusted connected or disconnected from the hot end.
    I adjust it connected, making sure my temp settings and pressure on the filament are good for a nice feed.
     The formula is basically the same as for axes steps/mm. It's on the EEPROM settings page where you set your X,Y,Z steps but lower down. I have 1 extruder mine says  Extr. 1 steps per mm.
  • Extrusion speed for manual control is set in printer settings config of host.

    If your extruder makes a "clog" sound it looses a step as the filament is not heated fast enough to be pushed at the current speed. If you calibrate with 1 mm to extrude 100mm when you say 100mm you can start using higher speeds. At some time you will command 100mm and it will not move 100mm - then you have exceeded maximum the extruder can handle. It might be teeth just driver but not moving filament or a motor loosing steps, depending on which force is higher.
  • I notice that Repetier firmware doesn't support the M203 set max feedrate that Marlin/Smoothie have.  Is there a way to limit the max feedrate in firmware, or only in the slicer?

  • You can set it in eeprom. If eeprom is disabled the max. feedrate of the extruder as defined in configuration.h is the limit.
  • So let say slicer creates path that exceeds this extruder feed rate, does it just slow everything down?  In that case can I just set this extruder feed rate to the measured max extrustion feedrate for that nozzle, and just have the slicer speed rate as something much bigger.  Note I use simplify3d, which only has default printing speed (mm/s) option.  
  • In fact it would slow down the move if max. feedrate is exceeded. Problem with extruders is that the max. feedrate is for retraction and undoing retraction. The real print will never manage to hold that feedrate. Here only max. movement speed limit extrusion feedrate.
Sign In or Register to comment.