Azteeg X3 PRO - Problems with third (..forth, fifth..) extruder

Hey there!

I am using the Azteeg X3 Pro running with Repetier 0.92.

So far I was using it with two extruders and everything worked fine. Now I would like to use a third (..forth, fifth..) extruder. Therefore I used the configuration tool to create a new configuration.h file defining 3 (..4,5...) Extruders (EXT0, EXT1, EXT2). Same settings for the 3 extruder motors.

With manual control I can still move EXT0 and EXT1 without problems. But When I try to move EXT2, it only works in one direction. Or more precise:

Moving EXT2 "up" -> motor is turning to the right.
Moving EXT2 "down" -> motor starts turning to the left and immediately switches direction (turning to the right as well).

Extruder 4 & 5 (EXT3, EXT4) do not move at all (completely quiet).

What I tried so far:
- download new firmware
- changing stepper drivers
- changing motor + wiring
- redefining pins in pins.h:
pins of EXT0 -> EXT2
pins of EXT2 -> EXT0
-> same problem as before but on the motor connected to the physical extruder 0 port. Motor connected to physical extruder 2 port now works fine. So the Problem needs to be connected to the firmware.

Anybody experiecing the same problems? Any ideas what could be wrong?



  • I have a 4 extruder printer with that board so E0-E3 are defined correctly regarding pins.

    Do you have all the same stepper drivers? Some require enable signal inverted others not.

    Your EXT2 description is more strange as it shows direction was set correctly and then changed suddenly, as if it was used for some other purpose like stepper mirroring maybe?
  • I only use surestep_sd8825 drivers. If I use the stepper driver from EXT2 for the x-axis, everything is fine.
    And I didn't use stepper mirroring so far...

    Since you use the same Board + Software with 4 Extruders it could be a hardware problem on my side. But just to make sure it isn't a Software Problem I give you my setup:

    Arduino IDE 1.6.9
    RepetierHost 1.5.6
    Firmware: Repetier 0.92 downloaded from configuration tool
    Azteeg X3 PRO with Surestep sd8825

    Testing Routine in RepetierHost (manual Control):

    M302; cold extusion
    G91; relative Positioning

    T0; choose EXT0
    G1 E1 F6;
    G1 E-1 F6;

    T2; choose EXT2
    G1 E1 F6;
    G1 E-1 F6;

    What do you think? Hardware oder software problem?

  • edited May 2016
    I just tried EXT4 and it works fine!! Still nothing from EXT3 and strange behavior at EXT2.
  • I also tried my software on a RAMPS 1.4 using

    E0 as EXT0
    E1 as EXT1
    x-axis as EXT2
    y-axis as EXT3
    z-axis as EXT4

    And it worked straight away! So I guess my Azteeg X3 PRO - Board is simply broken.
  • Yes that might be the case. You could test it with a simple sketch and a multimeter.

    Take the simple blink program and let all pins for ext1-4 blick the same way with 2s period for on and off. Then with a multimeter you should be able to measure a on/off blick on the step/dir/enable pin. These are used by the firmware to control the drivers. Of course if other pins are defect on outside you get different behavior as well e.g. 2 motor pins defect = no motor or power supply to socket brocken. But it allows full analysis of all lanes (power lines can be tested easily as well).
  • Hi,

    are your Extruder Motors all the same? and Drivers adjusted matching to the Motor specs?

    had such an issue with the DRV8825 on Ramps Long time ago.

  • @Repetier: Yeah that is a good idea! I will do the "blink" test and also check all power lines (should have done that earlier already..).

    @RAyWB: Yes I am using the same motors on each extruder

    thanks a lot for you suggestions!

  • I tested EN/STEP/DIR of EXT2 and EXT3 with the "blink"-test and everything was okay. They switched on/off in a period of 2s.

    I also tested all power lines.. Vmot=12V, VCC=5V.. all good!

    Then I did some testing with a stepper driver + motor:

    Driver + Motor to EXT0 -> correct movement
    same Driver + Motor to EXT2 -> still changes direction (EN + STEP seemed fine, DIR not)
    same Driver + Motor to EXT3 -> no movement (Signals of STEP + DIR seemed fine but EN didn't change to 0V! -> no Power)

    So blink-test fine on every pin, but EXT2,EXT3 still no correct movement? Thats confusing :D

  • Yes that is confusing. Blinking and motor should be work the same.

    Except when the lines are somewhere connected e.g. at solderings. I guess your blink changes all outputs the same so you will not notice. But if you only change one pin it might still change 2 lines. E.g. ext2 step or en might set dir. 

    Maybe just check with unconnected board if pins en/step/dir have a direct connection. I think the AVR should survive it and not have a direct internal connection. Or you need some variants of blink to test different combination where only one pin goes on/off and all others are on or off.
  • edited May 2016

    today I was able to try my firmware on a brand new Azteeg X3 Pro board with new firmware from Github...and still the same problem... EXT2 and EXT3 not working properly. So it has to be a software problem.

    Is it possible to get a copy of the firmware files you are using for your 4 Extruder Configuration with the Azteeg X3 Pro you mentioned earlier? And also the version numberso of the Arduino IDE + ReptierHost?

  • Here is the config

    you must change enable invert for all steppers I think as I use RAPS128. It also uses a viki 2 display whcih you must change.

    Make sure to reinit eeprom after upload to have good settings for all 4 extruders and all vars initalized

  • finally I got it to work!!! :-)

    I took you configuration file and adapted it in some parts (Endstops, Sensors etc., Steps/mm) and it worked straight away!! So there was something wrong with the configuration file. But no clue what exactly... both files (the old one I tried earlier and the one you gave me) are pretty much the same. Anyway I am happy that every extruder is working now :-)

    thanks a lot for your help!

  • Can you tell me how you have the Viki 2 setup in your config files or if you've done anything different in the wiring? 

    I'm using the latest configurator (0.92.9) and I've got a Viki 2 hooked up to my Azteeg X3 Pro and it doesn't seem to be powering on or doing anything. The config.h has the #define FEATURE_CONTROLLER 21, Repetier.h has #define CONTROLLER_VIKI2 21, and the X3 Pro is defined and listed in the UI.h... I can't see any issues.
  • You need to exactly wire as Roy described in his documents on his homepage (panucatt) for the Pro. Some colors are hard to distinguish (stripes/marker) and I'm not sure he hasn't changed cable colors over time. So also watch where they come from.
Sign In or Register to comment.