Error with Z Probing

Hi guys,

yesterday i was trying to invoke the automatioc Z probing.
I have set all needed Defins in the Firmware for Z probing an it works great, but some movments settings from the printer wasn´t correct. For example when i send the command to drive 10mm to left he was driving to right and so so stuff.
For that reason i have set the movement settings so that he drives correctly, but now if i send the command G30 or G29 the printer drives my printingbed (i have an coreXY) to bottom and not to the Z-probe on the top, and if i trigger the probe manuel the host shows me som z-probing error and stops instantly.

I tried to set the z_probe_on_high too true and false, but with both settings it dosn´t work.

For your understanding, my Z start point is on Top, so the printer must drive Z- to print.

Greez, Max


  • I find the reason for my failure, my home position is Z-Max but my printer starts printing on Z-min.
    The stupidt thing now is, that i dont know how i can change this, so the printer starts printing on Z-Max.
  • z max homing is great for z probing. This means maximum distance between bed and nozzle after homing. That is fine. Prints contain a line like G1 Z0.2 that moves the nozzle down. So regardless of homing prints start always at the bottom.

    "For example when i send the command to drive 10mm to left he was driving to right and so so stuff"

    that shows you might have configured directions wrong. That can lead to strange problems. For core xy you have 8 combinations with DRIVE_SYSTEM 1 or 2, motor direction x and y. Only one of them gives the right move direction for x and y.

  • edited May 2016

    thx for the answer.
    I have set all new an now the printer works fine :)

  • I'm using an opto probe which is not only triggered when the probe hits the bed but also when it is retracted. Here's the design (on two of the pictures you can see the probe retracted and extended):
    I always get errors and haven't found a way to get it working. Is there a way to configure the firmware (latest version) for using that kind of probe. Or is it possible to add a feature for that kind of probe?

  • Hi Guys,

    i have one more question.
    I added the G32 command in my starting G-Code and the printer makes the Z-Probe at 3 points, but after this he drives ~10mm forward from the last probe point and makes a Z min homing (normaly homing from the printer is Z-Max) and after this i must home the printer with G28 x y, wenn i dont home the x and y axis the zero-points are at the last probe point plus the 10mm  forward.
  • @db3jhf Opto endstops for z probe work. Just needs the right setting for pullup and signal inversion to getect signal correctly.

    @cryze Sounds not correct. G32 bahves a bit different regarding Sx parameter. S2 will measure distance to top to store the correct height for next prints so you do not need G32 for any print.S0 measures height so does z min, but should not change x/y. What version are you using?
  • edited May 2016
    Version should be 0.92.9 (i´ve downloaded 2 - 3 weeks ago)
    Is itnecessary that i do a Z home to Max  bevor i make the Z probe?
    And what dose S1? Actually i dont want to save G32 (my eeprom is off)

    Do you have link for my where i can find all commands for repetier, cause some commands i cant find i the reprap wiki :(
  • edited May 2016
    Now i've set the probe off set (x-y) to zero and now i have no changes for x/y.

  • edited May 2016
    i have found the problem, the probe x/y offset can´t be higher then 0, it makes no diffrent if i write 55 or 0 in the Firmware.

    EIDIT: it makes a diffrent, after the probing the extruder drives 55mm forward but the probe points be the same.
  • edited May 2016
    whene i set the y offset to -55 the probe points are not the same like by 0 and +55.
    So i tried to invert the coordinates from my printer, now is the offset from the probe really -55 but my error is also inverted.
    Now i have no diffrents between 0 and -55 but by +55.
    has updated z probe command definitions.

    z probe offsets can have any sign. Not really sure what you try to explain here.

    without parameters seems like what you want. It measures and sets z correctly so you can start printing. So normally you do
    G0 Z10
    as start code assuming you have z max endstop.
  • Thx for the Update :)

    What im try to explan is:

    If have the bed leveling methon 2, so i set 3 test points, where the probe should test the distance.
    And for the correct position from the probe by the testpoints, it's necessary that the x/y prope offset is correctly set or not?
    For exemple, if the first test point is X100  and Y5 and the probe offset from the nozzle is 0/0 than is the nozzle at this position but not the Probe cause the prob and the nozzle cant be at the same position, thats why i can set the probe off set or? But if is set the probe offset to Y+55, my probe tested at the same position like with the offset 0, just when the tests are finished my printer drives the 55mm back, but bevore he has not changed de cooardinates so at the end of the Z Probing the cooardinates for the nozzel are not correct cause the printer tested the probe points not with the +55m on the Y axsis.

  • Please go in center of bed near bed and try
    G30 P3

    and see if it executes both moves. We have now security checks if the selectionis possible. So if your probe point is 100/5 and y offset 55 it means it need to go to 100/-50 and that is out of move range for most printers. I susch a case the move is not executed. You need to move testing point to 100/60 instead so the move is still possible. Best is to to center and then start probing but points must still be reachable!
  • If im not wrong all points should be reachable, but now im not shure, i will check that :D
    Why it's the best to centern and then start probing?
    With that you just mean to center the extruder befor start testing or set the testpoint to center?

  • I mean go to bed center like
    G0 X100 Y100 F10000

    this just gives enough space for switching to z probe in all cases. In reality you must be just 55mm away for y=0 to work.
  • Jep that was the failure.

    Big thx :)

    can you answer me one more question.^^
    Now i have every thing writen in the firmware and nothin in the eeprom, if i activate now the eeprom is all from the firmware in the eeprom too or must i write it also in the eeprom by hand?

  • On first run with active eeprom or if EEPROM_MODE has a new value all values get copied from configuration.h. You can also reset with

  • Perfect.

    Thx a lot for the great support :)

Sign In or Register to comment.