How to force webserver to redirect only to https?

Hi there,

I have RS running on a Raspberry Pi 3b

My organization requires that internal webservers resolve only in https.  I've configured the server as described on the website, but it's still broadcasting http on port 3344. 

I was able to block port 3344, but it had the side effect of blocking the webcams, too. 

I'm not much of a linux network security guy, which is why I'm writing this post.   Can you point me in the right direction?

thanks in advance


  • https requires all embedded images/cams/content to be https as well. Webcams are streamed over same port as  Repetier-Server so that is no real issue. Only direct access to mjpg-streamer would not work, but inside server they will work.

    http is always enabled as fallback in case certificates are not trusted/expired. So blocking that port is the way to go. Please note that server has now a own https solution you can enable as well in addition to forwarding to it.
  • i found tinkering with the nginx config to be cumbersome, so the solution i used was installing UFW with rules to allow only https and ssh

Sign In or Register to comment.