migrating to windows 7

I am trying to move my repetier host to windows 7 64 bit. The installer can't seem to install the .net framework component. Is this an issue with windows 7?


  • Don't have W7 since a few years, so hard to say. Same installer configuration as when it worked. You might try installing .net manually and then the host. It only installs .net runtime if windows does not have it already.
  • I manually installed the .net framework 4.0 the installer demanded and the repetier host install seemed to complete. When I try to run the program I get a windows error trying to find a solution but fails.
  • What error do you get? WIth seome error message sthere is also a details button giving more useful informations.
  • I get a window with a python errors
  • We do not use python. Did you select the very old skeinforge slicer as well? That would be the only python element I can imagine and you should not use that slicer any more. It is only for old users not wanting so switch to good slicers:-)
  • Sorry, this error is when I try to run cura 4.13.1. When I try to run repetier host windows just says the program has stopped running and is trying to find a solution which it doesn't
  • Ok, but cura 4 is not part of host so better ask ultimaker when it does not run on your computer. With version 4 you need to slice in cura front end and then later import the generated g-code.
  • The problem is that I can't get repetier to start
  • Please explain in more detail. You said you get a python error in cura not being part of host and tell me the problem is repetier host does not start. This is unrelated. What is the error when you start host? After which action does it happen?
  • My post about the python error was a mistake. When I try to start repetier host, a window opens saying windows is looking for a solution to a problem that is unspecified, it eventually fails with no explanation
  • I stand corrected, the window that opens says host has stopped working, and windows is looking for a solution. No solution found
  • Also, running in compatibility mode doesn't help
  • I have the same issue. Any tips for solution?

  • My problem was with the operating system. I upgraded to windows 8 and all my problems went away.
  • I tried a fresh install of Windows 7 to reproduce this behaviour. After installing all updates Repetier-Host worked flawlessy. Was your instance a new install without all updates?
  • I upgraded to windows 8 and all my problems went away.

  • i am using windows XP professional
  • just downgraded to 3.11

    No sensible attacking vectors.
  • Using an out-of-date version of Windows 7: Make sure your installation of Windows 7 is completely updated with all service packs and updates. Older operating systems can occasionally cause compatibility problems with specific programme elements.

    Unsupported.NET Framework Version: Windows 7 does not officially support the version of the.NET Framework that Repetier Host may need. For Windows 7 compatibility, check Repetier Host's system requirements.

    Installer corruption: There's a chance the Repetier Host installer you downloaded is flawed. To rule out this possibility, try downloading the installer once more from the official website.

    Ensure that you have administrator rights on your Windows 7 computer. To ensure you have the required permissions, right-click the installer and choose "Run as administrator."

    Disable any firewall or antivirus software that may be interfering temporarily on your Windows 7 PC. These security technologies may have a negative impact on the installation procedure.

    Hope it will help you.
Sign In or Register to comment.