need Help, maybe a defect in the Board ? extruder has problems with z-Axis

Hello guys, i need help with my Afinibot A3 Printer.

it has the long narrow Zonestar mainboard, its an older one with no auto leveling but it works great !

from one day to another it got an issue with the Z-Axis !  problem: it seems that the hight of the layers are not raising up correctly !!!

that causes prints that has only ca. 75% of the intended hight of the model and extreme over extrusion because of the reduced layers !

i didnt change anything and also old correctly worked gcode files has this issue, so it must be printer related.

is this a known problem ? is there a setup in the printer to correct this or via the small potentiometers on the board ?

Thanks so much !


  • If z still moves there are a few possible reasons:
    - you have somehow changed steps per mm for z so it is not high enough. Try a 100mm move and if it moves that more or less without motor starting to whine it should be ok.
    - your motors can not always move when you tell them to move and you loose some steps. Possible reasons: friction had increased, z jerk was increased, acceleration has increased, motor current was reduced. With the poti you control current with these drivers and if resistance changes so does current. There is also a potential point to measure a voltage that you can multiply with a factor to get current. Check melzi documentation for position and factor. All other values can often be seen and changed in eeprom settings.
  • mmhh good point i will check this first.

    maybe its a friction issue ... unfortunately i sawn some wood in the last days in the same room and the wood dust gets everywhere .... :D

    i try a dissasebly of the threaded rods and clean them up and oil them.

    x and y axis works well

    how can i get to the eeprom settings. can it be accessed through the display menu on the printer itself or is it only possible with usb PC connection ?

  • Via usb I think. Nut sure if you can see them on display, don"t have your printer.  Repetier-Server has a viewer for eeprom settings as well as Repetier-Host.
  • edited March 2023
    so update:   friction is not the problem i removed the threaded rods cleaned them up and put everything together.

    no change ... maybe the PSU gets weak ? because i noticed that the Heatbed needs really long time to reach the temperature of 60°C    i will swap it out for testing, maybe theres not enough current ... but that would be strange because x and y works well ....

    afterwards i wil check the steps per mm for Z .... i dont know what the original value was but i can edit it

    maybe it was resetted or changed by accident caused by an electrical discharge ?!   sometimes the board freezes or boots new if touched .... ?! very strange

    thanks for the hint with the USB connection and Repetier-Server/Host

  • Rods are harder to move. That is why z max speed and acceleration/jerk is also lower. Once it is moving evenly at low speed you loose no steps which is why I proposed to long move test to see if movement amount overall is ok. With layers all tiny missed steps easily build up to bigger values in total also it moves a bit so from this it is unclear if you loose a few steps or steps per mm was wrong.
  • edited March 2023
    i swapped out the PSU ... no change in Z-Axis behaviour
    i checked in the printer display values for jerk and max feedrate for Z etc. and everything looks fine so far.
    so i tried to conenct the printer via usb ... unfortunately i got connection error
    serial com error system Io Ports serial Error Received Event Args
    so i can send nothing.  i take a look at this later maybe wrong baud setup ... i will check.

    i noticed that the passive coolers on the Z Axis chip is getting much warmer then the x and y ones ... ?! 

    i tried to move z- axis via printer display up, it takes sooo long because its 0.01 mm steps i reached 8mm after 15 minutes or so :D but this works ?!   and the 8mm on the display matches the 8mm on the z hight ....

    what exactly does the potis do on the levels ?  if i turn them up ..what happens ? just more current for the motors or does it change the hight in any case ?  for example if the hight on display and printer z axis is correct and i turn up the poti ..does the printer hight goes up ?  so it is very difficult to find the richt position of the poti, right ?

    i also found a similar control board on ebay i ordered .... takes about 14 days delivery :/   maybe the stepper driver is damaged or so ?   how can i download the original firmware from the old board and flash it to the new one ?

  • Poti just changes current. As long as you do not loose steps it will not have any position changes. But more current also means more heat and when they overheat they don't move as well. And if you have 2 z motors in contrast to x and y each motor gets half current so you need more which might be why it is hotter.

    From your test with tiny moves below 1 full step probably I take that resolution is ok.
  • Hello there. I found a solution that works. I Was able to connect the printer via usb to repetier host.
    I checke the eeprom settings and raise the step per mm for z. Axis from value 1600 which was the default to 2540. And Do some z-axis Tests and print works as it should now.

    Poti change does nothing.... I really have no idea what causes this z-axis issue.... Maybe a small logic damage in the Chip or some resistor burned and leads to higher step counts....
  • Do big moves also work correct with that step value? Or is it just that it equals the move error for layer moves be doing more steps.
  • It works in all cases! Maybe the Mini step test before Was not really usefull...
    Very Strange. Maybe I check this issue again with my spare control Board when it arrive.
Sign In or Register to comment.