New server version causes crashes with all printers

Just updated to the latest version for Repetier Server and now I cant run a single print. On all my machines as soon as I kick off a print they all keep disconnecting and reconnecting.

This has shut down my whole farm and I have no option to roll back the changes. Please can you advise what to do here as I have a big backlog of orders I need to get through.

Comments

  • Did you change image or server version? You can revert to older version by manually installing the old package file. There might be some issues with viewing gcode as they have changed the format a bit.

    But can you say what exactly the issue is? Is the server restarting due to some errors or are the printers it self reconnecting for some reason like EMI/Underpower. In new image we used latest bullseye compared to buster before. But at least on our systems it had no issues. YOu see this easily in server.log and syslog downloadable in printer logs for example.

  • I simply updated the server version through the UI. I can send commands fine such has heating the bed or moving around the printer etc. But when I try to print a file I just keep getting connect and disconnect spam.

    1 machine is running skr 1.4, 1 skr 2 and the other machine running skr mini. All were absolutely fine on version 1.3.0
  • edited September 23
    Send:14:41:39.542: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.552: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.554: Resend: 13 Recv:14:41:39.574: Waiting for resend requests finished. Starting resends ... Send:14:41:39.574: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.584: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.586: Resend: 13 Recv:14:41:39.605: Waiting for resend requests finished. Starting resends ... Send:14:41:39.605: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.623: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.627: Resend: 13 Recv:14:41:39.646: Waiting for resend requests finished. Starting resends ... Send:14:41:39.646: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.659: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.661: Resend: 13 Recv:14:41:39.680: Waiting for resend requests finished. Starting resends ... Send:14:41:39.680: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.692: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.694: Resend: 13 Recv:14:41:39.715: Waiting for resend requests finished. Starting resends ... Send:14:41:39.715: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.733: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.740: Resend: 13 Recv:14:41:39.759: Waiting for resend requests finished. Starting resends ... Send:14:41:39.760: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.770: T:23.69 /0.00 (978.62) B:25.91 /0.00 (975.00) @:0 B@:0 Recv:14:41:39.781: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.783: Resend: 13 Recv:14:41:39.803: Waiting for resend requests finished. Starting resends ... Send:14:41:39.803: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.815: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.817: Resend: 13 Recv:14:41:39.837: Waiting for resend requests finished. Starting resends ... Send:14:41:39.837: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:39.849: Error:No Checksum with line number, Last Line: 12 Recv:14:41:39.851: Resend: 13 Mesg:14:41:39.851: Receiving only error messages. Reset communication for printer Ender 5. Mesg:14:41:40.980: Dtr: true Rts: true Mesg:14:41:40.980: Connection continued Send:14:41:40.991: N14 M82 ;absolute extrusion mode Send:14:41:40.991: N15 M503 ;print out settings Send:14:41:40.991: N16 G21 ;metric values Send:14:41:40.991: N17 G90 ;Absolute positionning Send:14:41:40.991: Slow command added:M190 S55.0 ; Set bed temp and wait to be reached Send:14:41:40.991: N18 M190 S55.0 ; Set bed temp and wait to be reached Send:14:41:40.991: Slow command added:G28 ;Home Send:14:41:40.991: N19 G28 ;Home Send:14:41:40.992: N20 M114 Send:14:41:40.992: N21 G92 E0 ;Reset Extruder Recv:14:41:40.995: 3.69 /0.00 (978.62) B:25.82 /0.00 (975.44) @:0 B@:0 Recv:14:41:41.008: Error:Line Number is not Last Line Number+1, Last Line: 12 Recv:14:41:41.010: Resend: 13 Recv:14:41:41.029: Waiting for resend requests finished. Starting resends ... Send:14:41:41.029: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.041: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.043: Resend: 13 Recv:14:41:41.063: Waiting for resend requests finished. Starting resends ... Send:14:41:41.063: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.075: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.077: Resend: 13 Recv:14:41:41.097: Waiting for resend requests finished. Starting resends ... Send:14:41:41.097: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.109: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.111: Resend: 13 Recv:14:41:41.130: Waiting for resend requests finished. Starting resends ... Send:14:41:41.130: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.142: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.144: Resend: 13 Recv:14:41:41.163: Waiting for resend requests finished. Starting resends ... Send:14:41:41.163: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.174: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.176: Resend: 13 Recv:14:41:41.196: Waiting for resend requests finished. Starting resends ... Send:14:41:41.197: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.207: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.209: Resend: 13 Recv:14:41:41.228: Waiting for resend requests finished. Starting resends ... Send:14:41:41.229: Resend: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C Recv:14:41:41.240: Error:No Checksum with line number, Last Line: 12 Recv:14:41:41.242: Resend: 13 Mesg:14:41:41.243: Receiving only error messages. Reset communication for printer Ender 5. Mesg:14:41:42.366: Dtr: true Rts: true Mesg:14:41:42.366: Connection continued Send:14:41:42.377: Resend: N14 M82 ;absolute extrusion mode Recv:14:41:42.381: 3.75 /0.00 (978.50) B:25.88 /0.00 (974.94) @:0 B@:0 Recv:14:41:42.393: Error:Line Number is not Last Line Number+1, Last Line: 12 Recv:14:41:42.395: Resend: 13 Mesg:14:41:42.396: Receiving only error messages. Reset communication for printer Ender 5. Mesg:14:41:43.516: Dtr: true Rts: true Mesg:14:41:43.516: Connection continued Send:14:41:43.527: Resend: N15 M503 ;print out settings Recv:14:41:43.531: 3.78 /0.00 (978.44) B:25.94 /0.00 (975.12) @:0 B@:0 Recv:14:41:43.543: Error:Line Number is not Last Line Number+1, Last Line: 12 Recv:14:41:43.545: Resend: 13 Mesg:14:41:43.546: Receiving only error messages. Reset communication for printer Ender 5. Mesg:14:41:44.676: Dtr: true Rts: true Mesg:14:41:44.676: Connection continued Send:14:41:44.687: Resend: N16 G21 ;metric values Recv:14:41:44.691: 87 /0.00 (978.25) B:25.85 /0.00 (974.94) @:0 B@:0 Recv:14:41:44.703: Error:Line Number is not Last Line Number+1, Last Line: 12 Recv:14:41:44.705: Resend: 13 Mesg:14:41:44.706: Receiving only error messages. Reset communication for printer Ender 5. Offl:14:41:44.709: Ignored (offline):M73 P2 R483 Q2 S483 Offl:14:41:45.606: Ignored (offline):M77 Mesg:14:41:45.837: Dtr: true Rts: true Mesg:14:41:45.837: Connection continued Send:14:41:45.848: Resend: N17 G90 ;Absolute positionning Recv:14:41:45.852: 9 /0.00 (978.62) B:25.94 /0.00 (975.31) @:0 B@:0 Recv:14:41:45.864: Error:Line Number is not Last Line Number+1, Last Line: 12 Recv:14:41:45.866: Resend: 13 Mesg:14:41:45.867: Receiving only error messages. Reset communication for printer Ender 5.
  • Bah seems the forum doesnt respect line endings... either way thats basically whats happening. Nothing has changed from my end other than simply clicking update on the server. Might I suggest a rollback function on the sever. The last thing I want to do now is to spend all afternoon trying to roll it back and set it all back up again from scratch.
  • Im going to roll back until I can fix this on a sandbox. If I ssh into the pi can I just install version 1.0.3 over the last one? How can I do that what commands do I need? Im a pro licence holder btw.
  • Note to future self and others.

    To downgrade SSH to the pi,

    Then run the following to get the old version:



    Now run the following to install the old version:

    sudo dpkg -i Repetier-Server-1.3.0-Linux.deb

    This will install the old version over the new one. This fixed all those issues for me. I really wish you guys would do a bit more testing on your releases. The bug report area is full of issues relating to 1.4.x

    Thankfully I was easily able to roll back. I think ill use a separate pi for future updates just incase all hell breaks loose again.
  • We test until we get no problems in testing, but there are always edge cases. I think I found your problem:

    Send: N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C 
    Recv:14:41:39.733: Error:No Checksum with line number, Last Line: 12 
    Recv:14:41:39.740: Re

    N13 M75 CE5_16g_Mag_v3_9 Sunlu PLA 109g lw 0.4mm lh 0.28mm flow 100% if 40% ext1 215.0C bed 55.0C

    has already 98 byte und there will be also the checksum added. I think marlin line limit is 96 byte so it does not fit generating the error message. So this error will only be visible with extraordinary long file names.

    The change causing this was that in marlin.xml in firmare folder we changed
    M75
    into
    M75 {{job.name}}

    To show running job on printer. Will now reduce this to max. 20 chars to prevent such an overflow. So server is ok just the name causes overflow in marlin breaking communication. And too many errors then finally disconnect.

    So thanks for providing the info for the reason so we can catch this in 1.4.3.

  • Thanks for the fast response! Appreciate it. Sorry for being crabby, I was stressing out about my orders. Still love repetier though! Will eagerly await 1.4.3
  • I hope it is OK to add some information to this topic:
    I also have trouble with v1.4.2, but for a FLSUN QQ-S Pro which has been unable to print new g-code uploaded, BUT it could print existing g-code (uploaded with v1.3.1) without any problems. On the console page, a lot of "Expected line nn got line xx" and "Resend line nn" was continuously displayed and it continued even after deactivating the printer. The same g-code causing the problem could be printed from a SD card without any problem. After downgrading to v1.3.0 (as shown by Festivejelly - thanks!) and re-uploading the troublesome g-code, everything works again!
    On another note, the FLSUN QQ-S Pro claims to be running Repetier firmware (and Cura is set to produce Repetier g-code), but I have to set Repetier-server to "Marlin" in printer setup for it to work!
  • What does M115 return? And what does M205 return. WIth both answers it is quite easy to say if it is running marlin or repetier-firmware. I'm not aware that they use our firmware, but you never know and it makes a difference also general communication works with marlin settings as well. "Expected line nn got line xx" actually sounds like marlin

    Do you mean uploads from 1.3.1 printed with 1.4.2 work and uploaded with 1.4.2 does not work? That would be strange since the gcode is th eunchanged original file we use. Only analysis differs as format for layer file has changed.

    "Expected line nn got line xx" happens when buffer in printer overruns. Enable ping-pong mode or reduce input buffer size. Normally 127 is ok. Some need 63 some can do 255, some can not handle parallel commands in all situations and get in trouble which is when ping-pong helps. If you use old marlin you might need to disbale sending progress to lcd especially if it can not handle e.g.
    M117 12:34:56
    without error. Old versions did not allow : in strings as they are used for time.
  • M115 returns: 
    FIRMWARE_NAME:Robin
    Printed filament:525.72m Printing time:3 days 14 hours 20 min
    PrinterMode:FFF
    M205 defenitely returns the eeprom contents.
    So it looks like a repetier firmware. I think they use it for their Q5 as well as for the QQ-S Pro. But if the firmware is set to "Repetier" then the console will display this during the startup (with "Commands" enabled and just the first page of lines):
    Mesg:17:24:02.800: Dtr: true Rts: true
    Mesg:17:24:02.801: Connection started
    Mesg:17:24:02.801: Printer reset requested false
    Mesg:17:24:02.801: Dtr: false Rts: false
    Mesg:17:24:02.822: Dtr: true Rts: true
    Recv:17:24:04.973: Connection verified by:start
    Recv:17:24:04.974: Printer reset detected:start
    Recv:17:24:04.974: start
    Send:17:24:04.974: N0 M110 N0
    Recv:17:24:04.983: Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
    Recv:17:24:04.985: zDistortionCorrection:1
    Recv:17:24:04.985: Autoretract:0
    Recv:17:24:04.988: X:0.00 Y:0.00 Z:0.000 E:0.0000
    Recv:17:24:04.993: SelectExtruder:0
    Recv:17:24:04.993: FlowMultiply:100
    Recv:17:24:05.716: Error:Format error
    Recv:17:24:05.716: Resend:1
    Send:17:24:05.728: N0 M110 N0
    Recv:17:24:05.848: Error:Format error
    Recv:17:24:05.849: Resend:1
    Send:17:24:05.861: N0 M110 N0
    Recv:17:24:05.865: Error:Format error
    Send:17:24:05.865: N1 M999 ; In case we did not reset recover from fatal state
    Recv:17:24:05.869: Unknown command:
    Recv:17:24:05.869: Error:Format error
    Recv:17:24:05.873: skip 0

    Yes, uploads from v1.3.1 worked (but only tried 2) while new uploads with 1.4.2 did not. And using the "Show g-code" function on the uploaded files, did not show any apparent errors in the uploaded file.

    Regarding the serial (USB) connection, I can assure you that I have tried multiple connection settings, including Ping-pong mode as well as non-ping pong mode with various buffer sizes. Also, as mentioned it did print existing files without any errors :-)

    But as it is relatively easy to go forward and back (if needed) in versions, I will check if I can reproduce the errors by updating to v1.4.2 again and let you know if it just was a bad update that was causing the problems or if the problems persists.
  • Ok, that is strange. In newer firmwares you can not get Format error any more, but previously you could get it if a line had no G, M or T. If that forces a resend it will get an endless loop, which is likely the reason I removed it. But that is not the case here. M110 N0 seems to be the command firmware does not like and there is a M included. With marlin using ascii format it seems to be no issue. Can't say why but there is a way to make server use ascii for repetier. In installDir/firmwares is a file repetier.xml with this:
    <!-- Define main communication behaviour
    okAfterResend - true id after resend:line a line with ok follows
    protocol - Used communication protocol repetier or ascii
    allowColonInAscii - Some firmwares have problems with : in ascii content like M117
    -->
    <com okAfterResend="true" protocol="repetier" allowColonInAscii="true"/>
    If you change protocol to ascii it should then also work with repetier after server restart. Then communication is using correct signals at least and might prevent some errors due to different handling in marlin.

    Maybe you also got in 1.4.2 the same issue with long command line length as above. When file names are very long 
    M75 {{job.name}}

    would generate mor ethen 96 chars breaking firmware parsing causing endless loop. repetier.xml does not have this, but uses M531 with filename. So if you have very long file names that could be the issue if it happens on print start.

  • Hi, sorry about the time to answer - run out of filament during a print and ended up having to take hotend apart, clean everything and change to a new bowden tube :-)
    I tried updating to v1.4.2 again and it still does not print when using the same settings as in 1.3.0, but neighter does the same print from v1.3.0 - so that observation was apparently not the true.
    Using "ascii" in the "repetier.xml" file and changing "firmware" to "repetier" does fix the printing problem, But there are still a few "Format errors", so they are probably not using the newest firmware.
    Thanks for your help!
  • They can still be part of communication errors. If communication does not stall a them with resend - error cycles that would be ok.
Sign In or Register to comment.