Need manual OK after every line of gcode!

edited October 2015 in Windows
Hi, I am totally new to 3d printing so I am sorry if this is a stupid question/issue.
I am running RH ver 1.5.6 on windows 10 and windows xp machines (just to make sure it was not a windows 10 problem). On both machines I need to press a manual OK after every line of gcode.

I am running a makibox with latest firmware.

The printer runs fine apart from this and my first print looked good (some weaving put not bad for a first run) except I pressed OK 3000 times! I can hit ok in batches so they seem to buffer too then stop and I have to hit OK another xx times as a batch and xx lines of gcode print then stops.

I have tried slicing with slic3r but to iliminate another possible error I tried printing the standard test cube gcode provided so no slicing needed. Both do the same.

Any obvious setting I have missed or known issue like this?
Any help greatly appreciated.


  • Sounds like you get lots of communication errors. What does the log show as response? With pingpong disabled it needs some missed "ok" returns until it blocks. In 1.5 you can set a timeout to continue automatically, normally set to 40 seconds but that gives lot of blobs. Without com errors you woundln't have these problems.

    Maybe your baudrate is only nearly correct, e.g. 230400 vs, 250000 works some times but with frequent errors.
  • Ahh I see, comms problem maybe. Didn't get any comms error in the log as I remember but I will try again and report back a little later. Gives me a direction to investigate. Thanks.
  • edited October 2015
    Hi, well I get no comms errors, the only error so to speak is the occasional M117 error.
    Off course that's with me pressing OK after each line of code for it to progress otherwise it just sits there after the first move. (That is after heating the bed taking the head to the zero position and getting the extruded to the correct temp)

    How does the comms part work? The host send a command and the printer send an OK as a return. If it gets an OK then it send the next instruction?
    Seems such a simple problem but it driving me nuts.
    Any help appreciated. Thanks
  • Update: so in desperation I loaded pronterface. Just changed the printer size in setting and loaded the test cube gcode and hit print.
    It works fine. No need to hit OK after each line of gcode.
    Makes me think there is some issue with RH 1.5.6.

    Any thoughts as I would like to run RH as my choice of software .

  • Enable ACK and show commands in log window. Then you see the ok messages as well. Sometimes the first letter gets something different. In repetier-firmware we send therefore line numbers along with ok so we can detect missed ok lines.
  • Is there any way to attach a file here? I think if someone could see my log output and gcode maybe they could see why the hangup.
  • No files supported. Use pastebin or some other external storage for this.
  • Hi, I have pasted the log on pastebin. Towards the bottom is the gcode so you can see where it stops.
    Really hoping for a solution.
  • Strange firmware you use. Have never seen this and didn't know it exists. What I see is that they like to add unimportant stuff to slow down communication and that they do not support M110 which is used to set line numbering. I guess that latter is the bigger problem as we change the line numbering from time to time and also set it in first line. 
  • I have to be honest, I am not sure I understood the information about line numbering especially the change in line numbering you talk abouit as I am new to gcode.
    The firmware is straight from the Makibox website. That was their latest software before they went bust and other makibox user on their forum seem to be using it too. I seem to be the only one in windows 10 with RH1.5.6 though. Most people are using an older version of RH. I might try that to see if that makes a difference.
    I will let you know as soon as I get a chance.
    Thanks for the help so far.
  • The N parameter is a line number to see if we are missing a line. M110 sets the counter and the firmware says unknown command to it. So if host sets it back to 1 to reduce size the firmware will not recognice it and still want M+1 for next line. That is a serious problem for longer prints. You come away with it at the start since both start with 1 or 0. I have changed that recently, so 1.0.6 might be solution for now. Best solution is to install a new firmware if the board is supported.
  • Hi,
    As I still felt RH 1.5.6 was the issue (especially as Pronterface worked fine), I uninstalled it and loaded RH 1.0.6 and everything works fine!
    Not sure what stops RH 1.5.6 from printing but for now I will stick with RH 1.0.6.

  • Sorry, I think I didn't update my page before posting. Anyway as you can see I did just what you were suggesting and it works. Makibox went out of business so there will not be any more firmware I think but maybe another firmware will work so I will look into it.
    Thanks again for your help.
  • Just to let you know that RH 1.6.0 works fine.
    Thank you for all the hard work.
Sign In or Register to comment.