Ungewollter Druckertausch im Repetier Server

Hallo zusammen,
da ich nun auch diverse Probleme bei der Einrichtung habe, möchte ich hier mal nachfragen, ob jemand eine Lösung für mein Problem hat. Zunächst mal mein Setup:
- Raspberry Pi Vers. 4 B
- Repetier Server Pro V 1.0.4
- 3 Drucker (Ender 3 V2, Ender 5, Ender CR.6 SE)
- 1 USB Hub
- 3 Webcams, die am Hub angeschlossen werden.

Ziel ist es natürlich, über den Pi und Repetier alle 3 Drucker  zu steuern. Pro Drucker ist eine Webcam vorgesehen.

Grundsätzlich ist die Einrichtung einfach und funktioniere auch völlig problemlos. Der Pi verfügt über 4 USB Abschlüsse, davon sind 3 mit den Druckern belegt. Der 4. bekommt den Hub, an diesem werden die Kameras angeschlossen.

Im Repetier Server sind die USB Ports 0-2 den Druckern zugewiesen und die Cams lassen sich auch den einzelnen Druckern zuweisen.

Soweit, so gut.
Jetzt zum Problem. Irgendwann, keine Ahnung wann oder wieso, tauschen die Drucker.
Wenn ich also dem CR6 einen Druckauftrag gebe, startet der Ender 5 und umgekehrt. Manchmal (ich habe schon mehrfach neu installiert) ist auch alles durcheinander. Druckauftrag an den 3er, der 5er startet, Druckauftrag an den 5er, der 6er läuft, Druckauftrag an den 6er, der 5er geht. Die Kameras zeigen übrigens dann auch immer jeweils andere Drucker.
Die USB Ports werden in den Einstellungen genauso angezeigt, wie ich sie ursprünglich eingerichtet hatte. Hier hat sich offenbar nichts verändert.

Was habe ich bisher versucht?
- Ich habe also mehrfach die SD Karte komplett neu eingerichtet. 
- Ich habe mal alles ohne Kameras laufen lassen
- Über Putty die Einstellung im Raspi geprüft (sudo raspi-config), aber nichts gefunden

Meine erste Idee war ja, dass das mit den Cams zusammenhängt. Die kann ich aber mittlerweile ausschließen.


Wer hat hier noch Ideen. Hat jemand dieses Problem schon mal gehabt.

Welche Infos werden noch benötigt.

Vielen Dank für Eure Unterstützung!!

Gruß,

Ufti

Comments

  • Wie fangen die ports an? Sie müssen mit /dev/serial/by-path anfangen, so dass es wichtig ist wo sie verbunden sind (welcher usb port). Insbesonders direkt in /dev hängen die Namen von der Reihenfolge des Erkennens durch linux ab und sind somit etwas zufällig.
  • Hallo und vielen Dank für die Antwort.
    Die Ports heißen bei mir "/dev/ttyUSB0" bis "/dev/ttyUSB2" Das erschien mir am logischsten.
    Wenn es aber an den "by-path"-Ports hängen soll, werde ich das nachher mal testen.
    Ich melde mich, sobal ich was genaueres weiß.
  • ttyUSB0 ist einfach der erste der gesehen wird. Da ist das vertauschen normal. Also genau das Problem.
  • Hallo,
    also, tatsächlich scheint das Problem behoben zu sein.
    Ich habe zwar erst mit 2 Druckern getestet, da der 3er noch in einem größeren Druck (manuell gesteuert) ist, aber sieht gut aus. Beide Drucker mit Kamera funktionieren.
    Wenn der 3er implementiert wird (also morgen) kann ich nochmal ein kurzes Update geben.
    Manchmal ist die Lösung doch so einfach... :)
    ...und man sieht den Wald vor lauter Bäumen nicht.

    Nun denn, vielen Dank für die Hilfe.

    Gruß,

    Ufti

  • Hallo wir haben das gleiche Problem mit dem MegaX und dem Artillery X1 v.4 wie Uftilani

    Wir haben auch schon das alles versucht es geht ein zeitlang gut aber dann werden die Drucker wieder vertauscht.
    meistens passiert das wenn man alles ausschaltet und neu startet dann finden Rasperie Server die Zuordnungen nicht mehr. Die Ports heißen bei mir auch "/dev/ttyUSB0" bis "/dev/ttyUSB2" aber wie gesagt muss den Pi und die Drucker ausschalten und wieder neu starten dann taucht das Problem auf. Arbeiten wir nur mit einem Drucker und haben den einen ausgeschaltet dann funktioniert  alles. Das zweite Problem das wir noch haben, liegt bei der W-Lan Verbindung da haben wir auch schon alles verucht manchmal ist die W-Lan Verbindung stabiel und dann reist Sie einfach wieder ab obwohl der Router 2m neben dem Rasperie Pi steht. Mann muss dann in den Einstellungen mehrmals auf Verbinden klicken manchmal 3 bis 4 mal und dann ist er wieder verbunden.

    MFG
    R.Thome



  • Bei den Druckern als port wie oben erwähnt /dev/serial/by-path verwenden, dann ist wichtig in welchem usb port sie sind und nicht die reihenfolge des Einschaltens.

    Bei neueren images kann man wpa supplicant auch explizit vorgeben und muss nicht mehr unsere Steuerung nutzen. Manchmal hilft es auch AP auf nie zu setzen, dann wechselt er nicht in den AP modus wenn er glaubt nicht verbunden zu sein. Insbesondere wenn man ein display hat kann man das gefahrlos machen ohne angst zu haben sich auszuschließen.
  • Hi,

    ich habe 2 Drucker an meinen Raspi mit Repetier Server angeschlossen. Einen Anet ET4 (Marlin 2.06) und einen Sapphire Pro (Marlin 2.06). Leider taucht der Anet weder in serial/by-id noch in serial/by-path auf so dass ich ihn über USB1 angeschlossen habe. Er wird aber nach einem Neustart des Repetierservers manchmal nicht gefunden, weil sich der USB auf USB0 geändert hat. Was kann ich tun?
    Danke im Voraus für Hinweise
  • Bei den Namen unter /dev direkt entscheidet die Reihenfolge in der Linux die Drucker sieht über die Nummer. /dev/serial/by-path sollte da sein - hab noch nie gesehen das er nicht existiert wenn das Gerät unter /dev vorhanden ist. Da legt Linux eine link du dem echten Gerät unter /dev ab. Existiert aber erst wenn das Gerät angeschlossen ist.

    Testweise einfach mal über ssh einloggen und
    ls -l /dev/serial/by-path

    Einmal ohne drucke rund dann Drucker einbinden und noch mal.

    Wenn der Link nicht entsteht sofort
    tail -200 /var/log/syslog
    aufrufen und sehen ob da was steht was schief gegangen ist.
  • danke schonmal für die Antwort. Mit dem syslog kann ich aber nichts anfangen.
    USB0 ist der Drucker, den ich gerade angeschlossen habe: ls /dev/serial/by-id hat keine neuen Eintrag: (Die Raspi Installtion ist übrigens da 1.04 Image auf Raspberry 4)
    Jun  6 11:17:14 RepetierServer systemd[1]: Starting Time & Date Service...
    Jun  6 11:17:14 RepetierServer dbus-daemon[426]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jun  6 11:17:14 RepetierServer systemd[1]: Started Time & Date Service.
    Jun  6 11:17:43 RepetierServer kernel: [10878.742423] usb 1-1.1: new full-speed USB device number 9 using xhci_hcd
    Jun  6 11:17:43 RepetierServer kernel: [10878.888675] usb 1-1.1: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
    Jun  6 11:17:43 RepetierServer kernel: [10878.888693] usb 1-1.1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    Jun  6 11:17:43 RepetierServer kernel: [10878.888709] usb 1-1.1: Product: USB Serial
    Jun  6 11:17:43 RepetierServer kernel: [10878.899574] ch341 1-1.1:1.0: ch341-uart converter detected
    Jun  6 11:17:43 RepetierServer kernel: [10878.906911] usb 1-1.1: ch341-uart converter now attached to ttyUSB0
    Jun  6 11:17:43 RepetierServer mtp-probe: checking bus 1, device 9: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1"
    Jun  6 11:17:43 RepetierServer mtp-probe: bus: 1, device: 9 was not an MTP device
    Jun  6 11:17:43 RepetierServer mtp-probe: checking bus 1, device 9: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1"
    Jun  6 11:17:43 RepetierServer mtp-probe: bus: 1, device: 9 was not an MTP device
    Jun  6 11:17:44 RepetierServer systemd[1]: systemd-timedated.service: Succeeded.

    Ich hoffe auf Erleuchtung...

  • Wenn beide den gleichen chip haben kann es sein das by-id identisch ist für beide Drucker. In dem Fall würde nur /dev/serial/by-path unterschiedliche Einträge haben. Werd das nachher noch mal an einem Drucker mit gleichem chipsatz testen, ob der bei mir die Einträge erzeugt (by-id/by-path). Wäre eine Erklärung wenn der Treiber selbst die links erzeugt. Dann müsste man vermutlich mit eigenen udev Regeln einen Link erzeugen.

    Ansonsten ist im syslog nichts schlimmes zu erkennen. Er erwähnt keine links aber auch keine Fehler beim erzeugen.
  • edited June 7
    In by-path stehen nur die beiden Kameras.

    Wäre auch eine gewagte Theorie und würde eigentlich bedeuteten, dass man kann keine 2 identischen Drucker anschließen könnte, wenn man sie unterscheiden will.
  • > In by-path stehen nur die beiden Kameras.
    Nein, dann bist du im valschen Verzeichnis. /dev/v4l/by-path ist wo die kameras by path erscheinen denke ich.
    Drucker erscheinen unter /dev/serial/by-path - bin aber bald bei meinem Drucker zum testen.
  • Also bei mir sind die links da. Hier die tests aus dem ssh verlauf:

    pi@pi48-anycubic:~ $ lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 006: ID 214b:7250
    Bus 001 Device 005: ID 2c99:0002
    Bus 001 Device 004: ID 046d:0826 Logitech, Inc. HD Webcam C525
    Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    pi@pi48-anycubic:~ $ ls /dev/ttyUSB0
    /dev/ttyUSB0
    pi@pi48-anycubic:~ $ ls -l /dev/serial/by-path/
    total 0
    lrwxrwxrwx 1 root root 13 Apr  2 07:17 platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.1:1.0-port0 -> ../../ttyUSB0
    lrwxrwxrwx 1 root root 13 Apr  2 07:17 platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.3:1.0 -> ../../ttyACM0
    pi@pi48-anycubic:~ $ ls -l /dev/serial/by-id
    total 0
    lrwxrwxrwx 1 root root 13 Apr  2 07:17 usb-1a86_USB_Serial-if00-port0 -> ../../ttyUSB0
    lrwxrwxrwx 1 root root 13 Apr  2 07:17 usb-Prusa_Research__prusa3d.com__Original_Prusa_i3_MK3_CZPX3018X004XK75806-if00 -> ../../ttyACM0

  • Das ist ja schön, nur wie soll mir das weiter helfen?

    lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

    Bus 001 Device 005: ID 046d:0823 Logitech, Inc. HD Webcam B910

    Bus 001 Device 007: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

    Bus 001 Device 004: ID 046d:0823 Logitech, Inc. HD Webcam B910

    Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    ls /dev/serial/by-id

    usb-1a86_USB_Serial-if00-port0

    ls /dev/serial/by-path

    platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.1:1.0-port0

    platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.3:1.0-port0

  • lsusb zeigt du hast 2 identische serielle adapter. Ich sehe beide haben die gleiche ID, aber genau wie ich die ganze Zeit sage hast du 2 unterschiedliche Namen in /dev/serial/by-path also kannst du die statt usb0/1 wählen und alles ist gut. Mit
    ls -l /dev/serial/by-path
    siehst du sogar das sie die beiden ttyUSBx verlinken.
  • Danke für Deine Geduld. Ich war etwas begriffsstutzig, sorry.
Sign In or Register to comment.