Ungewollter Druckertausch im Repetier Server

Hallo zusammen,
da ich nun auch diverse Probleme bei der Einrichtung habe, möchte ich hier mal nachfragen, ob jemand eine Lösung für mein Problem hat. Zunächst mal mein Setup:
- Raspberry Pi Vers. 4 B
- Repetier Server Pro V 1.0.4
- 3 Drucker (Ender 3 V2, Ender 5, Ender CR.6 SE)
- 1 USB Hub
- 3 Webcams, die am Hub angeschlossen werden.

Ziel ist es natürlich, über den Pi und Repetier alle 3 Drucker  zu steuern. Pro Drucker ist eine Webcam vorgesehen.

Grundsätzlich ist die Einrichtung einfach und funktioniere auch völlig problemlos. Der Pi verfügt über 4 USB Abschlüsse, davon sind 3 mit den Druckern belegt. Der 4. bekommt den Hub, an diesem werden die Kameras angeschlossen.

Im Repetier Server sind die USB Ports 0-2 den Druckern zugewiesen und die Cams lassen sich auch den einzelnen Druckern zuweisen.

Soweit, so gut.
Jetzt zum Problem. Irgendwann, keine Ahnung wann oder wieso, tauschen die Drucker.
Wenn ich also dem CR6 einen Druckauftrag gebe, startet der Ender 5 und umgekehrt. Manchmal (ich habe schon mehrfach neu installiert) ist auch alles durcheinander. Druckauftrag an den 3er, der 5er startet, Druckauftrag an den 5er, der 6er läuft, Druckauftrag an den 6er, der 5er geht. Die Kameras zeigen übrigens dann auch immer jeweils andere Drucker.
Die USB Ports werden in den Einstellungen genauso angezeigt, wie ich sie ursprünglich eingerichtet hatte. Hier hat sich offenbar nichts verändert.

Was habe ich bisher versucht?
- Ich habe also mehrfach die SD Karte komplett neu eingerichtet. 
- Ich habe mal alles ohne Kameras laufen lassen
- Über Putty die Einstellung im Raspi geprüft (sudo raspi-config), aber nichts gefunden

Meine erste Idee war ja, dass das mit den Cams zusammenhängt. Die kann ich aber mittlerweile ausschließen.


Wer hat hier noch Ideen. Hat jemand dieses Problem schon mal gehabt.

Welche Infos werden noch benötigt.

Vielen Dank für Eure Unterstützung!!

Gruß,

Ufti

Comments

  • Wie fangen die ports an? Sie müssen mit /dev/serial/by-path anfangen, so dass es wichtig ist wo sie verbunden sind (welcher usb port). Insbesonders direkt in /dev hängen die Namen von der Reihenfolge des Erkennens durch linux ab und sind somit etwas zufällig.
  • Hallo und vielen Dank für die Antwort.
    Die Ports heißen bei mir "/dev/ttyUSB0" bis "/dev/ttyUSB2" Das erschien mir am logischsten.
    Wenn es aber an den "by-path"-Ports hängen soll, werde ich das nachher mal testen.
    Ich melde mich, sobal ich was genaueres weiß.
  • ttyUSB0 ist einfach der erste der gesehen wird. Da ist das vertauschen normal. Also genau das Problem.
  • Hallo,
    also, tatsächlich scheint das Problem behoben zu sein.
    Ich habe zwar erst mit 2 Druckern getestet, da der 3er noch in einem größeren Druck (manuell gesteuert) ist, aber sieht gut aus. Beide Drucker mit Kamera funktionieren.
    Wenn der 3er implementiert wird (also morgen) kann ich nochmal ein kurzes Update geben.
    Manchmal ist die Lösung doch so einfach... :)
    ...und man sieht den Wald vor lauter Bäumen nicht.

    Nun denn, vielen Dank für die Hilfe.

    Gruß,

    Ufti

  • Hallo wir haben das gleiche Problem mit dem MegaX und dem Artillery X1 v.4 wie Uftilani

    Wir haben auch schon das alles versucht es geht ein zeitlang gut aber dann werden die Drucker wieder vertauscht.
    meistens passiert das wenn man alles ausschaltet und neu startet dann finden Rasperie Server die Zuordnungen nicht mehr. Die Ports heißen bei mir auch "/dev/ttyUSB0" bis "/dev/ttyUSB2" aber wie gesagt muss den Pi und die Drucker ausschalten und wieder neu starten dann taucht das Problem auf. Arbeiten wir nur mit einem Drucker und haben den einen ausgeschaltet dann funktioniert  alles. Das zweite Problem das wir noch haben, liegt bei der W-Lan Verbindung da haben wir auch schon alles verucht manchmal ist die W-Lan Verbindung stabiel und dann reist Sie einfach wieder ab obwohl der Router 2m neben dem Rasperie Pi steht. Mann muss dann in den Einstellungen mehrmals auf Verbinden klicken manchmal 3 bis 4 mal und dann ist er wieder verbunden.

    MFG
    R.Thome



  • Bei den Druckern als port wie oben erwähnt /dev/serial/by-path verwenden, dann ist wichtig in welchem usb port sie sind und nicht die reihenfolge des Einschaltens.

    Bei neueren images kann man wpa supplicant auch explizit vorgeben und muss nicht mehr unsere Steuerung nutzen. Manchmal hilft es auch AP auf nie zu setzen, dann wechselt er nicht in den AP modus wenn er glaubt nicht verbunden zu sein. Insbesondere wenn man ein display hat kann man das gefahrlos machen ohne angst zu haben sich auszuschließen.
Sign In or Register to comment.