Install problem. WLAN does not connect


This is my problem: After installing OS and Repetier image WLAN does not connect!

My system:
   Rasberry Pi 4B with offical 7" touch screen
   Speedport router
   Laptop running Win 10
  1. Image download from web site and flashed to SD card
  2. Set "LCD-Rotate=2"
  3. Boot Rasberry--> OK
  4. Wlan(speedport)router is visible to the setup.
  5. Set up WLAN according to Documentation
  6. Try to connect-->FAIL

  7. Connect with LAN cable ---> OK
  8. Laptop to Pi with Repetier server---OK
  9. Repetier server wlan settings applied. Still no wlan connect!

I have read ALL the documentation and tried the various suggested manual install routines with no
success! I have also watched varois videos where it all looks so easy!!!!!!

As I can install the Rasbian OS with touch screen, where wlan works without problems,
I would like then to  install the Repetier software separately on to  the Pi.
However I am not sure how to do this.
Any instructions would be very helpfull.

  Deutsch kann ich gut Lesen, aber Schreiben...........deshalb English;-)


  • Have you set country to german? If your route ruses channel 12 or 13 it will not work with default country which does not allow these channels.
    In latest image you can place a wpa supplicant version that you use on normal pi, see this gets copied for linux and server disables active modification. Should be easier and image is basen on latest rasbian os, so should work as good.

    Otherwise with
    sudo dpkg -i RepetierServerLatest.deb
    rm RepetierServerLatest.deb

    you can also install it on original raspbian but without preconfigured webcam/touch screen/usb stick support scrips.
  • Moin
    Thanks for the answer "trotz" weekend!
    1. Yes, Country is set to "DE".
    1a. Also with the OS + Rep.Server v25 image the touch screen is a bit "trager".
         In case its a power issue I have ordered a 5v 3amp power unit.
    2.  I have tried a ".deb" image install which works but is possibly not the "Latest" image.
    3. I shall now try this complete new install with "Latest" image.
    4. My goal is to have the "console" user interface ( as seen on the Phillips videos) directly on boot and a connection
           to my laptop for monitoring (as shown in your diagrams in the RepetierServer docs).
    5. However, I shall also try the WEB interface, which has all the functions, but seems to be a bit more complicated.
    6. I am also working my way through the "Booting into Touchscreen Mode for Linux" docu.

    I shall report back my progress.

  • 1a. Watch the bolt icon in our gui. As long a sit says undervoltage: never you are good from power side. Important is not to use a 3a usb charger but a 3a power unit. Chargers are not required to hold voltage as stable as pi would like it.
  • Thanks for the info.
    I have ordered an original power supply for the Rasberry.
    Let's see what happens!
  • Moin Moin
    indeed the lightning bolt shows "never". So I've now got two power supplies!!

    And now to my problem....
         All original Rasberry. Pi 4B + 7" Touchscreen.
         Repetier Pi OS + Repetier-Server image V25 1.0.4
    Software ammendments:
         "config.txt" amended for 180° screen turn.
         AND "wpa-supplicant-wlan0.conf" changed with
         " ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
           } " 
          I got a "console" light with an unresponsive touchscreen and little ability to
          configure the wlan with no connection!!
          After reading a lot of documentation ( F&Q, youtube, and your own doku's, etc)
          with no success I finally had the idea to look at the startup scripts from Rasbian OS.
          In the wpa-supplicant-wlan0.conf I found this line and added it after"psk"

           Total success!!!

    Either I didn't see it in the doku or because of the touchscreen problems I couldn't see
    it in the minimal console menu.

    Anyway perhaps it should be included in the offical docu.

    So, never the less, many thanks for the info.




  • I think I add it in the sample config. It is the default for most anyway and it is easy to change if you think your router can not handle it.
  • Moin
    Well, I couldn't see/find it anywhere, and after I got everything working I rechecked to see if
    I had missed it. Still can't find it but now I know its easy;-),
    I'ts probably just a "fluke" of my system but perhaps it should be mentioned in your docu abot WLAN being "complex". Anyway, as I wrote, every thing is working quite well now so I'll probably upgrade to the Pro version!
Sign In or Register to comment.