Connect to PRUSA Mini

Hi guys,

can you confirm that Repetier Server can connect to the PRUSA Mini, as it is running Marlin 2.0, or is thsi unclear?




  • We have ordered one to test, but Marlin 2 should be no problem. From what I saw it seems to still have a usb port to connect to firmware.
  • Unfortunately, it doesn't seem to be fully compatible. The display on the printer does not notice when you start printing from Repetier, moreover the printer keeps pausing for a few seconds and then continues printing or fails completely.
    Maybe just wrong settings, but since it is not 100% Marlin firmware the problem could be there.

  • Since display is controlled by printer firmware it might not show everything we want - depends on implementation. But all the new stuff is why we ordered one for testing and optimizing. Maybe we need to add a new firmware type to get it running. Will see when it arrives.
  • Any progress on this one?
  • We are waiting for the printer. Contacted prusa last week and they promised to speed up delivery, so hope it comes soon for testing. If you can provide a full log around a problem you experience we might be able to help earlier.
  • Ok, guys, we now have a prusa mini thank to Prusa customer service they send it earlier. I'm currently on my second test print but no problems so far. Only problem was a crash of display it self which seems due to having the web page of printer open. In 4.0.3 they therefore removed ethernet connection completely. 

    Naturally there is no extra info on the display - that is controlled by the firmware and has no status line any more. There is also no progress info when printing over usb. That is a decision of prusa/marlin so nothing we can do about that. But the important fact is that it is printing without any problems from server connected to usb.

    If you experience any problems I did not see so far, please provide a log around the problem time and describe what happened.
  • Hey, if I read it above correct the mini should work with repetier?

    My setup: Rasperry Pi 4, with Repetier Server Pro 0.93.1 , Prusa mini with FW 4.1.0 final.

    The printer is shown as green in repetier. But if I try to do anything (as test change the bed temp) nothing happen on the printer.

    What are the correct settings?
    Did somebody has a configuration file for me which I can try?

    Not sure what I should change that it works for me.
    Thank you for support in advantage.
  • This is a prusa mini config I had used successfully:

  • Repetier said:
    This is a prusa mini config I had used successfully:

    Thank you very much.

    First print is running :). Until now it looks good.
  • Any idea why the Mini does not come up with a possible port to select in Repetier? 
    I used a USB A to USB A Cable to connect the Mini to my PI
  • Wrong port. USB A on prusa mini is to connect a usb stick to print files on it. There is a regular usb connection for serial connection. Not sure if mini or the big variant.
  • Wie schließe ich den Mini denn an? Was für ein Kabel brauche ich dafür? Reicht ein Samsung Ladekabel?
  • Normales usb micro Kabel. Alle 4 Kontakte werden benötigt, aber denke die meisten Ladekabel haben auch die Datenkontakte.
  • When you print on the Mini using OctoPrint, it displays a big Octopus on the Mini's LCD screen and adjust the available menu items accordingly. Is this something that's done on Prusa's site or do you plan to have something similar done with Repetier Server as well? Currently, when I print from Repetier Server, the LCD items remain as if no print was running at all so when I want to tune Z (for example) I have to go through a number of menu items (by which time the skirt it printed so have to live Z on first layer instead). Cheers.
  • Not that great that they assume octoprint is the only host here. But that is build in the prusa mini, so nothing we can change. But I think the octo icon is visible during print as well. The printer is in th eothe roffice so can't backcheck but I know I've seen it printing with server.
  • Right. They only just added Repetier Server support to their PrusaSlicer so fingers crossed they'll go the extra mile and update the firmware for it as well :) 
  • hi, i have a problem with prusa mini..the printer keeps pausing and commands cannot be sent via repetier.All prints fail!
    I have raspberry pi3 and prusa mini with last official firmware.
  • The prusa mini has in deed a problem I already send to them. At the moment there is only one way to get it working reliable and that is to enable ping pong mode. When you get problems you must hit reset on the prusa mini to get it's serial handling in line again. When it gets more then one command at once it is easy to confuse. In ping pong mode we already have printed over 100h without any problems while without ping pong it happens on regular basis.
  • Just following up on this. What connection are you guys using to between the mini and the pi? I tried using the mini-usb and repetier could not find it through serial connection. Also tried using the IP address and repetier would not connect that way either.
  • You need usb connection with ping-pong enabled for the prusa mini.
  • Is it possible to connect the mini with tcp/ip? It always says that the printer is offline? Which port to I need?
  • We only know about the web interface (port 80). A put through channel is not known to exist, but would be required to work.
Sign In or Register to comment.